We help IT Professionals succeed at work.

Error 14 initializing SQL*Plus

chalie001
chalie001 asked
on
388 Views
Last Modified: 2018-02-02
hi am geting this error when starting my oracle database am in window 7 i did the following

C:\Users\rdp>SQLPLUS /NOLOG

SQL*Plus: Release 11.1.0.7.0 - Production on Sun Apr 16 08:29:03 2017

Copyright (c) 1982, 2008, Oracle.  All rights reserved.

SQL> CONNECT /AS SYSDBA
ERROR:
ORA-12560: TNS:protocol adapter error


SQL> HOST
Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

C:\Users\rdp>SET ORACLE_HOME=C:\app\oracle\product\12.1.0\dbhome_1

C:\Users\rdp>SQLPLUS /NOLOG
Error 14 initializing SQL*Plus
Message file sp1<lang>.msb not found
SP2-0750: You may need to set ORACLE_HOME to your Oracle software directory

C:\Users\rdp>cd ..

C:\Users>cd ..

C:\>set
ALLUSERSPROFILE=C:\ProgramData
APPDATA=C:\Users\rdp\AppData\Roaming
CLIENTNAME=DESMAND-PC
CommonProgramFiles=C:\Program Files\Common Files
CommonProgramFiles(x86)=C:\Program Files (x86)\Common Files
CommonProgramW6432=C:\Program Files\Common Files
COMPUTERNAME=VMWIN7-PC
ComSpec=C:\Windows\system32\cmd.exe
FORMS_USERNAME_CASESENSITIVE=1
FP_NO_HOST_CHECK=NO
HOMEDRIVE=C:
HOMEPATH=\Users\rdp
JAVA_HOME=C:\Program Files\Java\jdk1.6.0_45
LD_LIBRARY_PATH=C:\Oracle\Middleware\FRHome\lib
LOCALAPPDATA=C:\Users\rdp\AppData\Local
LOGONSERVER=\\VMWIN7-PC
NUMBER_OF_PROCESSORS=4
ORACLE_HOME=C:\app\oracle\product\12.1.0\dbhome_1
OS=Windows_NT
Path=C:\Oracle\Middleware\FRHome\jdk\bin;C:\Oracle\Middleware\FRHome\bin;C:\app\
oracle\product\12.1.0\dbhome_2\bin;C:\app\oracle\product\12.1.0\dbhome_1\bin;C:\
Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\Windows
PowerShell\v1.0\;C:\oracle\Middleware\forms;C:\oracle\Middleware\bin;C:\Program
Files\Java\jre7\bin;C:\javajdk\jdk1.7.0_79\bin;C:\Oracle\Middleware\FRHome\opmn\
bin;C:\Oracle\Middleware\FRHome\opmn\lib;C:\Oracle\Middleware\FRHome\perl\bin;C:
\jre\bin;C:\app\oracle\jdk;
PATHEXT=.COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH;.MSC
PROCESSOR_ARCHITECTURE=AMD64
PROCESSOR_IDENTIFIER=Intel64 Family 6 Model 94 Stepping 3, GenuineIntel
PROCESSOR_LEVEL=6
PROCESSOR_REVISION=5e03
ProgramData=C:\ProgramData
ProgramFiles=C:\Program Files
ProgramFiles(x86)=C:\Program Files (x86)
ProgramW6432=C:\Program Files
PROMPT=$P$G
PSModulePath=C:\Windows\system32\WindowsPowerShell\v1.0\Modules\
PUBLIC=C:\Users\Public
SESSIONNAME=RDP-Tcp#0
SystemDrive=C:
SystemRoot=C:\Windows
TEMP=C:\Users\rdp\AppData\Local\Temp
TMP=C:\Users\rdp\AppData\Local\Temp
USERDOMAIN=VMWin7-PC
USERNAME=rdp
USERPROFILE=C:\Users\rdp
windir=C:\Windows
windows_tracing_flags=3
windows_tracing_logfile=C:\BVTBin\Tests\installpackage\csilogfile.log

C:\>set ORACLE_HOME=C:\app\oracle\product\12.1.0\dbhome_1

C:\>SQLPLUS /NOLOG
Error 14 initializing SQL*Plus
Message file sp1<lang>.msb not found
SP2-0750: You may need to set ORACLE_HOME to your Oracle software directory
Comment
Watch Question

David VanZandtSr Software Engineer
CERTIFIED EXPERT

Commented:
The first error, ORA-12560, appears related to your syntax, missing a space after the slash.

You set the ORACLE_HOME from within the shelled environment (meaning you pushed into DOS command line while SQLPLUS remains open. On previous versions that used to fail for me, as it wasn't changing the environment variable globally. I would try setting the variable prior to executing sqlplus.

BTW your PATH includes two ORACLE_HOMEs, dbhome_1 and dbhome_2.  Remove the inappropriate one, and look into using the .oraenv function to set the values based upon your SID choice from the oratab file. Easily explained elsewhere on this site.

Try to cd $ORACLE_HOME\bin, then to execute sqlplus /log from it without using the search path.

Do a web search on the error code shown, as in "oracle sp2-0750". Some of the articles suggest you have corrupted your .OraInventory file.

HTH,
dvz
CERTIFIED EXPERT
Most Valuable Expert 2012
Distinguished Expert 2019
Commented:
Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION
David VanZandtSr Software Engineer
CERTIFIED EXPERT

Commented:
Charlee, can we be of any further help on this?

Author

Commented:
was running sqpl plus from diffirent path

Gain unlimited access to on-demand training courses with an Experts Exchange subscription.

Get Access
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Empower Your Career
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE

Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a sample view!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.