We help IT Professionals succeed at work.

WDS can't PXE boot

jean paul
jean paul asked
on
701 Views
1 Endorsement
Last Modified: 2017-04-16
Hi, I'm trying to configure a wds server to allow PC to pxe boot. I configured wds and everything needed and this is working ... when the dhcp is on the wds server and everything is on the same subnet.
But I don't have the dhcp on the wds server, the dhcp is on a router.

I've used GNS3 to try to understand it better, here is the topologie simplified, not exactly this in my network(I mean there is more devices) :
 Topologie
On the router I only configured a dhcp server ( in GNS3), here is the config :
ip dhcp pool test
   network 192.168.227.0 255.255.255.0
   default-router 192.168.227.5
   option 66 ascii 192.168.130.5
   option 67 ascii /boot/x64/wdsnbp

Open in new window


I tried to add the option 150 too "option 150 ip 192.168.130.5", but not doing anything.

On my WDS server, I unchecked the two checkbox for DHCP "Don't listen on dhcp port " and "Configure the dhcp option to indicate that this server is also a Pxe server" and the server is answering to everybody(known and unknown client). I tried too to just check the second box "this server is also a pxe server".

On wireshark between the router and the Pxe client here is what I have :
Wireshark
Without options 66 and 67 the router answer with his DHCP Offer but the Pxe Client don't accept it so he resend a Discover, and with those options the DHCP works fine. But then my problem is after when TFTP comes, the Pxe client send his tftp packets to the router and not my wds server, so obviously the router say "port unreachable" because is not a TFTP server.

I discovered too that the Router in the DHCP Offer don't send the option 66 :
DHCP Offer not option 66
My WDS Server don't receive any traffic, from the DHCP Discover to the TFTP.

And on my Pxe client :
Pxe client
Should I just add a port-forwarding line in my router to say that traffic to port 69 should be forwarded to the wds server ?
Why my router is not forwarding anything from the pxe client to my wds server ?

So as I said the settings of my wds server are fine because it worked if the DHCP is on the wds server.

Thanks
Comment
Watch Question

CERTIFIED EXPERT
Distinguished Expert 2018
Commented:
Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION

Author

Commented:
Well thank you very much for your reply, I added "next-server 192.168.130.5" and the tftp request started to be forwarded to the wds server.
I needed to add a gateway on the wds server too, because the wds server wasn't answering and after it I got the error "access violation ..." so I had to change the option 67 on the router "option 67 ascii \boot\x64\wdsnbp.com" and not "/boot/x64/wdsnbp.com", slash and backslash...

But thank you !
CERTIFIED EXPERT
Distinguished Expert 2018

Commented:
You're welcome.
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a sample view!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.