troubleshooting Question

Exchange Database fails to mount

Avatar of sglee
sglee asked on
18 Comments2 Solutions1126 ViewsLast Modified:
 I have SBS2011/Exchange 2010 Server  that lost power and the server was turned off.
 When it came back on, the exchange database failed to mount (although public database was mounted).
(1) When I ran ESEUTIL /MH “Mailbox Database.edb”, it showed "State: Dirty Shutdown".
(2) When I ran ESEUTIL /G "Mailbox Database.edb", it said "Checking database integrity.

The database is not up-to-date. This operation may find that this database is corrupt because data from the log files has yet to be placed in the database. To ensure the database is up-to-date please use the 'Recovery' operation. Operation terminated with error -550 (JET_errDatabaseDirtyShutdown, Database was not shutdown cleanly. Recovery must first be run to properly complete database operations for the previous shutdown.)

(3) When I ran Eseutil /ml “C:\Program Files\Microsoft\Exchange Server\V14\Mailbox\Mailbox Database\e00”,
 it said "No damaged log files were found."
(4) When I ran ESEUTIL /r E00 /l “C:\Program Files\Microsoft\Exchange Server\V14\Mailbox\Mailbox Database” /d “C:\Program Files\Microsoft\Exchange Server\V14\Mailbox\Mailbox Database”, I got:

Initiating RECOVERY mode...
    Logfile base name: E00
            Log files: C:\Program Files\Microsoft\Exchange Server\V14\Mailbox\Mailbox Database
         System files: <current directory>
   Database Directory: C:\Program Files\Microsoft\Exchange Server\V14\Mailbox\Mailbox Database

Performing soft recovery...
                      Restore Status (% complete)

          0    10   20   30   40   50   60   70   80   90  100
Operation terminated with error -1019 (JET_errPageNotInitialized, Blank database page) after 3.625 seconds.

(5) When I ran ESEUTIL /p “C:\Program Files\Microsoft\Exchange Server\V14\Mailbox\Mailbox Database”,  I get the following error.

Operation terminated with error -1032 (JET_errFileAccessDenied, Cannot access file, the file is locked or in use) after 20.32 seconds.

(6) I rebooted the server a couple of times, but to no avail.

I googled the subject "Cannot access file, the file is locked or in use" and found this:

1.  Recycle the Information Store Services
2.  Make the disk hosting the database offline from diskmanagement.msc and then bring it on line . This would release the lock on the database
 3. Verify if the database is in cleanshutdown state (eseutil /mh databasename). If the database is in dirty 4. shutdown state, run eseutil /r E01(Log file prefix) /l logfile path to replay the log files and make sure the database is in clean shutdown state
5. Mount-database <databasename> if the mount fails Proceed step 5
 6. Disable/Uninstall the antivirus on the server / Verify the AV exclusions
7. hange the log folder name and try mounting the database
8.  If you are not able to change log folder name, Download Procmon and check process locking the log file path
9.  Change the Database Log folder Path and try mounting the database
10. Reboot the server

I am not sure if I should follow the tips above. Can you help?
Ranjithkumar Rajangam

Our community of experts have been thoroughly vetted for their expertise and industry experience.

Join our community to see this answer!
Unlock 2 Answers and 18 Comments.
Start Free Trial
Learn from the best

Network and collaborate with thousands of CTOs, CISOs, and IT Pros rooting for you and your success.

Andrew Hancock - VMware vExpert
See if this solution works for you by signing up for a 7 day free trial.
Unlock 2 Answers and 18 Comments.
Try for 7 days

”The time we save is the biggest benefit of E-E to our team. What could take multiple guys 2 hours or more each to find is accessed in around 15 minutes on Experts Exchange.

-Mike Kapnisakis, Warner Bros