Outlook & Word 2016 - Emoji in AutoCorrect screwed up

Andrew Leniart
Andrew Leniart used Ask the Experts™
on
Hi,

After a recent update to Office 2016 ( via Office 365 Subscription ), all of the standard Emoji Auto Correct Options that worked perfectly before the update have been screwed up and just turn into a square when used now.  Ie: :) :( etc.  See example below..

:-) turns into a square instead of a smiley face, as does :-( or :-D or :-o etc..

Emoji Fail Example Snapshot
A Repair of Office 365 (both offline and online) didn't help, nor did uninstalling and then downloading and reinstalling from scratch.

Anyone know of an easy way of fixing this problem?

Thanks..
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
WadskiIT Director

Commented:
Sorry for cheating but this link has loads of different solutions to this problem - I suggest you check here:

http://itgroove.net/oh365eh/2017/02/25/when-smiley-face-symbol-auto-corrects-to-square-outlook-2016/
Andrew LeniartIT Professional | Freelance Journalist | Looking for Opportunities
Distinguished Expert 2018

Author

Commented:
Thanks Wadski, but that link didn't really help.  It basically suggests replacing every emoji entry manually to fix the problem. Surely there must be an easier way like restoring a file before the update or similar?

Here's a snapshot of my Auto Correct Options.

Auto Correct Options Snapshot
Any other ideas?
WadskiIT Director

Commented:
Autocorrect lists are stored here: %AppData%\Microsoft\Office


Close all office apps, backup your original copy and copy a colleagues over and see if that corrects them for you.

Ensure permissions etc are correct before trying it otherwise it may come up blank.
Ensure you’re charging the right price for your IT

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Andrew LeniartIT Professional | Freelance Journalist | Looking for Opportunities
Distinguished Expert 2018

Author

Commented:
Hi Wadski,

Did as you suggested, except I I used one of my backups (I use Acronis to create incremental backups twice a day) from before the update. No joy. So I went back all the way to a full backup I did on 29/12/2016 - still no go. The problem remains.

I replaced all MSO*.acl files in the C:\Users\MyUserName\AppData\Roaming\Microsoft\Office folder but it didn't make any difference at all.

Do you (or anyone else) have any other ideas?
Andrew LeniartIT Professional | Freelance Journalist | Looking for Opportunities
Distinguished Expert 2018

Author

Commented:
Update: Just spent about 4 hours with Microsoft Technical Support via live chat who I allowed to log into my machine to try and resolve the problem. 1st Technician was a level one Tech and tried everything he could think of, but couldn't figure out what was going wrong, so he escalated the problem to a Level 2 Technician and passed the remote session over to him.

The Level 2 Tech also tried to trouble shoot the issue for about an hour and a half until he finally admitted defeat and asked if it would be ok with me  if he escalated the problem to Level 3, after which he took a bunch of Trouble Shooting analysis logs using tools he uploaded to my machine, as well as a video of the problem to pass onto the Level 3 Tech's who apparently are going to study the matter and get back to me within 24 to 48 hours.

Still no solution, but pretty good support for $0.00 on Microsoft's part.

Will update here once I hear back and hopefully get a resolution from Microsoft's Level 3 technical support.

Cheers...
IT Manager
Top Expert 2010
Commented:
Try the following fix.

go to an open message > Insert > Symbols > select More Symblols > find and select the right WingDing symbol you want > click the AutoCorrect ... button in the lower left corner > The AutoCorrect dialogue box opens and, like stated in Stefan's second message below, the smiley face shows up in the "With" box and the Formatted Text is selected, add in the desired "Replace" text > Click Add > Click OK

Source: https://answers.microsoft.com/en-us/office/forum/office_2010-word/smiley-face-autocorrect/6c56051a-9380-49f3-95fa-b4e47212427c
Andrew LeniartIT Professional | Freelance Journalist | Looking for Opportunities
Distinguished Expert 2018

Author

Commented:
Further Update: Have now been contact by Microsoft Level 3 Technical Support (I wonder how many levels they have? lol)  Anyway, they suggested changing my default Language to English (United States) in Microsoft Office - The default "was" set to English (Australia) as that's where I am.

They also suggested changing the computers Region and Language default to English (United States) - Again, my setting there was set to English (Australia) as obviously, that's where I am!

Well, after further tests by Microsoft via Remote Login to my computer, that didn't make any difference (as I suspected it wouldn't, given that it worked fine for months with my previous settings!).

So next step having now changed all my defaults to English (United States) 365 was uninstalled from my computer, my machine rebooted and then 365 Re-Installed fresh from Microsoft Server and rebooted once again. Once done, further tests showed no difference whatsoever. The issue remained.

As still no joy, they are investigating the problem further and are going to phone me back again today. I will update this topic once again when I get another phone call back from Microsoft Level 3 Technical Support today. Time spent on this issue with Microsoft Support to date - approximately 8 Hours!! :)  Stay tuned..

Cheers..
Jackie Man IT Manager
Top Expert 2010

Commented:
Have you tried my fix?
Andrew LeniartIT Professional | Freelance Journalist | Looking for Opportunities
Distinguished Expert 2018

Author

Commented:
@Jackie Man: Apologies for the delayed reply, I was about to try it as I'd only just gotten off the phone with Microsoft when I posted my update.

I very much appreciate your comment and suggestion and will get back to you soon as I will try it now.
Andrew LeniartIT Professional | Freelance Journalist | Looking for Opportunities
Distinguished Expert 2018

Author

Commented:
@Jackie Man:  Your suggested solution appears to be working !!  :)

I have no idea if this is because of what Microsoft have done (I suspect not) but I've just been able to get the Wingdings :-) - :| and :-(  AutoCorrect functions working using Wingdings font set by following "your" instructions step by step.

Will advise Microsoft Level 3 Tech Support of this when they call me.

Now, would you happen to know what the other symbols in the AutoCorrect box are supposed to represent? They are:

:o
:-o
:p
:-p
;)
;-)

..or what their Alt + Key combinations are supposed to be? They don't seem to exist in the Wingdings Font Set.

Well done Jackie, you're more value than Microsoft Support! lol..
Jackie Man IT Manager
Top Expert 2010

Commented:
It is a known issue for more than 5 years and Microsoft knows it.

It will take some time for me to get the info and will update you within today.
Andrew LeniartIT Professional | Freelance Journalist | Looking for Opportunities
Distinguished Expert 2018

Author

Commented:
Many thanks Jackie.. Will be looking forward to it. I'm trying a google search myself now as well to see if I can find out what emoji's they're supposed to represent.

Much appreciate your assistance!
Jackie Man IT Manager
Top Expert 2010

Commented:
Do not waste time to search.

Mine is a working 100% OK and can get the info immediately.

I have to finish my work first and will post the update.
Andrew LeniartIT Professional | Freelance Journalist | Looking for Opportunities
Distinguished Expert 2018

Author

Commented:
Thanks very much Jackie.. Will be looking forward to your post!

:-)
Jackie Man IT Manager
Top Expert 2010

Commented:
..or what their Alt + Key combinations are supposed to be? They don't seem to exist in the Wingdings Font Set.

True... They don't seem to exist in the Wingdings Font Set, but you can define your own  Alt + Key combinations for the emoji.

Emoji in AutoCorrect screwed up
Andrew LeniartIT Professional | Freelance Journalist | Looking for Opportunities
Distinguished Expert 2018

Author

Commented:
Thanks once again Jackie.. I've already got those working perfectly, now just searching for the meanings of these other ones.. :o :-o :p :-p ;) ;-)

In Google, I've found
:o and :-o to represent a Shocked Face => 😲
:p and :-p to represent a Tongue => 😝
;) and ;-p to represent a Wink => 😉

But in Symbols, they come up as Font: (normal text) and Subset Extended Characters - Plane 1

Inserting them into AutoCorrect as per your instructions appears to work, however they don't seem to work in Word or Outlook.  Still trying to figure that one out.
Jackie Man IT Manager
Top Expert 2010

Commented:
:o and :-o
:p and :-p
;) and ;-p

The emoji above do not exist in Auto-correct entries for MS Word or MS Outlook.

But, you can define one.
Andrew LeniartIT Professional | Freelance Journalist | Looking for Opportunities
Distinguished Expert 2018

Author

Commented:
Ok, to get them in MS Word, using :-o as an example, go through the following steps..

1.  Open a new Word document and paste this symbol into your document   😲
2.  Now highlight it and from the Insert Tab, click the Symbol Down Arrow and Select More Symbols...
3.  The Symbol will come up in word as an "Astonished Face" in Font: (normal text) and Subset: Extended Characters - Plane 1
4.  Insert the symbol (add if it's not in yours) and it will add or replace perfectly.
5.  Now try to the :-o in Word Document and it doesn't turn into an emoji - just stays as :-o

Hope that's clear?  Give it a try and let me know how it went for you?
Jackie Man IT Manager
Top Expert 2010

Commented:
Your procedure is not correct.

It is much simple.

Click Insert symbol icon, select Other symbols.. in the pull down menu,, select Segoe UI Symbol and find out and select the symbol you want.

Click Autocorrect button on the lower left and a new windows will appear and type the keys for autocorrect ,like :-o and click OK.

You need to define the same autocorrecy twice for one autocorrect entry, one in MS Word and another one in MS Outlook.
Andrew LeniartIT Professional | Freelance Journalist | Looking for Opportunities
Distinguished Expert 2018

Author

Commented:
Hi Jackie, Just tried (In Outlook) your suggested way using the Segoe UI Symbol, but can only see that particular symbol "😲" if I change the "from:" field near the bottom right of the Symbol pop-up to "Unicode (hex)" rather than the other two choices which are "ASCII (decimal)" and "ASCII (hex)" - doesn't show up in the last two.

Anyway, found the symbol, clicked the AutoCorrect button on the lower left as you said and it inserted ok, though only when I selected Replace:  With:  Plain text - Formatted text wasn't an option and just showed a square (couldn't do anything in the "Formatted  text" box till I selected Plain text, where the symbol appeared as expected.  

Clicked Replace and confirmed I wanted to replace the existing entry, but it still comes up as a square when used in the email.  Same deal with Word. (That's why it took me so long to reply)

Hmmm.. Somethings still screwy?

Edit: Actually, sorry, in word, it Inserts into AutoCorrect just fine when I replace it, but just comes out as :-o when I type it in the document - doesn't turn into an emoji ?
Jackie Man IT Manager
Top Expert 2010

Commented:
I need to look into my eBook on MS Outlook before I can give you further advice.
Jackie Man IT Manager
Top Expert 2010

Commented:
Can you manually insert the symbols?

If no, font is corrupted.
Andrew LeniartIT Professional | Freelance Journalist | Looking for Opportunities
Distinguished Expert 2018

Author

Commented:
Hi Jackie,

It wasn't a corrupt font - it was the testing process.  I've figured out what I was doing wrong testing the solution (at least in so far as Word goes) and am in the process of writing up exactly how it's done.  I've yet to make sure it's exactly the same in Outlook.

For your info, your procedure was pretty much spot on, except that after you do the AutoCorrect part, you must then exit the application (Word) and Open it again for the AutoCorrect to work properly.  

When I was trying earlier, I'd go through all of your steps and the Wingdings ones worked just fine with no restart of Word,  

The Segoe UI Symbol ones however, required that I closed Word, re-opened Word before they would work correctly.

I'll post a detailed info here about both Word and Outlook once I've finished my adjustments and testing to ensure everything works.

Thanks again for your help, will get back to you.

BTW.. Still no phone call from Microsoft Level 3 support! lol..
Jackie Man IT Manager
Top Expert 2010

Commented:
Good to hear your feedback.

You should be fine.
Andrew LeniartIT Professional | Freelance Journalist | Looking for Opportunities
Distinguished Expert 2018

Author

Commented:
I wish that were so Jackie..  Everything works well in Microsoft Word 2016, but Outlook 2016 doesn't appear to accept Segoe UI Symbol font Symbols.. So the problem with Outlook persists.  

For example, when I use the Segoe UI Symbol (Character Code 1F601) for :D - all I get is a square when I try to insert it or type it into an email body.  Tried closing and reopening as with Word but makes no difference in Outlook.  Yet it works perfectly in Word?!

Guess it's back to the hunt sigh..

Just when I thought I had it all figured out too. :(
Jackie Man IT Manager
Top Expert 2010

Commented:
For the pre-existing emoji, do they work well in Outlook 2016 after the fix?
Andrew LeniartIT Professional | Freelance Journalist | Looking for Opportunities
Distinguished Expert 2018

Author

Commented:
Hi Jackie..

For the pre-existing emoji, do they work well in Outlook 2016 after the fix?

Yes, :) :( and :| (all Wingdings Symbols) work perfectly in Outlook.  Just not the others.

Still scouring the web. So much for the promised call from Level 3 tech by Microsoft - still waiting for that one.

Determined to get to the bottom of this!
Jackie Man IT Manager
Top Expert 2010

Commented:
Good.

Can you do me a favor to close this question?

It serves as a supporting evidence for my another answered question which is nearly identical to yours but the asker has abandoned it and our moderator insists that my comment is not good enough. You can ask a related question for the customized emoji autotext.

I am confident with these kinds of challenging questions.

Thanks!
Andrew LeniartIT Professional | Freelance Journalist | Looking for Opportunities
Distinguished Expert 2018

Author

Commented:
No worries.. it's getting way too long now anyway and the Word 2016 part of it is resolved (with your help of course)

Yes, I agree. I will close it and post a related question regarding the Outlook 2016 customised  issue only, as that's all I'm concentrating on at the moment.  

Hoping you'll continue to help when I've raised the Outlook only question - you appear to be very good at this and some of your comments prompted me to do some google searching which provided a bit more info.   :)
Andrew LeniartIT Professional | Freelance Journalist | Looking for Opportunities
Distinguished Expert 2018

Author

Commented:
Word 2016 Issue has been fully resolved with all of your help Jackie, so thank you very much for sharing your expertise to help me resolve that one.  Now to just work on the Outlook 2016 problem! :)
Jackie Man IT Manager
Top Expert 2010

Commented:
Good... Looking forward to your new question.

Thanks!

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial