GPO Mapped Drives - Say NTFS with a Red X

jzicari
jzicari used Ask the Experts™
on
Attempting to migrate from Login Scripts to GPO for mapped drives.  
Created the mapped drives in GPO.  
They're showing up with a red x and say NTFS.
When double clicking on them, they open fine.  
Problem is, we have apps that connect back to those drives and if they're in "disconnect" mode, Apps fail.  
Once you double click on it and then go into the App, works fine.  Not the process, obviously.

I've done the following steps.  
Registry Keys - Enable Linked Connections, SyncForegroundPolicy, GpNetworkStartTimeoutPolicyValue and DisableDHCPMediaSense.

The mapped drive is as follows:

Create
\\Servername\Shared
reconnect, label as Shared (\\Servername}
Drive Letter Use: S
Show this drive/show all drives

Domain is a 2008 R2 with 2 local DCs running dhcp and dns.
Client in Question is both Windows 7 and when in Citrix (xenapp 6.5 farm)  

At this point, i'm scratching my head.  
thanks!
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Distinguished Expert 2018

Commented:
Try changing Create to Update.

Commented:
To configure the EnableLinkedConnections registry value, follow these steps:

   
  • Click Start , type regedit in the Start Search box, and then press ENTER.
  •    Locate and then right-click the following registry subkey:
  •    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System
  •    Point to New , and then click DWORD Value .
  •    Type EnableLinkedConnections , and then press ENTER.
  •    Right-click EnableLinkedConnections , and then click Modify .
  •    In the Value data box, type 1 , and then click OK .
  •    Exit Registry Editor, and then restart the computer."

You can set this in group policy to.

Author

Commented:
@mbkitmgr already added that via GP, which it actually put in the registry.  

@masnrock changed to update, same issue.
Network drives both map but come up with red X and say NTFS.
When i click on them, they connect and are fine.
Ensure you’re charging the right price for your IT

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Distinguished Expert 2018

Commented:
It could be a timing issue of GPO processing. Try adding these registry keys to a workstation:

HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows NT\CurrentVersion\Winlogon "SyncForegroundPolicy"=dword:00000001
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon "GpNetworkStartTimeoutPolicyValue"=dword:00000019
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters "DisableDHCPMediaSense"=dword:00000001

If that works, then you could actually push that out to other machines via GPO.
Commented:
Actually ended up being something with our policies. They weren't being applied correctly because of permissions.
That's what happens when you take over for someone else.  
Thanks for the input guys!
MaheshArchitect
Distinguished Expert 2018

Commented:
run below command on file server
net config server /autodisconnect:-1

This will ensure that no disconnection of shares from server side and that should resolve the issue

Also on client machines add Keepconn registry so that client will remain connected
https://www.nextofwindows.com/how-to-fix-the-red-x-on-the-icon-of-mapped-network-drives-in-windows-7

Author

Commented:
Permissions issue w/in the policies.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial