Link to home
Start Free TrialLog in
Avatar of tabush

asked on

UPS Worldship 2017 on Windows 2008 R2 - (ET)

We run virtual desktops on Windows 2008 R2. When we try to install UPS WorldShip 2017 we get an error that "New installations of WorldShip are not permitted on Windows Server 2008....."
Previous versions of UPS Worldship arent supported anymore and dont work.

Anyone know of a way to get around this installation error and force it through?
Avatar of John
Flag of Canada image

Can you tell if this is a Server error? or a UPS install error?

System requirements are Windows 7 or higher. I think the Server 2008 kernel is the same as Vista which has been put out to pasture by Microsoft.

Have you a newer server you could try?

If nothing else, you could put a Windows 7 virtual machine on Server 2008 or run on a Windows 7 machine that users can access.
Avatar of tabush


Its a UPS install error so must be something they built into the installer to block it. I had this issue a while back with installing icloud but found a hack where you can modify one item in the .exe to allow it on windows server 2008 R2 because normally its only allowed on desktop operating systems.

I saw in a forum that it works on 2012 server but we're not ready to upgrade our whole environment to 2012 or break our current model.
I'm trying to avoid creating a windows 7 vm but yes that should work.
Avatar of John
Flag of Canada image

Link to home
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of tabush


I think 2008 R2 though is built like a windows 7. Either way UPS software doesnt like it...
Its only a few users so that might be our only option unfortunately.

I was hoping there was a registry hack or some other way to trick the installation into thinking it was a windows 7
Avatar of Shaun Vermaak
Try to run it in Compatibility Mode. You can try ACT (Application Compatibility Toolkit) too
I think 2008 R2 though is built like a windows 7  <-- Server 2008 was earlier and based on Vista.
Avatar of tabush


No luck with compatibility mode and downloaded ACT but cant figure out how to use it. Most likely i'll have to create terminal server with that app running windows 7 or 2012
Yes, the latter is what you need to do.
Thanks and I was happy to work with you.
Update the "settings.ini" file in the Worldship distribution to get around this.  Look for this section:

OS1=Windows 7,1
OS2=Windows 8
OS3=Windows 10

Simply add an "OS4" line or update one of the others.  Note that just because you add your OS in there, it does not mean that Worldship will actually work in that OK, just that the installer won't complain and kick you out.
Avatar of tabush


What's the exact syntax for 2008R2? i tried
OS4=Windows Server 2008
OS4=Windows 2008 R2
OS4=Windows 2008R2

Still getting the unsupported error
User generated image
Hmm... this has worked for me in the past when installing older versions of Worldship on server systems not explicitly listed in the *.ini file.  For example, I was installing Worldship on a Win2k3 server back then (now impossible since MS & UPS dropped XP libraries).  So, for Win2k3, the line I added was:

OS5=Windows Server 2003

I would imagine Windows 2008 server would be listed similarly.  Quick disclaimer: all of our backend (files, printers, AD, etc.) is served up by Linux now, so I don't have Windows 2008 server or anything newer available to me and cannot do any testing myself.  

The error you posted suggests that the ini file may not be the only check point anymore, but that there is something else in WorldShip blocking the install.  

But WorldShip has to get the info for the current OS somehwere, right?  So, another strategy that has sometimes worked for me is to update the values in HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion to make Windows Server 2008 look like Windows 7...

Running a strings extraction on one of the key binaries, CCC.exe, I came across this:

Software\Microsoft\Windows NT\CurrentVersion



Immediately before this were a list of old OS's, like Win95, etc--presumably all the invalid OS's.  I did not see Windows Server 2008 there (2003 was there), so there is hope.  Also, the strings extraction shows pretty obviously that Worldship is in fact looking in the registry to determine the current OS, and I would expect the installer to do the same thing.

Unfortunately, the same exercise reveals the binary loading in the run-time library MSVCR120.dll, which means UPS is using VisualStudio 2013... VisualStudio 2013 only supports Windows Server 2008 R2 x64 edition.  

So, it may well be a moot point to try to get Worldship 2017 going under Windows Server 2008.  You may be able to come across something that will let you fool the installer and get something working if you have the x64 server edition.  But you are literally at the cusp of obsolescence with Windows Server 2008, so you're at best buying yourself only a little bit of time--not sure if it is worth the effort...

For ourselves, we have a Worldship server on a VM running Windows 10 Pro (host OS is Linux, of course), and anyone that needs it gets a client install on their desktop Windows 10 box.  

Good Luck!