Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

Troubleshooting
Research
Professional Opinions
Ask a Question
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE

troubleshooting Question

srst configuration not working.

Avatar of Hadii zakaria
Hadii zakaria asked on
Voice Over IPIP Telephony
2 Comments1 Solution223 ViewsLast Modified:
Sip phones do not register to CME when connection to UCM is lost. can any one assist me.

my configs below
cts logging verbose
!
!
voice-card 0
 dspfarm
 dsp services dspfarm
!
!
!
voice service voip
 no ip address trusted authenticate
 allow-connections h323 to h323
 fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
 h323
  no h225 timeout keepalive
  call preserve
!
voice class codec 1
 codec preference 1 g729r8
 codec preference 2 g711ulaw
!
voice class h323 1
  h225 timeout setup 3
  call preserve
!
voice class custom-cptone exit
 dualtone conference
  cadence 400
!
voice class custom-cptone join
 dualtone conference
  cadence 200
!
!
!
!
voice translation-rule 1
 rule 1 /^.*/ /81\0/
!
!
voice translation-profile 81code
 translate called 1
!
!
!
license udi pid CISCO2911/K9 sn FGL204110KH
hw-module pvdm 0/0
!
!
!
!
redundancy
!
no cdp run
!
ip tcp synwait-time 10
ip tftp source-interface GigabitEthernet0/0
ip ssh time-out 60
ip ssh authentication-retries 2
ip ssh version 1
!
!
!
!
interface Loopback0
 ip address 172.25.12.5 255.255.255.252
 no ip redirects
 no ip unreachables
 no ip proxy-arp
!
interface Embedded-Service-Engine0/0
 no ip address
 shutdown
!
interface GigabitEthernet0/0
 description Suam-suame Link to Radio
 no ip address
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip flow ingress
 ip virtual-reassembly in
 duplex auto
 speed auto
 no cdp enable
no shut
!
interface GigabitEthernet0/0.35
 encapsulation dot1Q 55
 ip address 172.31.10.212 255.255.255.0
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip flow ingress
 ip virtual-reassembly in
 no cdp enable

!
interface GigabitEthernet0/1
 description Suam-suame Connection to ASA
 ip address 172.25.12.2 255.255.255.252
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip flow ingress
 duplex auto
 speed auto
 no cdp enable
 h323-gateway voip bind srcaddr 172.25.12.2
!
interface GigabitEthernet0/2
 no ip address
 duplex auto
 speed auto
!
!
router eigrp 100
 network 172.25.0.0
 network 172.31.0.0
 redistribute static
 eigrp stub connected static
 no eigrp log-neighbor-changes
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
ip flow-export source Loopback0
ip flow-export version 9
ip flow-export destination 172.16.7.133 9996
!
ip route 172.20.12.0 255.255.255.0 172.25.12.1
ip route 172.25.12.8 255.255.255.248 172.25.12.1
ip route 172.26.12.0 255.255.255.0 172.25.12.1
ip tacacs source-interface GigabitEthernet0/1
!
logging trap debugging
!
!
!
!
control-plane
!
!
voice-port 0/0/0
 supervisory disconnect dualtone mid-call
 cptone GH
 timeouts call-disconnect 5
 connection plar opx 4102
 description ##Manager Line conn mngr pstn line to this port##
 caller-id enable
!
voice-port 0/0/1
 supervisory disconnect dualtone mid-call
 cptone GH
 timeouts call-disconnect 5
 connection plar opx 4201
 description ## Front Desk / User Line##
 caller-id enable
!
voice-port 0/0/2
 supervisory disconnect dualtone mid-call
 cptone GH
 timeouts call-disconnect 5
 connection plar opx 4201
 description ##Front Desk / User Line##
 caller-id enable
!
voice-port 0/0/3
 supervisory disconnect dualtone mid-call
 cptone GH
 timeouts call-disconnect 5
 connection plar opx 4201
 description ## Front Desk / User Line##
 caller-id enable
 !
 !
 !
 !
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
sccp local GigabitEthernet0/1
sccp ccm 172.16.7.244 identifier 2 version 7.0
sccp ccm 172.16.7.243 identifier 1 version 7.0
sccp ccm 172.25.12.254 identifier 3 version 7.0
sccp ip precedence 3
sccp
!
sccp ccm group 1
 bind interface GigabitEthernet0/1
 associate ccm 1 priority 1
 associate ccm 2 priority 2
 associate ccm 3 priority 3
 associate profile 1 register PTB_HW_CFB
 keepalive retries 1
 keepalive timeout 20
 switchover method immediate
 switchback method immediate
 switchback interval 15
 signaling dscp af31
!
ccm-manager music-on-hold
!
!
dspfarm profile 1 conference  
 codec g729br8
 codec g729r8
 codec g729abr8
 codec g729ar8
 codec g711alaw
 codec g711ulaw
 maximum sessions 2
 conference-join custom-cptone join
 conference-leave custom-cptone exit
 associate application SCCP
!
dial-peer voice 81 voip
 description ##PSTN code translation for outbound line selection##
 translation-profile incoming 81code
 answer-address 4102
 dtmf-relay h245-alphanumeric
!
dial-peer voice 190 pots
 description ##Emergency Calls##
 destination-pattern 91..$
 port 0/0/1
 forward-digits 3
 !
dial-peer voice 191 pots
 description ##Emergency Calls##
 preference 1
 destination-pattern 91..$
 port 0/0/2
 forward-digits 3
!
dial-peer voice 192 pots
 description ##Emergency Calls##
 preference 2
 destination-pattern 91..$
 port 0/0/3
 forward-digits 3
!
dial-peer voice 1991 pots
 description ##Emergency Calls for Manager Extension ##
 destination-pattern 811..$
 port 0/0/0
 forward-digits 3
!
dial-peer voice 200 pots
 description ##Local and National Calls##
destination-pattern ^[2-5]........$
 port 0/0/1
 forward-digits 9
 prefix 0
!
dial-peer voice 201 pots
 description ##Local and National Calls##
 preference 1
 destination-pattern ^[2-5]........$
 port 0/0/2
 forward-digits 9
 prefix 0
!
dial-peer voice 202 pots
 description ##Local and National Calls##
 preference 2
 destination-pattern ^[2-5]........$
 port 0/0/3
 forward-digits 9
 prefix 0
!
dial-peer voice 205 pots
 description ##Local and National Calls in SRST Mode##
 destination-pattern ^90[2-5]........$
 port 0/0/1
 forward-digits 9
 prefix 0
!
dial-peer voice 206 pots
 description ##Local and National Calls in SRST Mode##
 preference 1
 destination-pattern ^90[2-5]........$
 port 0/0/2
 forward-digits 9
 prefix 0
!
dial-peer voice 207 pots
 description ##Local and National Calls in SRST Mode##
 preference 2
 destination-pattern ^90[2-5]........$
 port 0/0/3
 forward-digits 9
 prefix 0
!
dial-peer voice 2000 pots
 destination-pattern ^81[2-5]........$
port 0/0/0
 forward-digits 9
 prefix 0
!
dial-peer voice 2005 pots
 description ##Local and National Calls for Manager Extension in SRST
 destination-pattern ^8190[2-5]........$
 port 0/0/0
 forward-digits 9
 prefix 0
!
dial-peer voice 2300 voip
 destination-pattern [234]...$
 session target ipv4:172.16.7.243
 voice-class codec 1  
 voice-class h323 1
 dtmf-relay h245-alphanumeric
 ip qos dscp cs3 signaling
!
dial-peer voice 2301 voip
 preference 1
 destination-pattern [234]...$
 session target ipv4:172.16.7.244
 voice-class codec 1  
 voice-class h323 1
 dtmf-relay h245-alphanumeric
 ip qos dscp cs3 signaling
!
!
!
!
gatekeeper
 shutdown
!
!
telephony-service
 sdspfarm units 1
 sdspfarm tag 1 PTB_HW_CFB
 conference hardware
 srst mode auto-provision none
 srst ephone template 1
 srst dn line-mode octo
 max-ephones 20
 max-dn 40 preference 9 no-reg both
 ip source-address 172.25.12.2 port 2000
 timeouts interdigit 5
 system message "Operating in fallback mode"
 cnf-file location flash:
 cnf-file perphone
 time-zone 22
 date-format dd-mm-yy
 max-conferences 3 gain -6
 call-forward pattern ....
 moh enable-g711 "music-on-hold.au"
 multicast moh 239.1.1.1 port 16384 route 172.25.12.2 172.25.12.5
 transfer-system full-consult
 transfer-pattern ....
 secondary-dialtone 9
!
!
ephone-template  1
 conference drop-mode creator
 conference add-mode creator
 conference admin
 softkeys hold  Resume Newcall Join Select
 softkeys idle  Redial Newcall Cfwdall Pickup Gpickup Join ConfList RmLstC Dnd Login
 softkeys seized  Redial Endcall Cfwdall Pickup Gpickup Meetme Callback
 softkeys connected  Hold Endcall Trnsfer Confrn ConfList Acct Park
!
!
ephone-dn  1  octo-line
 number 4201
 pickup-call any-group
 pickup-group 32
 description 4201
 name Joseph Sowah Okpoti
 preference 9
 huntstop channel 2
!
!
ephone-dn  2  octo-line
 number 4202
 pickup-call any-group
 pickup-group 32
 description 4202
 name <name of the user>
 preference 9
 huntstop channel 2
!
!
ephone-dn  3  octo-line
 number 4203
 pickup-call any-group
 pickup-group 32
 description 4203
 name <name of the user>
 preference 9
 huntstop channel 2
!
!
ephone-dn  4  octo-line
 number 4204
 pickup-call any-group
 pickup-group 32
 description 4204
 name <name of the user>
 preference 9
 huntstop channel 2
!
!
ephone-dn  5  octo-line
 number 4205
 pickup-call any-group
 pickup-group 32
 description 4205
 name <name of the user>
 preference 9
 huntstop channel 2
!
!
ephone-dn  6  octo-line
 number 4206
 pickup-call any-group
 pickup-group 32
 description 4206
 name <name of the user>
 preference 9
 huntstop channel 2
!
!
ephone-dn  7  octo-line
 number 4207
 pickup-call any-group
 pickup-group 32
 description 4207
 name <name of the user>
 preference 9
 huntstop channel 2
!
!
ephone-dn  8  octo-line
 number 4208
 pickup-call any-group
 pickup-group 32
 description 4208
 name <name of the user>
 preference 9
 huntstop channel 2
!
!
ephone-dn  9  octo-line
 number 4209
 pickup-call any-group
 pickup-group 32
 description 4209
 name <name of the user>
 preference 9
 huntstop channel 2
!
!
ephone-dn  10  octo-line
 number 4210
 pickup-call any-group
 pickup-group 32
 description 4210
 name <name of the user>
 preference 9
 huntstop channel 2
!
!
ephone-dn  11  octo-line
 number 4211
 pickup-call any-group
 pickup-group 32
 description 4211
 name <name of the user>
 preference 9
 huntstop channel 2
!
!
ephone-dn  30  octo-line
 number A01 no-reg both
 conference ad-hoc
 preference 1
!
!
ephone-dn  31  octo-line
 number A02 no-reg both
 conference ad-hoc
 preference 2
!
!
ephone-dn  32  octo-line
 number A03 no-reg both
 conference ad-hoc
 preference 3

end
ASKER CERTIFIED SOLUTION
Avatar of buckethead34
buckethead34

Our community of experts have been thoroughly vetted for their expertise and industry experience.

Commented:
This problem has been solved!
Unlock 1 Answer and 2 Comments.
See Answers