• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 209
  • Last Modified:

Point DNS (IP) to Azure VM not working

I am setting up a site in an Azure VM Windows 2012 server. The DNS is pointing to the external IP of that machine.
Yet, when I go to IIS to bind the site to that IP the IP is not displayed in the drop down menu and the site does not come up.
I checked the traceroute and the domain is correctly pointing to that IP, I am not familiar with what other configuration needs to take place in order to bind the external IP to the site so that it comes up.
Any guidance would be helpful.
0
Aleks
Asked:
Aleks
  • 12
  • 7
  • 2
  • +2
2 Solutions
 
Alexandre TakacsCTOCommented:
Yet, when I go to IIS to bind the site to that IP the IP is not displayed in the drop down menu and the site does not come up.

What does come up (if anything) ?

Does the Azure VM have the expected public IP ? Can you "ping" it (assuming adequate firewall setup) ?
0
 
Tom CieslikIT EngineerCommented:
I think your External IP is pointed to your domain, not to virtual server.
Domain is registered on Azure but your VP IP is different.

What you see if you do IPCONFIG / ALL on VM ?

Did you assigned External IP to virtual machine virtual NIC ?
0
 
AleksAuthor Commented:
The domain points to the external IP. How do I point that external IP to the VM ?
The domain is registered with Godaddy, a third party DNS points the domain to the external IP of Azure.  

How to I assign the External IP to virtual machine virtual NIC?

so that I can bind it to the website i created?
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
Alexandre TakacsCTOCommented:
Did you follow these instructions ?

Again, what is the current IP assigned to your machine ? Can you provide an IPCONFIG ?
0
 
AleksAuthor Commented:
I'll follow the instructions when I get home this evening thx
0
 
David Johnson, CD, MVPOwnerCommented:
in iis on the azure vm don't worry about the ip address or use the internal ip address available from the drop down you will not see the external public ip.  I assume that you've added the endpoints for http/https to the azure vm in azure settings. You have to go into the network settings, inbound and outbound security and enable http for both inbound and  outbound. You need to create these 2 new rules

As I've shown in this video
0
 
Brian MurphyIT ArchitectCommented:
Are you allocating private or public ranges on your IP?  If so, you have to "allow" that traffic - similiar to NAT - other than 3389.

Similar to a Load Balancer, you don't need a NAT but instead a SNAT and possibly a NAT.  I tend to use wildcard certificates that can host thousands of domains per certificate *.domain.com = 1.domain.com 1.2.domain.com 1.2.3.domain.com 2.domain.com 1.1.2.domain.com.

Are you using a TLS Certificate?

If so, or not, why can you not telnet to port 80, 443, 8080, whatever the site is bound?   Doesn't Azure provide you an external IP and Internal IP but by default leave only 3389 exposed - "if you choose this option" and again, assuming IIS here.....Windows.  

So, where did you get this IP Address that is found in GoDaddy?  That is ARIN, not WHOIS.  You must use a public IP given by Azure or in some cases you CAN transfer those IP's, but rare.

If you had a NAT or port redirect local to your physical location - for example - you could use a port redirect where traffic comes in destined for A and sent to B.  Now this is contingent on the security options you have checked on IIS Web server and whether or not the SSL certificate is bound - Yes?
0
 
AleksAuthor Commented:
I already followed all the instructions on the link above. The VM has a static IP address.
But when I login to the computer via RDP and try to bind such IP to a website I don't see it available, evidently the website doesn't resolve.

www.bluedotazure.com

What am I missing?
Screenshot_1.png
0
 
AleksAuthor Commented:
If possible please provide step to step instructions on what to do.
The domain is pointed to the public IP of the VM
The VM does not show the IP in the options to bind a website (domain) to a particular IP.

What do I need to do (step by step) to have that public ip available to choose from so I can bind it.
0
 
Alexandre TakacsCTOCommented:
I'm sorry to insist but could you provide an IPCONFIG /ALL of from your VM ?
0
 
AleksAuthor Commented:
Ill connect to it and run ipconfig. Ill post in 5 min
0
 
AleksAuthor Commented:
Here it is:

Ethernet adapter Ethernet:

   Connection-specific DNS Suffix  . : bspr5lvrvttezpiongw3te3lid.bx.internal.cl
oudapp.net
   Link-local IPv6 Address . . . . . : fe80::3854:d498:84ad:9cc6%12
   IPv4 Address. . . . . . . . . . . : 10.0.0.4
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 10.0.0.1

Tunnel adapter isatap.bspr5lvrvttezpiongw3te3lid.bx.internal.cloudapp.net:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . : bspr5lvrvttezpiongw3te3lid.bx.internal.cl
oudapp.net

Tunnel adapter Teredo Tunneling Pseudo-Interface:

   Connection-specific DNS Suffix  . :
   IPv6 Address. . . . . . . . . . . : 2001:0:4137:9e76:1098:1abf:cb57:6d7a
   Link-local IPv6 Address . . . . . : fe80::1098:1abf:cb57:6d7a%14
   Default Gateway . . . . . . . . . : ::

Open in new window

0
 
Alexandre TakacsCTOCommented:
Thanks... next can you make a screenshot of your portal -> Network interfaces (you might want to blur the your private IPs)

portal
0
 
AleksAuthor Commented:
ok .. one min .. thx for the screenshots, very helpful (Azure is new to me)
0
 
AleksAuthor Commented:
I covered the private IP. It shows the public IP

IP
0
 
AleksAuthor Commented:
Besides this is there anything else needed?  the IP is there in the VM, but not showing in the IIS Panel so I can bind it to the domain.
0
 
AleksAuthor Commented:
I can do a 'consultant live' meeting here on EE if you think that will help get this configured sooner.
0
 
Alexandre TakacsCTOCommented:
Well as you can see your IP is mapped to a private address 10.0.0.4 - this one should appear in the IIS control panel and it the one you should bind to. Then you have to authorize HTTP traffic in the security group:
inboundinboiund2As an alternative it is possible to directly add a secondary public static IP to your virtual NIC by creating a public IP address resource as described here . Under that scenario you could bind directly to said public IP (ie it should appear in the IIS CP).
0
 
Alexandre TakacsCTOCommented:
Well it works for me (assuming 52.168.146.133 is indeed your IP):

web
  1. you should also map 443 (for https)
  2. how did you setup the domain(s) you want to map to that server DNS wise (ie who does the DNS, do you have a A record pointing to 52.168.146.133)?
  3. obviously you have to put something to be served IIS side...
0
 
AleksAuthor Commented:
I added the above rule and it worked!  Thank you so much!
0
 
AleksAuthor Commented:
The step by step explanation with screen shots was very useful !
0
 
David Johnson, CD, MVPOwnerCommented:
I mentioned this and showed it in a video, 18 hours ago ID: 42143824
0
 
Alexandre TakacsCTOCommented:
Glad you had it working :)
0

Featured Post

Upgrade your Question Security!

Add Premium security features to your question to ensure its privacy or anonymity. Learn more about your ability to control Question Security today.

  • 12
  • 7
  • 2
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now