• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 48
  • Last Modified:

Do VM's get their time from VMhosts at all?

I am having an issue with one Windows 7 VM where sometimes the time appears to be drifting. It will be a few minutes off from what it is supposed to be.
I installed a 'Net Time' client to get this to sync up with an internet time server and it was working fine for the most part. But the host was rebooted over the weekend and the VM again had the wrong time until someone logged into it to check.

What is strange is that I have other Windows 7 VMs which don't appear to have this problem - it is only this one VM but I'm not sure what else to check. The Windows time setting seem correct.

The VM host itself has a time that is way off - I think it has never been configured. Before any change I want to make sure it would even have an effect in this case.
0
SeeDk
Asked:
SeeDk
1 Solution
 
Dmitri FarafontovLinux Systems AdminCommented:
If you install VMWare tools you should have a more or less consistent time. You did not mention the hypervisor you are using with your previous post however. Here is a video about it:
https://www.youtube.com/watch?v=tVEw9VprYeQ
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
if you have VMware Tools installed, even if you turn off Sync with Host, (which is the Default) when the VM restarts or is vMotioned, it will Sync time with host!

see here to disable, by modifying the VMX file.

https://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1189

https://blogs.vmware.com/apps/2016/01/completely-disable-time-synchronization-for-your-vm.html
0
 
SeeDkAuthor Commented:
This is running on ESXI 5.5 - VMware tools is not installed on either VM. What is the default behavior in that case?
Actually both of these VMs are joined to a Windows domain and in theory it should get the time from Domain Controller. Which it has been working for a long time now - not sure why recently the time has become an issue.
0
Prepare for your VMware VCP6-DCV exam.

Josh Coen and Jason Langer have prepared the latest edition of VCP study guide. Both authors have been working in the IT field for more than a decade, and both hold VMware certifications. This 163-page guide covers all 10 of the exam blueprint sections.

 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
The Domain Controller should be where this VM gets it's time source.

the time of the VM, matches what  the host ?

if VM time is not synced it will drift... it has no clock.
0
 
SeeDkAuthor Commented:
It did match with the DC until recently.
It begun to drift a few weeks ago which is why I installed net time :http://www.timesynctool.com/ on the VM.
Works fine but for some reason the time was still off. I guess the issue is not the ESXI host time though...it sounds like that should not affect it.
0
 
Satish AutiSenior System AdministratorCommented:
You need to disable time sync with exsi and configure your domain controller as NTP server for fetching time from external time servers.

https://support.microsoft.com/en-in/help/816042/how-to-configure-an-authoritative-time-server-in-windows-server

OR run below command in elevated command prompt.

net stop w32time
w32tm /unregister
w32tm /register
net start w32time
net time /setsntp:
net stop w32time & net start w32time
w32tm /config /manualpeerlist:pool.ntp.org /syncfromflags:manual /reliable:yes /update
w32tm /resync /rediscover
net stop w32time & net start w32time

Ref:
https://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1318
0
 
SeeDkAuthor Commented:
Ok thanks I made this change - hoping this does the trick to keep it in sync.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now