Out of office message is not working. Auto Reply is not working

We have migrated our exchange from exchange 2007 to Exchange 2013 then exchange 2013 to exchange 2016.
Now everything seems working fine except out of office. We set auto reply but it is not working. When any user send emails, auto reply does not go to him. No notification of OOF

Product-Exchange 2016
LVL 1
Arif KhanSystem AdministratorAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Satish AutiSenior System AdministratorCommented:
What is the outlook version you are using?
Arif KhanSystem AdministratorAuthor Commented:
Outlook 2010. But this, I dont this is limited to outlook . Because we can set OOF message from OWA also, nothing is working
Satish AutiSenior System AdministratorCommented:
Are you able to configure new outlook profile for affected user?
Try doing that, so will come to know auto discover is working properly or not?
Know it's also not working in OWA as well but still give a try.

If auto discover is working fine but still issue persists, then try restart MSExchangeAutodiscoverAppPool

Restart-WebAppPool MSExchangeAutodiscoverAppPool
Exploring SharePoint 2016

Explore SharePoint 2016, the web-based, collaborative platform that integrates with Microsoft Office to provide intranets, secure document management, and collaboration so you can develop your online and offline capabilities.

Arif KhanSystem AdministratorAuthor Commented:
Did not help this, kindly suggest any other step
Satish AutiSenior System AdministratorCommented:
Please see if auto reply and OOF settings are configured in exchange 2016 from Exchange Admin Center because in exchange 2007/2010 hub transport use to set auto replies and OOF settings for entire org. Now hub transport is no more role of exchange 2016.

You must check the rules and correct them.

https://www.codetwo.com/admins-blog/how-to-block-sending-out-of-office-messages-on-exchange-server-for-external-recipients/
Satish AutiSenior System AdministratorCommented:
To check the settings. (Default is * domain) use power shell.

Get-RemoteDomain Default | fl AllowedOOFType, AutoReplyEnabled, AutoForwardEnabled

If it's not enabled run the below command to enabled it.

Set-RemoteDomain Default -AutoReplyEnabled $true –AutoForwardEnabled $true –AllowedOOFType $ExternalLegacy
Arif KhanSystem AdministratorAuthor Commented:
HI Satish,

Thanks for your reply. I checked, it is already enabled but still no auto reply

C:\Windows\system32>Get-RemoteDomain Default | fl AllowedOOFType, AutoReplyEnabled, AutoForwardEnabled


AllowedOOFType     : External
AutoReplyEnabled   : True
AutoForwardEnabled : True
Satish AutiSenior System AdministratorCommented:
Ok, Can you please verify the auto discover settings?


1. Test E-mail Autoconfiguration and see which OOF URL it's pointing.

2. Remove the anonymous authentication and set to integrated and basic authentication for EWS directory in IIS on Exchange.

3. Stop and restart IIS.

https://technet.microsoft.com/en-us/library/aa996324.aspx

Finally you can try to reset the AutodiscoverVirtualDirectory.

Remove-AutodiscoverVirtualDirectory

New-AutodiscoverVirtualDirectory

 

Hope it helps!
Arif KhanSystem AdministratorAuthor Commented:
Should I reset both Default and Backend virtual directory of AutoDiscover?
Satish AutiSenior System AdministratorCommented:
From the client side do the Test E-mail autoconfiguration and check where it is pointing. Reset that one.

auto.JPG
Arif KhanSystem AdministratorAuthor Commented:
Satish AutiSenior System AdministratorCommented:
Reset that one and see the results.
Arif KhanSystem AdministratorAuthor Commented:
Hi Satish,

Thanks for your message. I have reset the Auto Discover virtual directory using ECP, it is successful. But still Auto reply is not working. After resetting AutoDiscover, now getting issue of "Mail tips could not be retrieved. However, it is not creating any mail flow problem. So, I will work first of OOF and then on this new error. Assist me pls
Any other step please?
Satish AutiSenior System AdministratorCommented:
Can you try to recreate the OOF once? Also let me know is the users are still using old profiles or after migration you have configured new ones.
As I read somewhere we need to recreate the outlook profiles after migration to exchange 2016.
Arif KhanSystem AdministratorAuthor Commented:
I reset the Auto reply message. I am setting Auto reply from OWA not from outlook. It did not help me.
Satish AutiSenior System AdministratorCommented:
Could please run below command one more time?

Set-RemoteDomain Default -AutoReplyEnabled $true –AutoForwardEnabled $true –AllowedOOFType $ExternalLegacy

Set-RemoteDomain –AllowedOOFType $ExternalLegacy - Enables OOF for Outlook 2003 and previous (for Exchange 2007 and 2010 support)
Satish AutiSenior System AdministratorCommented:
Arif KhanSystem AdministratorAuthor Commented:
Ok. I am checking.

Yes, we are mail flow go through Logix filter
Arif KhanSystem AdministratorAuthor Commented:
I have checked but no luck
Satish AutiSenior System AdministratorCommented:
What it working while migration from exchange 2007 to Exchange 2013?
Arif KhanSystem AdministratorAuthor Commented:
Actually I migrated only and tested everything except OOF. Now client is saying that it was not working since migration time. I am not sure.

Here I tried to check the OOF on outlook 2010, it is giving error that " Your automatic reply settings cannot be displayed because the server is currently unavailable. Try again later.
Satish AutiSenior System AdministratorCommented:
Satish AutiSenior System AdministratorCommented:
I guess this is very similar with your issue.

https://www.petenetlive.com/KB/Article/0000897
Arif KhanSystem AdministratorAuthor Commented:
After going through this article. Error "Mail tips not enable" is resolved. And, Able to set the Auto reply. But it is not working. I set auto reply and sent test mail. Not getting any auto reply
Satish AutiSenior System AdministratorCommented:
Try to restart exchange services and then test again.
Arif KhanSystem AdministratorAuthor Commented:
Done. But still I am very wretched. bad luck.
Satish AutiSenior System AdministratorCommented:
It's not so long now.. we are reached very near to resolve it now but something simple we are missing..

Can you give a try to reset the IIS again?
Arif KhanSystem AdministratorAuthor Commented:
Yes, I did it Bro, no luck.
Arif KhanSystem AdministratorAuthor Commented:
Hi Satish,

I am really very much thankful to you for your all efforts which you made to assist me towards fixing this problem.

Finally, I got solution. I removed Deny permission of ExchangeLegacyInterop from ADSIEDIT-->Default Receive connector

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Satish AutiSenior System AdministratorCommented:
This is something new I learn. Can you share the link where you found this solution.
Arif KhanSystem AdministratorAuthor Commented:
Hi Satish,

we did RnD and it worked :D. Well, your really great and helpful.
Arif KhanSystem AdministratorAuthor Commented:
This fixed the problem
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Office

From novice to tech pro — start learning today.