?
Solved

RemoteAPP crashes from just one computer

Posted on 2017-07-31
6
Medium Priority
?
61 Views
Last Modified: 2017-08-11
I have a very odd situation for which I'm looking for assistance.

I have a client with a server running Server 2012 R2 Essentials.  They use WSE RemoteApp to allow remote users to access QuickBooks Enterprise 16.  This works fine for several users, except for one who just recently started having problems.  He can connect to the server and log into QuickBooks, but QB will abort moments later with an Unrecoverable Error.  The Code is 19758  66888.  I'm not finding anything online about that error.

What is particularly odd about this is that it only occurs with this one computer.  I try the same thing on another computer running the same version 1703 (and build) of Windows 10 Home, from the same location (have tried 2 different locations), using the same login and QuickBooks credentials with no problems.

I have installed a new hard drive in the laptop and reinstalled Windows 10 from scratch and the same symptom occurs.  The BIOS and drivers are up to date with no errors.

When I reinstalled Windows, I did copy user data (Documents, etc.) from the old drive.  I thought that might somehow be the issue, so I created a new user on the computer.  It shows the same error.  Both users are local admins.

The only common element with the failures is this specific computer.  The error is coming from QuickBooks.  I'm not seeing how something in this computer can cause the application error in the host computer.

I added a new Windows user on the server as well as a new QB user but still get the same symptoms.

I ran Windows Memory Diagnostic with no errors detected.

I've communicated with the company that produces WSE RemoteApp, but didn't get any solid answers there.

Any thoughts on what to look at next would be appreciated.
0
Comment
Question by:CompProbSolv
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 2
6 Comments
 
LVL 25

Expert Comment

by:Brian B
ID: 42236524
Based on the description of the WSE product, the application is still running on the server. Is it possible to log on to the server directly/remotely and run the program there for any user? Basically trying to get this RemoteApp thing out of the picture, because I'll bet if you called Quicken they'll say it is not supported running in this way.

You have done a pretty detailed troubleshooting job already. What about disabling antivirus?

It could be something weird about the particular system, unless that second computer you tried is the same hardware.
0
 
LVL 22

Author Comment

by:CompProbSolv
ID: 42239818
WSE used Remote Desktop and adds the RemoteAPP feature that isn't present in Server Essentials.  I agree that QB is running on the server and not locally.  In fact, in the original installation on this laptop, QB 16 wasn't even present on the workstation, though QB 14 was.

QB works fine for any proper user on the server with WSE out of the picture.  Keep in mind that it also works with WSE for any proper user on any other computer.

I would agree that Intuit is unlikely to want to discuss it at all because of WSE.
0
 
LVL 22

Author Comment

by:CompProbSolv
ID: 42239821
This has gotten even more odd.  After rebuilding the laptop and seeing the problem return, it went away.  The only thing of significance that I did was to log into the server (not through Remote Desktop) as the user, log into QB as the same user, and then exit.  I don't know if that caused it to work or if it was a coincidence.

I was able to reconnect with WSE several times without problems.  I only let it get to the main screen of QB as the error was showing up before that.

The client got the computer back and the problem is still there.  He is experiencing it when he tries to create a new invoice.  I hadn't tested that before.

I can use the same rdp file on my computer and log in with his credentials and create a new invoice without issue.

I'm back to the question of what it can be in the local computer that affects QB running remotely on the server.
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 25

Accepted Solution

by:
Brian B earned 2000 total points
ID: 42240466
As much as I love problems like this, I am thinking you are going to have to get support form the people who make this product. I mean, they are the ones who claim it will work, right?

Meanwhile, see if you can dial back the RDS settings as much as possible, like leave out printer and drive connections, for example. Anything that might tie the RDS session to the application.
0
 
LVL 22

Author Comment

by:CompProbSolv
ID: 42251437
The problem never really went away.  What I hadn't recognized is that my test of whether or not I got to the desktop without error wasn't adequate.  Once I thought it was working I discovered that the failure came back when I tried to create an invoice or even to create a new data file.  The symptom was showing up immediately when I started this project likely because of the different windows that were open in QB at the start.

Nonetheless, I've given up on this one.  I'm really stuck on what it is that QB "knows" about my computer that makes the difference.  I thought it might be the screen resolution, but that didn't have any effect.  I set the laptop to 1280x1024 (which is what my other test systems are using) and it still had the problem.

Thanks for your suggestions.....
0
 
LVL 22

Author Closing Comment

by:CompProbSolv
ID: 42251439
Wasn't able to resolve the problem.  Brian is correct that the solution needs to come from the software author.
0

Featured Post

Enterprise Mobility and BYOD For Dummies

Like “For Dummies” books, you can read this in whatever order you choose and learn about mobility and BYOD; and how to put a competitive mobile infrastructure in place. Developed for SMBs and large enterprises alike, you will find helpful use cases, planning, and implementation.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Curious about the latest ransomware attack? Check out our timeline of events surrounding the spread of this new virus along with tips on how to mitigate the damage.
I originally wrote this article to compare SARDU and YUMI, but have now added Easy2Boot, since that is the one I currently use and find the easiest to create and alter.
How to install and configure Citrix XenApp 6.5 - Part 1. In this video tutorial we have explained step by step installation of Citrix XenApp 6.5 Server on Windows Server 2008 R2 is explained in this video. We have explained the difference between…
Monitoring a network: why having a policy is the best policy? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the enormous benefits of having a policy-based approach when monitoring medium and large networks. Software utilized in this v…

719 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question