Why does NetExtender clear the "Append these DNS suffixes" after releasing the connection

Rock Suutala
Rock Suutala used Ask the Experts™
on
I log into different domains using NetExtender. When I log into client1 NetExender sets the flag to "Append these DNS suffixes" and adds client1.com as the suffix. Requests by host or host.domain name resolve fine. After I disconnect I see the flag is still set and the domain name (client1.com) is still present.  

When I connect NetExtender to client2.com name resolution does not work. I can only access devices by IP addresses. If then I uncheck  "Append these DNS suffixes" in DNS portion of my computers network settings devices are once again accessible by name.

Is there a setting in SonicWall SSLVPN configuration that will do the proper house keeping?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Kevin CrossChief Technology Officer
Most Valuable Expert 2011

Commented:
I use different VPN clients for my different customers and a couple use NetExtender and I ran into this.  Let me double check what I changed then will post back.

EDIT: cannot get into the machine with that VPN on it but just remembered it started working because client changed to different VPN.  For other client using SonicWall, we use Shrewsoft VPN, so not seeing the issue there but I believe there was a setting.  If I find it, will post back.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial