Why won't Adobe FlashPlayer route audio through my USB to HDMI connection?

I have a 60-inch plasma television connected to my laptop's docking station (port aggregator) by way of a USB-to-HDMI converter. In the following Settings dialog, it is identified as display number 3:

display-settings.png
I have a subscription to NBCSports.com where I use Mozilla Firefox to stream live and recorded content. So that I can watch the videos on the 60 inch screen, I select the USB to HDMI speaker for audio output…

audio-output-selection.png
 and then drag my browser over to the television screen (i.e., display number 3).

After logging in and selecting the video I want to watch, I get the following:

Initial-flash-player-screen.png
Although  I can hear the audio through the speakers connected to my computer, there is no video until I maximize the window…

flash-player-at-full-screen-1.png
I'm not sure why that is, but I can live with it. The real problem is that the audio is coming from my computer's speakers instead of the television's speakers. I'm not sure whether this is unique to the NBCSports.com site or the way in which FlashPlayer is being called, but I don't have any problems routing audio through the USB-to-HDMI connection when watching YouTube videos.

By the way, for the purposes of preparing this question, I muted the audio on the NBCSports.com tab. I use speech recognition to interact with my computer, and that was interfering with the process. Before anyone had an aha moment, I just thought I'd let you know.


While playing the video in full-screen mode on display 3, the taskbar on Display 2 looks like this:

task-bar-1.png
When I hover over the FlashPlayer icon in the taskbar, I get the following…

task-bar-2.png
This is the first time I've had problems routing audio to the television's speakers while streaming content from the NBC Sports.com site. The things that have changed on the system since the last time the audio worked include the feature updates for Windows 10 and the installation of an Internet security product by ESET.
babyb00merAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

William MillerIT SpecialistCommented:
Have you checked the individual volume for the player inside of the audio mixer? It's not been muted mistakenly somehow, has it? That would mute the player without your global setting having any effect.

Edit: The player itself should show as Adobe in the volume mixer, so it would likely be separate from the page's volume control as well.
0
Joe Winograd, Fellow&MVEDeveloperCommented:
I use this method when the HDMI port is built into the computer, so I don't know if it will work for a USB-to-HDMI adapter, but it's worth a try. Either right-click on the speaker icon in the system tray and select Playback Devices or go to Control Panel and run the Sound applet. Either way, you will get something like this:

Set HDMI output
Click the HDMI Output choice, click Set Default, click OK. That should do it. Yours may or may not be AMD, but you should see something that says HDMI as a choice. Regards, Joe
0
arnoldCommented:
Jjjflash is a component that runs within the browser, does other doubts from Firefox route out the USB to HDMI ...Joe kindly posted graphical direction.

The issue is likely that you have a player configured to use the USB to HDMI, while system Defaul settings for audio playback is done thing else....

Once chanted, you may regret the choice given many sites have auto-play ads of various time that will play through your audio device.
0
Acronis Data Cloud 7.8 Enhances Cyber Protection

A closer look at five essential enhancements that benefit end-users and help MSPs take their cloud data protection business further.

babyb00merAuthor Commented:
Adobe is not listed in the application section of the mixer. The closest it gets is Mozilla Firefox – which, I assume, contains the flash plug-in.

mixer-1.png mixer-2.png
Making the USB-to-HDMI device the default doesn't work either. I tried it with both Firefox and Internet Explorer. The audio is still routed through the device identified as "Speakers (High Definition Audio Device)" – which are the speakers connected to my computer.

playback-devices-1.png playback-devices-2.png
If the problem was that the output device was being inadvertently muted, I wouldn't expect to hear any audio at all. The problem I'm having is that the audio is not going to the device I'm selecting.

I don't know what the default player is for YouTube, but I have no problems getting it to route audio through the USB-to-HDMI port. So far, this seems to be an isolated event. Making global changes to my system doesn't seem to make sense when no other applications are having this problem.
0
Joe Winograd, Fellow&MVEDeveloperCommented:
I don't have that NBC Sports Gold app, so can't test it here, but maybe you'll get audio playback choices if you left- or right-click its speaker icon:

nbc app
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
arnoldCommented:
I think the speaker is either volume control or mute, check to make sure your firefox tab is not audio muted.

Should have looked before, but if you look at the image right after the USB to HDMI Volume, the active Firefox tab is clearly reflecting that it is MUTED speaker with a diagonal line through it.
0
William MillerIT SpecialistCommented:
I thought about this a bit last night and I think I've run into a similar issue in the past. It definitely wasn't this scenario, but I had issues getting the TV display to output sound. Have you tried setting the TV display as the primary display when you're watching something on it? Why would that matter? Beats me, it's HDMi and it should carry sound anyways.
0
babyb00merAuthor Commented:

Should have looked before, but if you look at the image right after the USB to HDMI Volume, the active Firefox tab is clearly reflecting that it is MUTED speaker with a diagonal line through it.


A couple of things…

Muting audio would have muted all audio output devices. If you read my original and subsequent comments, I never said that I couldn't hear anything. What I said was that the sound was coming from a source other than the one I selected.

Also, if you read my opening comment, it includes a paragraph written in italics in which I acknowledge and explain why audio is disabled on that tab.
0
babyb00merAuthor Commented:
Joe's instincts were correct. Right-clicking on the Flash player's speaker icon invokes a pop-up menu which contains a Settings option. The Settings dialog contains an Audio Output tab where you can specify the audio output device. From the drop-down list I selected "Speakers (USB to HDMI Audio)" and closed the dialogue (refer to the video). It worked like a charm!

NBC-Sports-06.wmv
0
Joe Winograd, Fellow&MVEDeveloperCommented:
Very glad to hear that works for you. Enjoy the sports on your big screen! Btw, nice video explanation!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 10

From novice to tech pro — start learning today.