Server 2016 start menu not working for other users

We have a SQL server and with the domain administrator account, everything works fine.  But with any other user, even one set as domain or machine administrator, the start button does not work and neither does the search or the task view button.  Also if you click on the time, nothing happens as it would normally show the calendar.

A few days ago, we had a software company have remote access to try and fix an issue with the software they use which uses the SQL database.  They made some registry changes (I believe permissions) and they said they changed it all back to what it was.  However, this issue has been since they were in it.  I have no clue as to what got changed and cannot seem to fix the issue.  Even created a new user as member of domain admins and same thing...
joeshinallAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

John TsioumprisSoftware & Systems EngineerCommented:
Well if this registry related then you out for a hunt....
Download Process Monitor  and start the monitoring....one for the user that Start Menu is working and one for the one not working...compare the results and with a bit of luck you will spot the offending key...
Because a single "bad" registry key can make a system completely useless i think its better to get a full image of your server and do this when there is absolutely no work at all ....
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
McKnifeCommented:
I have seen and solved this issue on win10 which is the same code as server 2016 when it comes to the start menu. It were apps that somehow misbehaved - the built-in ones.  You can uninstall those in powershell:
get-appxpackage | remove-appxpackage

Open in new window

will remove ALL apps for the user that is currently logged on. try that with a test user.
0
Vitor MontalvãoMSSQL Senior EngineerCommented:
What's the SQL Server start button?
Can you illustrate with a screenshot?
0
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

McKnifeCommented:
The start button in the task bar, the start menu, Vitor.
Another thing that would most probably work is installing classic shell which is mainly used on win8.x and 10, but is also working on all server versions.
0
Vitor MontalvãoMSSQL Senior EngineerCommented:
The start button in the task bar, the start menu, Vitor.
Thank you.
So the issue should be that the user can't load SQL Server Management Studio?
0
joeshinallAuthor Commented:
We have solved the issue.  One of my guys remembered that they used the registry to forcefully disable UAC.  They then enabled it back in the registry and I'm not sure why, but disabling the UAC again in the registry fixed the issue (giving it a 0 value instead of the 1 they had).  Thank you for the responses.
1
McKnifeCommented:
Are you sure that it is solved for all user profiles now?
Did you create a new test user to start with?

I would be very surprised if that is indeed the solution.
0
John TsioumprisSoftware & Systems EngineerCommented:
So again its the registry....as always...:)
0
joeshinallAuthor Commented:
Mknife, yes, it fixed the issue for all users.

John, we knew it was a registry issue, just didn't know the best way to find which key.
0
McKnifeCommented:
Ok, for your info: What you did was set UAC off in a way that is not supported by modern apps - they simply will not even start. Both the task view button and the start menu itself are among these modern apps - and normally, one would expect that you would be notified like this "This app cannot start since UAC is off" or something similar - the behavior that you saw is rather a bug then a registry issue.
0
McKnifeCommented:
...and why it works for the domain admin: if the account is called "administrator", UAC is off for that account, anyway. Is that the case, is it called "administrator"?
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Software

From novice to tech pro — start learning today.