http is not working on our network only https works

We have 120 users on network with cyberoam ( 50 ING ) firewall  configured , from last 2 weeks we had issues like http websites not resolving getting error could not reach . But on other ISP it works fine.

Environment :
Cyberoam 50 ING Firewall with BSNL ISP configured  ....connected to Unmanaged switches
Internal AD integrated with DNS Server windows 2012 r2
All server + clients having primary dns server is windows server local IP address

But if do the nslookup domain name then it resolves fine but on browser it stucks. But sometime it works fine too.

ipconfig / flushdns
ipconfig / release
ipconfig / renew
ipconfig / registerdns
Winsock reset
Antivirus scan + malware scan , after malware scan it works for sometime and again it stucks. some of PC having the malware or spyware which blocks the http 80

everything did but http is not working . Only remains the Cyberoam Firewall firmware upgrade and restart of Windows 2012 server.

Please assist me to resolve this issue on urgent basis

Regards,
Vijay Kadadi
LVL 17
kadadi_vIT AdminAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Andy MInternal Systems ManagerCommented:
I would start by checking firewall logs - see if there's anything there indicating a block on port 80. Worth checking your outgoing tcp firewall rule to ensure port 80 is still enabled and allowed.

You could also run wireshark to see what's happening to the port 80 requests.

To rule out DNS issues (though your nslookup works so I don't believe this would be the case) set static dns on one of the affected machines to use something like google (8.8.8.8, 8.8.4.4) or opendns (208.67.222.222, 208.67.220.220).
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
masnrockCommented:
What do your filtering policies look like on the Cyberoam?
0
William MillerInventory/IT ConsultantCommented:
If this is specifically on HTTP (Port 80), this sounds like a filtering issue. Like the other two experts here have alluded to, you'll want to check the hardware firewall to make sure Port 80 isn't being blocked. It's a common practice to keep people off of sites considered insecure. It's just another step some companies will take to steer their employees away from going to places they're not supposed to go.
1
PberSolutions ArchitectCommented:
No comment has been added to this question in more than 21 days, so it is now classified as abandoned.

I have recommended this question be closed as follows:

Split:
-- Andy M (https:#a42329809)
-- William Miller (https:#a42330149)
-- masnrock (https:#a42330026)


If you feel this question should be closed differently, post an objection and the moderators will review all objections and close it as they feel fit. If no one objects, this question will be closed automatically the way described above.

Pber
Experts-Exchange Cleanup Volunteer
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Hardware Firewalls

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.