Could not remote into Server 2008 R2

Dear Experts, we could not use remote Desktop service into a Win server 2008 R2, it said that "Your credential did not work"; some steps were performed but could not help:
1. Open all Firewall profiles, disable Antivirus
2. Changing password
3. Create a new local user and add to Remote Desktop Group
4. Change remote port
5. Restart RDP service
6. Allow remote desktop service

Any idea please?
LVL 5
DP230Network AdministratorAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

CESNetwork AdministratorCommented:
So by the server saying "Your credentials did not work" that means that it's not a connection issue;  you're successfully getting to the server it's just the username or password is wrong or the account is not part of the RDP users group.

This means that it is not #1,4,5 or 6.

Can you RDP using the local admin account?
0
DP230Network AdministratorAuthor Commented:
No I could not, I tried both Local Admin as well as a new local user but did not help!
0
TuliTaivasserver adminCommented:
- just to make sure: when you say "local user" you mean local to the server, right?
- any special characters in the password? can you type the password somewhere where you can actually SEE what gets wirtten? (e.g. in the username field). same keyboard layout on server and client?
- no blanks before or after the username (happens here more often than expected)
1
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

Neil RussellTechnical Development LeadCommented:
Ensure that user does not have "Must change password at next logon"  set
1
DP230Network AdministratorAuthor Commented:
@Tuli:
just to make sure: when you say "local user" you mean local to the server, right?
---> YES, it is local user on that server

- any special characters in the password?
----> No
can you type the password somewhere where you can actually SEE what gets wirtten? (e.g. in the username field). same keyboard layout on server and client?
-----> Yes, I tried copy paste from txt file but no luck

- no blanks before or after the username (happens here more often than expected)
------> No, it does not have

@Neil: the user had "Password never expired " setting, but no luck
0
CESNetwork AdministratorCommented:
what about local logon?  does that work?
0
DP230Network AdministratorAuthor Commented:
Yes, it worked.
0
DP230Network AdministratorAuthor Commented:
@CES IT: I reviewed the EE link but could not find this option, can you help?

.... on the general tab I changed Security layer from 'Negotiate' to 'RDP Security Layer' and I no longer need to enter credentials to start an RDP session.
0
JohnCommented:
If it works as a local logon, but not RDP, then it is the permissions on the listener.  

Generally, add the user to the Remote Desktop Users group and that will do the trick.  If this has been messed with, then you may want to check the permissions on the listener itself.
0
JohnCommented:
go to Remote Desktop Session Host Configuration in Admin Tools

Under connections, right click the listener in question (most servers only have one) and select properties

On the security tab, add/remove users and groups.  (Add the user you want to log in as)
0
DP230Network AdministratorAuthor Commented:
Hi John, thank you but still no luck, could not remote into that server :(
0
JohnCommented:
There are two layers of authentication in 2008 and upwards.  There's authentication with the server (NLA) and then RDP authentication for the session.  

Which one is it failing on?

Have you tried disabling NLA?  

To do this, right click 'My Computer' and select properties

Click on the remote settings link

When system properties comes up, click on the Remote tab

There are 3 selections at the bottom.  pick the middle one (Allow connections from computers running any version of Remote Desktop (less secure))
0
DP230Network AdministratorAuthor Commented:
@John: Yes, that middle one option was configured but still no luck
0
JohnCommented:
In a command prompt, try

Netstat -ano

Do you have this:?

  Proto  Local Address          Foreign Address        State           PID

  TCP    0.0.0.0:3389           0.0.0.0:0              LISTENING       1176

There will be lots of lines.  It needs to match the line above.  The PID is not important, but the rest is.
0
DP230Network AdministratorAuthor Commented:
Sorry guys, my bad. This is duplicate IP problem. I turned off a host with the same IP and RDP on this server worked again.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
JohnCommented:
did you not get a duplicate IP address warning?
0
JohnCommented:
The authentication problem was that you were logging in to serverB with a username and password for serverA due to the IP conflict.  

ServerB must have responded to the ARP request last and got it's MAC address in your ARP cache
1
DP230Network AdministratorAuthor Commented:
No, I did not have a warning in the Desktop notification, I only realized this problem when typed: "ipconfig /all"

Many thanks for your support!
0
DP230Network AdministratorAuthor Commented:
Problem solved after removed duplicated IP issue.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Remote Access

From novice to tech pro — start learning today.