Public Network won't change to Private

How do I change a Public Network to Private. Windows 8.1 and 10.

There is no ability to Make this PC discoverable.

Peter WilsonITAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JohnBusiness Consultant (Owner)Commented:
If you have Windows 10 Version 1709, click on the wireless icon, Properties, and you can change the setting.

For lesser versions or Windows 8, it is easier to delete the wireless profile, restart and remake the profile.

Open cmd.exe with Run as Administrator and  then:

netsh wlan delete profile name="profile name"
Peter WilsonITAuthor Commented:
I have no ability to change these settings in Win10 Pro.
JohnBusiness Consultant (Owner)Commented:
You need to get your IT Administrator to do it or give you access to do it.
Get Blueprints for Increased Customer Retention

The IT Service Excellence Tool Kit has best practices to keep your clients happy and business booming. Inside, you’ll find everything you need to increase client satisfaction and retention, become more competitive, and increase your overall success.

Blue Street TechLast KnightCommented:
Hi Peter,

I bet when you set this up/joined the wireless network you selected No to find other PCs, devices and other connected to the network... by selecting "No" when joining the network it will auto-assign the network to the Public space.

You can switch this Private by going to Start > Run and type regedit.
Browse to HKLM\Software\Microsoft\WindowsNT\CurrentVersion\NetworkList\Profiles\
Locate the string which is your wireless network and modify the Category from 0 to 1. You can look at the ProfileName and/or Description key for each string to help determine which string is your network.
0 = Public
1 = Private
Disconnect and then reconnect to the network.

A great write-up for your specific Windows version/builds is located here:

Let me know if you have any other questions!
Peter WilsonITAuthor Commented:
We are a small remote office with no IT admin. We setup a new wireless access point and now my Win10 Pro laptops are connecting as Public. I will try what you have suggested.
JohnBusiness Consultant (Owner)Commented:
See if you can set up an Admin account on the laptop. Be careful using the registry if you are a small company. Changing from Public to Private does not require registry changes.
Peter WilsonITAuthor Commented:
my account is an admin in Windows. I still have no option - it is not that it is greyed out it simply doesn't exist.
Blue Street TechLast KnightCommented:
Most likely your Windows 10 version the "toggle" or "switch" is Making this PC Discoverable. Depending on what you put there will signify Private or Public. Off = Public, On = Private. The reg modification will do the same. See the link I have in my last post.

Also, as a side note, you should have Admin should be a Standard User and have the password of an Admin account for elevation - it is a better security model, especially since it is a small environment and assuming you do not connect to a domain. If you connect to a domain you should most assuredly not have Admin rights.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
JohnBusiness Consultant (Owner)Commented:
So then something wrong with the operating system.

First try DISM

Open cmd.exe with Run as Administrator. Run dism.exe /oneline /cleanup-image /restorehealth

Restart and test.

If that does work try a Windows 10 repair install.

Go to the Media Creation Link

Windows 10 is running, so click on the Download button (not Upgrade Button, select Open (Run) but NOT Save. Allow the program to run. Allow drivers to update. Then select Keep Everything.
Peter WilsonITAuthor Commented:
Enabling Discover my PC resolved it. Thank you!
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 10

From novice to tech pro — start learning today.