Default all Excel files being opened to one instance (like Office 2007 allowed)

Has anyone found a way to have by default all Excel files to open into one instance like Office 2007 allowed? We are using Excel 2016 and we are only able to have Excel files being opened to create a  new instance for each one. In other words each .xlsx we open we want it to default to open under the same window. Thanks
LVL 8
ITSysTechSenior Systems AdministratorAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

AlanConsultantCommented:
Hi,

This is the default behavior for all versions of Excel already.

If your's if opening in a new instance, then something has been changed.

Alan.
0
ITSysTechSenior Systems AdministratorAuthor Commented:
We have 300 versions of Office 365 that exhibit this same behavior with no changes to the default settings.
0
AlanConsultantCommented:
That's very odd.  I guess it might be a Group Policy that is being applied, even one from an older version that is having an unexpected effect.

Please can you try this:

1) Open two workbooks in Excel

2) In Excel open the VB Editor (Alt-F11)

3) In the 'Immediate' pane, please enter this line of code, and press Enter:

?Application.Workbooks.Count

Open in new window


4) It will return a number, please post back that number.


Thanks,

Alan.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

ITSysTechSenior Systems AdministratorAuthor Commented:
It returns a 2
0
AlanConsultantCommented:
Okay.  Please can you re-do that test, but with this instead:

1)  Open any workbook - it doesn't matter what workbook, but ideally with a unique name.

2)  Open a second workbook - again with another (different) unique name.

3)  In Excel open the VB Editor (Alt-F11)

4)  In the 'Immediate' pane, please enter these lines of code, and press Enter after each one - they will each return a string:

?Application.Workbooks(1).Name
?Application.Workbooks(2).Name


Do the two names that it returns match the names of the two workbooks that you opened in (1)?


Thanks,

Alan.
0
ITSysTechSenior Systems AdministratorAuthor Commented:
Each one resulted in returning the name of the first workbook and the second workbook I opened.

?Application.Workbooks(1).Name
Master1.xlsx

?Application.Workbooks(2).Name
Master2.xlsx
0
AlanConsultantCommented:
Okay.  That means that both workbooks are open in a single instance of Excel (rather than two separate instances).

I am wondering if, rather than two instances of Excel, you mean that you want to turn off showing all the workbooks open in Excel separately in the taskbar?

Please can you open two workbooks, then in Excel go to:

File - Options
Advanced
Scroll down to the 'Display' section
Show all windows in the taskbar = TRUE

Change that to FALSE

Does that make it look like it did before?


Alan.
0
ITSysTechSenior Systems AdministratorAuthor Commented:
I can not find that option, this is what I see.
1.JPG
I should probably rephrase my question. In Excel 2007 you could go to file open and open one file then another and they would both show up in the same program (under one pane of glass). Whereas now under Excel 2016 you open one file and then another it opens under two panes of glass. Sorry for the confusion on my side.
0
AlanConsultantCommented:
Are you running Win10?

If so, please try this:

1) Right click on the taskbar, and choose 'Taskbar Settings'

2) Halfway down there is a setting called 'Combine taskbar buttons'

3) What is yours set to?  If not already, try changing it to 'Always, hide labels'


Does that make any difference?


If you have multiple displays, you might need to scroll down further in the 'Taskbar Settings' screen, and change:

'Show taskbar buttons on' setting to be 'Taskbar where window is open'

and

'Combine Buttons on other taskbars' setting to also be 'Always, hide labels'.

Alan.
0
ITSysTechSenior Systems AdministratorAuthor Commented:
They were both set at  (Always, hide labels)

-Windows 10 Pro 64bit
0
AlanConsultantCommented:
I am stumped at this point.

I only have Excel 2010 on the machine I am on right now, and it has different options for display than the Office 365 that you are using.

This is what I see:

ShowAllWindowsInTheTaskBar.bmp

We can fairly certain though that the multiple workbooks are opening in a single instance of Excel - not in multiple instances.


Alan.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ITSysTechSenior Systems AdministratorAuthor Commented:
They must have removed that option in Office 365. Thanks for your help!
0
AlanConsultantCommented:
No problem - I would be happier if we had a solution!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Office

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.