npdodge
asked on
VLAN and routing assistance needed
We have a shared DR site with our parent company and we are currently on the same subnet (192.168.200.0/24). Both of our production sites are in separate physical locations with a point to multi-point metro-ethernet link between the sites. I'd like to segragate our servers from the parent company and place them on a separate subnet at the DR site.
I'm including the config below that is relevant to my situation. My production site is "Switch 1", the DR site is "Switch 2" and the firewall is at the DR site.
At the DR site, I can either use the switch for layer 3 by configuring an IP (192.168.206.1) on interface vlan 206, or the firewall using 192.168.206.254. My thought is that it would be more secure using the firewall, I'm not really seeing additional latency. If I use the switch, I would need vlan 206 to use a different default route than vlan 200, which I don't think is possible. Our parent company will remain on the 200 VLAN using 192.168.200.0/24. My question is, I have it working using the firewall for routing as the default gateway of my servers on vlan 206, but am I configuring this in the most ideal way? Thanks.
Switch 1 (Production site)
interface Vlan210
ip address 192.168.210.2 255.255.255.0
ip route 192.168.206.0/24 192.168.210.1
Switch 2 (DR site)
interface Vlan210
ip address 192.168.210.1 255.255.255.0
interface Vlan206
ip address 192.168.206.1 255.255.255.0
interface Vlan200
ip address 192.168.200.1 255.255.255.0
ip route 0.0.0.0 0.0.0.0 192.168.200.3
ip route 192.168.17.0 255.255.255.0 192.168.210.2
Firewall (DR site)
interface Ethernet0/0
nameif Outside
security-level 0
ip address 98.x.x.x 255.255.255.240
interface Ethernet0/1
nameif Inside
security-level 100
ip address 192.168.200.3 255.255.255.0
interface Ethernet0/2
no nameif
no security-level
no ip address
interface Ethernet0/2.100
vlan 205
nameif companyA_dmz
security-level 50
ip address 192.168.205.1 255.255.255.0
interface Ethernet0/2.200
vlan 206
nameif companyA_inside
security-level 0
ip address 192.168.206.254 255.255.255.0
interface Ethernet0/2.300
vlan 210
nameif switch_network
security-level 0
ip address 192.168.210.3 255.255.255.0
object network CompanyA_Inside
subnet 0.0.0.0 0.0.0.0
object network CompanyA_Inside
nat (companyA_inside,Outside) dynamic interface
route Outside 0.0.0.0 0.0.0.0 98.x.x.x 1
route switch_network 192.168.17.0 255.255.255.0 192.168.210.1
I'm including the config below that is relevant to my situation. My production site is "Switch 1", the DR site is "Switch 2" and the firewall is at the DR site.
At the DR site, I can either use the switch for layer 3 by configuring an IP (192.168.206.1) on interface vlan 206, or the firewall using 192.168.206.254. My thought is that it would be more secure using the firewall, I'm not really seeing additional latency. If I use the switch, I would need vlan 206 to use a different default route than vlan 200, which I don't think is possible. Our parent company will remain on the 200 VLAN using 192.168.200.0/24. My question is, I have it working using the firewall for routing as the default gateway of my servers on vlan 206, but am I configuring this in the most ideal way? Thanks.
Switch 1 (Production site)
interface Vlan210
ip address 192.168.210.2 255.255.255.0
ip route 192.168.206.0/24 192.168.210.1
Switch 2 (DR site)
interface Vlan210
ip address 192.168.210.1 255.255.255.0
interface Vlan206
ip address 192.168.206.1 255.255.255.0
interface Vlan200
ip address 192.168.200.1 255.255.255.0
ip route 0.0.0.0 0.0.0.0 192.168.200.3
ip route 192.168.17.0 255.255.255.0 192.168.210.2
Firewall (DR site)
interface Ethernet0/0
nameif Outside
security-level 0
ip address 98.x.x.x 255.255.255.240
interface Ethernet0/1
nameif Inside
security-level 100
ip address 192.168.200.3 255.255.255.0
interface Ethernet0/2
no nameif
no security-level
no ip address
interface Ethernet0/2.100
vlan 205
nameif companyA_dmz
security-level 50
ip address 192.168.205.1 255.255.255.0
interface Ethernet0/2.200
vlan 206
nameif companyA_inside
security-level 0
ip address 192.168.206.254 255.255.255.0
interface Ethernet0/2.300
vlan 210
nameif switch_network
security-level 0
ip address 192.168.210.3 255.255.255.0
object network CompanyA_Inside
subnet 0.0.0.0 0.0.0.0
object network CompanyA_Inside
nat (companyA_inside,Outside) dynamic interface
route Outside 0.0.0.0 0.0.0.0 98.x.x.x 1
route switch_network 192.168.17.0 255.255.255.0 192.168.210.1
ASKER
If next hop is the "firewall" gateway, then all traffic would route to the Inside interface of the firewall (192.168.200.3) on the 200 VLAN.
Let say you have created a vlan in your firewall
Vlan 200 with an IP of 192.168.200.3
You need to create the same vlan on the switch with the same subnet ip address 192.168.200.4 -- this is an example--
Then do routing as it shows:
Let say you want to route you switch DR vlans to your firewall.
Also, as a good practice I have summarize this IPs
192.168.10.0,
192.168.11.0,
192.168.12.0
in your switch you have to do this:
ip route 192.168.0.0 0.0.7.255 192.168.200.3 --This is your firewall gateway inside to outside
Hope it helps
Vlan 200 with an IP of 192.168.200.3
You need to create the same vlan on the switch with the same subnet ip address 192.168.200.4 -- this is an example--
Then do routing as it shows:
Let say you want to route you switch DR vlans to your firewall.
Also, as a good practice I have summarize this IPs
192.168.10.0,
192.168.11.0,
192.168.12.0
in your switch you have to do this:
ip route 192.168.0.0 0.0.7.255 192.168.200.3 --This is your firewall gateway inside to outside
Hope it helps
ASKER
Not exactly following you, as it doesn't look like the "ip route" command can route based on source IP.
My parent company will be on vlan 200 (192.168.200.0/24), my company will be on vlan 206 (192.168.206.0/24). You're saying that we let the switch do the routing. So let's say interface vlan 200 on the switch has an IP of 192.168.200.1 and interface vlan 206 has an IP of 192.168.206.1.
Now the firewall has an interface on vlan 200 with an IP 192.168.200.3 and another interface on vlan 206 with an IP 192.168.206.254. How do I go about sending default traffic for 192.168.200.0/24 to 192.168.200.3 and another default route for 192.168.206.0/24 to 192.168.206.254?
I should add that we have a bunch of other routes already defined in the switch for subnets that are used at both production sites for the parent company and my company. Maybe that will help. :)
Switch 2 (DR Site)
ip route 0.0.0.0 0.0.0.0 192.168.200.3
ip route 10.0.17.0 255.255.255.0 192.168.200.2
ip route 192.168.1.0 255.255.255.0 192.168.210.2
ip route 192.168.10.0 255.255.255.0 192.168.210.2
ip route 192.168.13.0 255.255.255.0 192.168.210.2
ip route 192.168.15.0 255.255.255.0 192.168.210.2
ip route 192.168.16.0 255.255.255.0 192.168.210.2
ip route 192.168.17.0 255.255.255.0 192.168.210.2
ip route 192.168.18.0 255.255.255.0 192.168.210.2
ip route 192.168.19.0 255.255.255.0 192.168.200.2
ip route 192.168.33.0 255.255.255.0 192.168.200.2
ip route 192.168.40.0 255.255.255.0 192.168.200.2
ip route 192.168.41.0 255.255.255.0 192.168.200.2
ip route 192.168.42.0 255.255.255.0 192.168.200.2
ip route 192.168.43.0 255.255.255.0 192.168.200.2
ip route 192.168.50.0 255.255.255.0 192.168.200.2
ip route 192.168.51.0 255.255.255.0 192.168.200.2
ip route 192.168.52.0 255.255.255.0 192.168.200.2
ip route 192.168.61.0 255.255.255.0 192.168.210.2
ip route 192.168.62.0 255.255.255.0 192.168.200.2
ip route 192.168.71.0 255.255.255.0 192.168.210.2
ip route 192.168.72.0 255.255.255.0 192.168.210.2
ip route 192.168.73.0 255.255.255.0 192.168.210.2
ip route 192.168.74.0 255.255.255.0 192.168.210.2
ip route 192.168.80.0 255.255.255.0 192.168.210.2
ip route 192.168.81.0 255.255.255.0 192.168.210.2
ip route 192.168.82.0 255.255.255.0 192.168.210.2
ip route 192.168.83.0 255.255.255.0 192.168.210.2
ip route 192.168.84.0 255.255.255.0 192.168.210.2
ip route 192.168.85.0 255.255.255.0 192.168.210.2
ip route 192.168.96.0 255.255.255.0 192.168.210.2
ip route 192.168.97.0 255.255.255.0 192.168.200.2
ip route 192.168.100.0 255.255.255.0 192.168.200.2
ip route 192.168.110.0 255.255.255.0 192.168.200.2
ip route 192.168.120.0 255.255.255.0 192.168.200.2
ip route 192.168.130.0 255.255.255.0 192.168.200.2
ip route 192.168.140.0 255.255.255.0 192.168.200.2
ip route 192.168.150.0 255.255.255.0 192.168.200.2
ip route 192.168.253.0 255.255.255.0 192.168.210.2
ip route 192.168.254.0 255.255.255.0 192.168.200.2
Thanks for your quick responses!
My parent company will be on vlan 200 (192.168.200.0/24), my company will be on vlan 206 (192.168.206.0/24). You're saying that we let the switch do the routing. So let's say interface vlan 200 on the switch has an IP of 192.168.200.1 and interface vlan 206 has an IP of 192.168.206.1.
Now the firewall has an interface on vlan 200 with an IP 192.168.200.3 and another interface on vlan 206 with an IP 192.168.206.254. How do I go about sending default traffic for 192.168.200.0/24 to 192.168.200.3 and another default route for 192.168.206.0/24 to 192.168.206.254?
I should add that we have a bunch of other routes already defined in the switch for subnets that are used at both production sites for the parent company and my company. Maybe that will help. :)
Switch 2 (DR Site)
ip route 0.0.0.0 0.0.0.0 192.168.200.3
ip route 10.0.17.0 255.255.255.0 192.168.200.2
ip route 192.168.1.0 255.255.255.0 192.168.210.2
ip route 192.168.10.0 255.255.255.0 192.168.210.2
ip route 192.168.13.0 255.255.255.0 192.168.210.2
ip route 192.168.15.0 255.255.255.0 192.168.210.2
ip route 192.168.16.0 255.255.255.0 192.168.210.2
ip route 192.168.17.0 255.255.255.0 192.168.210.2
ip route 192.168.18.0 255.255.255.0 192.168.210.2
ip route 192.168.19.0 255.255.255.0 192.168.200.2
ip route 192.168.33.0 255.255.255.0 192.168.200.2
ip route 192.168.40.0 255.255.255.0 192.168.200.2
ip route 192.168.41.0 255.255.255.0 192.168.200.2
ip route 192.168.42.0 255.255.255.0 192.168.200.2
ip route 192.168.43.0 255.255.255.0 192.168.200.2
ip route 192.168.50.0 255.255.255.0 192.168.200.2
ip route 192.168.51.0 255.255.255.0 192.168.200.2
ip route 192.168.52.0 255.255.255.0 192.168.200.2
ip route 192.168.61.0 255.255.255.0 192.168.210.2
ip route 192.168.62.0 255.255.255.0 192.168.200.2
ip route 192.168.71.0 255.255.255.0 192.168.210.2
ip route 192.168.72.0 255.255.255.0 192.168.210.2
ip route 192.168.73.0 255.255.255.0 192.168.210.2
ip route 192.168.74.0 255.255.255.0 192.168.210.2
ip route 192.168.80.0 255.255.255.0 192.168.210.2
ip route 192.168.81.0 255.255.255.0 192.168.210.2
ip route 192.168.82.0 255.255.255.0 192.168.210.2
ip route 192.168.83.0 255.255.255.0 192.168.210.2
ip route 192.168.84.0 255.255.255.0 192.168.210.2
ip route 192.168.85.0 255.255.255.0 192.168.210.2
ip route 192.168.96.0 255.255.255.0 192.168.210.2
ip route 192.168.97.0 255.255.255.0 192.168.200.2
ip route 192.168.100.0 255.255.255.0 192.168.200.2
ip route 192.168.110.0 255.255.255.0 192.168.200.2
ip route 192.168.120.0 255.255.255.0 192.168.200.2
ip route 192.168.130.0 255.255.255.0 192.168.200.2
ip route 192.168.140.0 255.255.255.0 192.168.200.2
ip route 192.168.150.0 255.255.255.0 192.168.200.2
ip route 192.168.253.0 255.255.255.0 192.168.210.2
ip route 192.168.254.0 255.255.255.0 192.168.200.2
Thanks for your quick responses!
ASKER CERTIFIED SOLUTION
membership
Create a free account to see this answer
Signing up is free and takes 30 seconds. No credit card required.
ASKER
I think I'm following you, which is kind of what I'm doing between CompanyA and the DR site with the IPs used on the 192.168.210.0/24 subnet just for routing. The parent company chose to use 192.168.200.2 which just places broadcast traffic over their metro-e connection from the DR site. I'm assuming you would recommend that Parent company switch use 192.168.210.4 for routing, since 192.168.210.2 is CompanyA, 192.168.210.1 is DR switch, and then assign 192.168.210.3 on the Inside interface of firewall. Would that still allow me to use my firewall to segregate traffic between Parent, CompanyA, and DMZ? Traffic between those three domains should traverse the firewall.
Also, I did eliminate some routes on the DR switch that were not in use and was able to summarize a couple. I was able to reduce the routing entries from 39 to 21. I used Cisco's Route Summary Tool.
I created a diagram of the current architecture so you can visually see what I'm trying to accomplish.
Routing-diagram.jpg
Also, I did eliminate some routes on the DR switch that were not in use and was able to summarize a couple. I was able to reduce the routing entries from 39 to 21. I used Cisco's Route Summary Tool.
I created a diagram of the current architecture so you can visually see what I'm trying to accomplish.
Routing-diagram.jpg
I'm assuming you would recommend that Parent company switch use 192.168.210.4 for routing, since 192.168.210.2 is CompanyA, 192.168.210.1 is DR switch, and then assign 192.168.210.3 on the Inside interface of firewall. Would that still allow me to use my firewall to segregae traffic between Parent, CompanyA, and DMZ? Traffic between those three domains should traverse the firewall.
Correct, to not go into a confusion, just remember this:
Router and firewall knows about every network in your device, it doesn't matter if you have different subnet or interface.
Let say this is your network, forget about the rest of the sub-interface
INSIDE: 192.168.200.1/24 ---Could be any IP--
OUTSIDE: 100.100.100.2/30
DMZ: 192.168.201.1/24 --Could be any IP--
Switch DR
On your L3 switch you need to configure a port L3 and give an ip address acting as a gateway to your firewall, Ex:
int fa0/1 no switchport
ip address 192.168.200.2 255.255.255.0
Description Uplink.
This guy the @SWITCH DR@ will be your gateway for all your traffic in your switch. Example:
Let say you have subnets from 1-254, instead of creating all those routing table above you can short it and reduce the processing of your ASA.
This is your subnet of the total network: 192.168.0.0 255.255.0.0.
Now, on the switch you can type this Ip route 0.0.0.0 0.0.0.0 192.168.200.1-- which is the ASA gateway INSIDE.
That means any network from this switch can forward traffic to my next hop gateway.
From your firewall you need to create an static route back to the switch to respond to his reply. Ex:
route inside 192.168.0.0 255.255.0.0 192.168.200.2 ---This is the switch gateway, the one you have configured with the IP--
Also, you need to nat this subnet as well 192.168.0.0/16 that way all the network can go to the internet.
This is how you have it I
object network CompanyA_Inside
subnet 0.0.0.0 0.0.0.0 --- This is good because you are natting all the network, but in my view perspective I don't recommend it.
object network CompanyA_Inside
nat (companyA_inside,Outside) dynamic interface
Does that make sense?
Attached there's a packet tracer example I've made long ago.
Cameras.txt
ASKER
Thanks for your help Hemil.
You're welcome dude.!
Configure the L3 Switch to be the gateway of all the hosts in your DR site as you did.
interface Vlan210
ip address 192.168.210.1 255.255.255.0 ------------Good--------
interface Vlan206
ip address 192.168.206.1 255.255.255.0 ------------Good--------
interface Vlan200
ip address 192.168.200.1 255.255.255.0 ------------Good--------
Next thing is summarize those subnets and routed to the next hop address "Firewall" gateway
On the firewall you need to route your ip with the switch gateway.
To me it's a good practice to keep it that way. Even though there's so many ways to accomplish it.
Hope it helps,