.unable to open exchange management console: exchange 2013

Michael Cardenzana
Michael Cardenzana used Ask the Experts™
on
ok, this has been kicking my butt. for a month now I have not been able to find a solution for this. I get this error immediatly when I try to open power shell or exchange management console.


Any help would be great!

Thanks, guys


Problem signature:
  Problem Event Name:      PowerShell
  NameOfExe:      powershell.exe
  FileVersionOfSystemManagementAutomation:      6.3.9600.18773
  InnermostExceptionType:      System.ArgumentException
  OutermostExceptionType:      System.ArgumentException
  DeepestPowerShellFrame:      SHostUserInterface.GetTranscriptOptionFromSettings
  DeepestFrame:      System.IO.Directory.CreateDirectory
  ThreadName:      Consol.. main thread
  OS Version:      6.3.9600.2.0.0.272.7
  Locale ID:      1033
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Michael CardenzanaSystems Administrator

Author

Commented:
Error
Systems Administrator
Commented:
I actually figured this out.

turns out that I had enabled in the gpedit of the exchange server, specificly <computer configuration/administrative templates/windows components/windows powershell.

I had enabled:
"turn on script exection"
"Turn on powershell transcription"

I set these back to not defined and all is working in powershell. I have also circled them in the image attached.powershell-image.png

Commented:
Hello,


Error when launching PS (Normal and ISE):
Fault bucket , type 0
Event Name: PowerShell
Response: Not available
Cab Id: 0

Problem signature:
P1: powershell.exe
P2: 6.3.9600.17400
P3: System.ArgumentException
P4: System.ArgumentException
P5: SHostUserInterface.GetTranscriptOptionFromSettings
P6: System.IO.Directory.CreateDirectory
P7: Consol.. main thread
P8:
P9:
P10:

Attached files:

These files may be available here:


Analysis symbol:
Rechecking for solution: 0
Report Id: 6929f46d-85ec-11e8-80cb-005056b277d9
Report Status: 262144
Hashed bucket:

I had the same problem as Michael and when I checked the Group Policy, minedwas set as not configured. I enabled them and set them again as not configured. No go. I read about the entry from here: https://getadmx.com/?Category=Windows_10_2016&Policy=Microsoft.Policies.PowerShell::EnableTranscripting and realized that this of course, had a corresponding registry entry.

I took a look and low and behold, it was set to 1 in the registry but on the UI it says "not configured". Set it to 0 and it worked.

Software\Policies\Microsoft\Windows\PowerShell\Transcription\EnableTranscripting

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial