Auto Reply to every email received - Exchange Online/Office 365

I am currently using Office 365 and the requirement is:
- Setup auto reply for a mailbox
- Auto reply email has to be sent out to every email received (NOT like normal out of office auto reply where it only sends out auto reply only once to each email id)

Is there any options available to achieve the above on server side without setting up Outlook profile?

Thank you
G LAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Amit KumarCommented:
Using OOF it is not possible but you can create it using Outlook rules. Limitation with Outlook rule is it will use a template so Outlook  must be opened on a client which will run subjected rule.
1
AlanConsultantCommented:
Hi,

I don't know of any built-in option for this.

One option might be to setup an OOO for the destination mailbox, then disable and re-enable it once a day, once an hour, once a minute, or whatever time period suits.

If we go with the 'once a minute' option for the sake of discussion, then it would mean that unless a sender sent two emails inside of a minute (30 seconds on average, but 60 seconds if the timing was just wrong), then they would receive the OOO message in response to each email.

Obviously you would have to set this up as either a scheduled task, or a script that ran on startup of the server (say) and just looped once per minute.

I can't see any reason why it would cause a problem, but I have never tried this, so just noting the possibility that it could.

The powershell code would just be something like:

While($True)
{
Set-MailboxAutoReplyConfiguration -Identity 'username@example.com' -AutoReplyState Enabled
Start-Sleep -s 60
Set-MailboxAutoReplyConfiguration -Identity 'username@example.com' -AutoReplyState Disabled
}

Open in new window


Change the 60 (seconds) to whatever works for you, and the username@example.com to whatever the mailbox name is.

Alan.
0
S_K_SCommented:
What you ask for is practically possible and I have been able to implement this for a customer in past using Outlook profile.

Use the below steps to achieve this via Outlook 2010 and above:

1.      Click on the Rules button and select Create Rule
2.      Click on the Advanced Options button
3.      Click on the Next without selecting any option.
4.      Click on Yes to proceed when prompted
5.      In the top half of the Rules Wizard, select the checkbox next to “have server reply using a specific message”.
6.      On the bottom half of the box, click on the underlined “a specific message”.
7.      Clicking the link will open the message composition window. Type in a subject and compose your message. The subjectline will be used to identify your message in the Rules.
8.      Click Save & Close on the menubar.
9.      Click on the Next button. Click on the Next button again unless you wish to choose exceptions to your Auto Reply rule.
10.      Give a name to your new rule and select finish
 
Kindly test and let us know if this works for you or not please. PS: You do not have to keep Outlook open for this to work.

You may try using Transport Rule as such if this is a user specific need as such.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

G LAuthor Commented:
Hi S_K_S,

I tried your steps above as there is no native option in Exchange Online or O365. The solution I am trying to implement is for a shared mailbox and I setup the shared mailbox in Outlook using my credentials (which has full access to the shared mailbox).

After creating the new rule, I can see it in O365 settings:
Inbox Rules
But I am not receiving any auto reply email. Looks like I am missing on something.

Thank you.
0
S_K_SCommented:
Yes such options are normally needed for Shared Mailboxes only and you correctly followed the needed steps by Creating Outlook profile for the Shared Mailbox using the Credentials of your account (which has FullAccess).

To understand why things are not working on your side may I request you to share the screenshots from Outlook for the Rule you have created please? Based on that I\we can make suggestions to identify the missing part and help fixing this for you.
0
G LAuthor Commented:
Below is the Outlook Rules and Alerts configured:
Outlook Rule
Thank you.
0
S_K_SCommented:
Apologies on the delay on responding GL. Are you able to share the settings on how things look like from Advanced section please. Need to see what options were selected. If need be will set up a test on my machine and get back to you on the same soonest.
0
G LAuthor Commented:
I believe you wanted the below screen shot:
Inbox-rule-wizard--Outlook-settings.jpg
Thank you.
0
S_K_SCommented:
Hi GL,

I performed exactly the same steps and the Auto-Reply worked as expected. In my test environment we have blocked external Auto-Replies at ORG Level. That said looking at your screenshot I believe you have set the rule properly and it should work. Assuming you saved that Auto Reply message appropriately.

Have you tested Internal users if they get Auto-Reply or not and then we can switch the thought process on External users.

Run a Quick MessageTrace for emails sent by this mailbox on which you have the Rule in place and I am sure you will see something that will indicate what may be happening.
0
G LAuthor Commented:
Hi S_K_S,

Thank you for your time.

I did not receive any auto reply for internal email accounts as well. Based on the previous discussion, it is confirmed that steps are correct and will try it out on different computer/user and also will investigate Massage Trace.
0
AlanConsultantCommented:
Hi G L,

Did you get that to work?

My experience has been that it doesn't, but happy to find out differently.

If not, have you tried what I suggested further above?

Thanks,

Alan.
0
S_K_SCommented:
A known working Solution (personally tested) was provided. Alternate options also provided by other Experts as well
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Office

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.