iOS 11.0.2 and iOS 11.0.3

If your answer is factory reset, please skip this question.

User reported a problem for iPhone 7.

On iOS 11.0.2, outgoing phone call  can be made but no incoming phone call could be made.

On iOS 11.0.3, the situation is reverse. No outgoing phone call could be made whereas sometimes incoming phone calls can be made.

However, if the user dials a USSD code which is carrier-specific, it will be OK to dial an outgoing call for once.

Already contacted the carrier and the SIM card is fine on another Android phone or iPhone.

How to fix without factory reset?

Phone call is a basic feature of a smartphone and I have not encountered similar problem in any Android phones.
LVL 53
Jackie ManIT ManagerAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ITSysTechSenior Systems AdministratorCommented:
1.  Reset Network Settings: Tap Settings > General > Reset > Reset Network Settings.
2. Turn Airplane mode on, wait for the airplay symbol to appear in the status bar, and then turn it off again.
3. Verify blocked phone numbers: go to Settings> Phone> Block. Make sure the phone number you try to call is not in the block list.
0
Jackie ManIT ManagerAuthor Commented:
Thank you so much for your prompt reply.

1. & 2. have been tried but no success. User has already tried to reset all settings, not just network settings but problem is the same. The error message is call failed.

3. All telephone numbers cannot be called.
0
ITSysTechSenior Systems AdministratorCommented:
Have you tried switching to a different network band? Go to Settings > Cellular > Cellular Data Options > Enable LTE and turn off Enable LTE, 4G, or 3G (this option will depend on your carrier and device model).
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Jackie ManIT ManagerAuthor Commented:
Good suggestion.

I will try it on tomorrow.

Theoretically, if VoLTE is not enabled, mobile network will be switched from 4G to 3G automatically.
0
Jackie ManIT ManagerAuthor Commented:
User did not want further help. From my experience, it is related to the carrier.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
iOS

From novice to tech pro — start learning today.