Crystal report indenting

Hi..

I am new to CR,

I am getting string from db, that has numbered lines. but when comes to output in CR the align not correct.

the input given is shown below.

1.      Payment of any kind of Fees to  Authorities for approval of  Shop Drawing Inspection & for 24 x 7 Emergency
        Maintenance System is not in our  Scope.
2.      The above prices are based on survey only, replacement of equipment's found damaged/during or after the
        above mentioned works will   be charged extra.


but i am getting the output like this

1.      Payment of any kind of Fees to  Authorities for approval of  Shop Drawing Inspection & for 24 x 7 Emergency
Maintenance System is not in our  Scope.
2.      The above prices are based on survey only, replacement of equipment's found damaged/during or after the
 above mentioned works will   be charged extra.


waiting for your help.
vrv rajAsked:
Who is Participating?
 
James0628Commented:
It has been a week since you posted your question.  Are you still looking for help with this?

 If so ...

 Are the numbered lines (1 and 2 in your example) in separate records (or fields), or are all of the numbered lines combined in one string field?

 Are the line breaks (eg. between "Emergency" and "Maintenance") part of the data, or is that just where CR hits the end of the field on the report and goes to a new line?

 If each numbered line is in a separate record, and CR is providing the line breaks, then I think that there is a way to do it.  Go to the field format and on the Paragraph tab, set the Left indentation to 0.3 inches, and the First Line indentation to -0.3 (negative 0.3).  The First Line setting is relative to the rest of the paragraph, so if you use Left to indent the paragraph, and then use a negative number for First Line, the first line is indented less than the rest of the paragraph.

 That was just a weird idea that I got, and it turns out that it works.  :-)

 FYI, you can't "reverse indent" the first line more than the paragraph is indented, so Abs (First Line) has to be <= Abs (Left).

 James
0
 
Raghavendra HullurSoftware DeveloperCommented:
Hi,
The output samples you have shown looks similar.
Can you attach the report with sample saved data and a screenshot for how you want it to be displayed?
0
 
mlmccCommented:
I just tried to do what you want.  I don't see a way to do it through the normal formatting techniques.  You can indent the first line but or all the lines.  There doesn't seem to be a way to indent all lines after the first.

mlmcc
0
Cloud Class® Course: Ruby Fundamentals

This course will introduce you to Ruby, as well as teach you about classes, methods, variables, data structures, loops, enumerable methods, and finishing touches.

 
Raghavendra HullurSoftware DeveloperCommented:
Hi,
All that data, is it a single record or multiple records?
I copied the content from input string and imported it onto Oracle database with a varchar2 column and created a report and I see the data is getting displayed as per your original inputs. Sample report attached.
temp5.rpt
0
 
mlmccCommented:
The text you copied included the formatting.  I suspect his text doesn't have a CR/LF and tab or spaces in it.

mlmcc
0
 
mlmccCommented:
Interesting James.  I tried that but I set the First Line indent first and it wouldn't accept a negative number.  Since it works the other way, it makes sense.  I didn't think to try it the other way round.

mlmcc
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.