Can't access files behind two routers

Hi,
I've tried a couple of times to access files on my home NAS when outside the home, but can't. Recently, I installed plex streaming server app on a home pc, but same problem, can anyone advise what particular setting I need to change? Do I need to put the ISP modem in Bridger mode?
mewtdAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

AlanConsultantCommented:
Hi,

Without knowing your full setup, it is hard to be specific, but to make this work, you need to map a port from the outermost router to the IP address of the inner router (from the outermost router's perspective), and then map the same port from the inner-most router to the IP of the endpoint (Plex Server, say).

Alan.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Steve McCarthy, MCSE, MCSA, MCP x8, Network+, i-Net+, A+, CIWA, CCNA, FDLE FCIC, HIPAA Security OfficerIT Consultant, Network Engineer, Windows Network Administrator, VMware AdministratorCommented:
So you need to look at all your networking settings as well as your permissions.  This should fix you up.

If you have a home router or one at the office, then you "should" be in bridge mode.  To expand on Alan's point, you would map the port (port forwarding) from that router or cable modem that holds your public IP address to your endpoint on each end.  You can do this without being in bridge mode, you just have to move your port forwarding to your cable modem then.

As far as hitting it internally, some routers don't function so well for internal DNS, so if you want to avoid that issue, use the IP address to hit the device.  Finally, make sure you have the permissions on the shares.
0
KimputerCommented:
If you are behind two routers, you can still access the server, as long as you have the same NAT rules applied to both.
ISP router, public port NAT open ports xx to yy internal port, to WAN IP of router2
Router 2 also has to open ports xx to yy of internal port, to IP of the server (could be NAS, plex etc etc)
0
Cloud Class® Course: CompTIA Healthcare IT Tech

This course will help prep you to earn the CompTIA Healthcare IT Technician certification showing that you have the knowledge and skills needed to succeed in installing, managing, and troubleshooting IT systems in medical and clinical settings.

mewtdAuthor Commented:
HI,
Thanks all for responses.
I have logged on to the ISP modem and set port forwarding and port triggering for port 32400 to the IP address of the netgear router.
On the netgear router, I have set port forwarding and port triggering for the same port to the IP address of the computer with PLex installed.
I have done this for both UDP and TCP.
On the computer with Plex installed, I have ensured that it is broadcasting on port 32400.
I have checked the firewall on the computer, and it is allowing Plex in and out.

Still no luck accessing from my iPhone. "Couldn't connect to server"...
0
KimputerCommented:
Don't use port forwarding and port triggering at the same time for what you need. In this case, remove all port triggering, as port forwarding should be the only rule.
0
mewtdAuthor Commented:
A note: the ISP router is on the subnet 192.168.0.1 and the netgear is on the subnet 192.168.1.0, is that part of the problem?
0
mewtdAuthor Commented:
Also, when I go to portchecker.co/check and check the status of port 32400, it says the port is closed....
0
KimputerCommented:
Shouldn't be a subnet problem. (as the subnet mask is 255.255.255.0)
Check the port locally first (192.168.1.x, whatever the Plex server is). Then on the router subnet (192.168.0.x, whatever the router 2 is), and finally use the portchecker.co
0
mewtdAuthor Commented:
Hi Kimputer, I can run a netstat -an to check the port Is open on the computer with Plex installed, but can you please advise:
- how to open the port if the above command indicates it is closed
- When you say " Then on the router subnet (192.168.0.x, whatever the router 2 is)" , How do I check if the port is open on the router subnet, sorry I'm not clear on how to do that...

Thanks for help.
0
KimputerCommented:
Open the port is done on the firewall, and of course, depends on which firewall, since every firewall has its own routine to open the port. For windows firewall do this:
https://docs.microsoft.com/en-us/sql/database-engine/configure-windows/configure-a-windows-firewall-for-database-engine-access (except where it says 1433, use 32400)
First check locally on the server itself (if it's Windows)

telnet localhost 32400

See if there's a response.

Then move to another computer on the same subnet (obviously replace x with the correct number):

telnet 192.168.1.x 32400

Then move the test computer/laptop to the ISP router and do (replace x with the correct number, which is the IP of router2):

telnet 192.168.0.x 32400

And finally do the internet check with portchecker.co/check
0
mewtdAuthor Commented:
Hi, I've tried everything, and the port remains closed. I'm wondering now if the ISP blocks the port and no matter what I'm doing it makes no difference as it is closed on the ISP modem?
I cannot see any NAT option on the ISP modem.
I have the port 32400 forwarding from the ISP modem to the netgear router.
On the netgear router, I have the port forwarding to the computer with Plex installed.
0
mewtdAuthor Commented:
Can't telnet to either the modem or to the netgear on port 32400...
0
AlanConsultantCommented:
Hi,

Can you telnet to the Plex Server from a laptop (say) that is connected to the ISP Modem / Router (ie the laptop is 'outside / wan-side' of the NetGear router?

If so, then it must be either the ISP Router, or the ISP itself (their bulk routers).  Maybe give them a call and ask?  They might be able to unblock for you.  My ISP blocks outgoing connections to Port 25 by default, but will disable that block (allow the packets) if you request it.

What type of connection do you have?  Could you put another router outside the ISP router and test from a laptop connected to that, even if that router has no internet connectivity while you do that test?

Thanks,

Alan.
0
KimputerCommented:
Please stop considering it's an ISP modem/router issue, since you didn't even test the port locally on the server itself, and also on the LAN. The router2 wan check, and then finally ISP WAN check is only after you solve the previous problem first. It's quite useless to even speculate about those problems without figuring out locally what's wrong.
0
mewtdAuthor Commented:
HI,

I ran netstat -a on the system that is running Plex, and it says it is listening on port 32400

In Plex, the remote access settings shows a green arrow going from my public IP to my internal desktop, but a big red X in front of the public IP.

That's where I am getting the idea that the ISP is blocking the port.
0
KimputerCommented:
If you want to be sure, always diagnose your problem step by step. In this case, start with the beginning. As I said, check local, then LAN then WAN Router 2, then WAN ISP router.
0
mewtdAuthor Commented:
I changed the port to a totally different port, just to test the whole process again.
Decided to use port 43311.
Set this port in PLex as the default port.
Set inbound and outbound rules on the firewall for the desktop hosting Plex.
Set port forwarding on the ISP modem for port 43311 to go to the IP of the netgear router.
On the netgear, set a port forwarding for port 43311 to go to the desktop with plex.
Enabled remote access in plex.
Green lights all the way for about 5 seconds, then the green light changes to a red light at the internet hitting my external IP on port 43311.

I will get on to the ISP.
0
mewtdAuthor Commented:
ISP said the router was configured for ipv6 instead of ipv4, and that they would change this.
I have to re-set the modem to factory and setit up again when I get home, and they assure me this will sort out the port forwarding issue.
Will report back when done, with an update on whether it resolves or not...
0
KimputerCommented:
Seems you really don't want to do step by step checking, but that's ok if you really want that. Usually modems configured for ipv6 won't show the portforwarding options (they'll be revealed after you set it up as ipv4). So it's kind of strange why you keep saying you configured it.
0
mewtdAuthor Commented:
HI, I understood that the config of the modem for iPV6 was on their side and that they had adjusted this from their side. Following that adjustment, I needed to re-set the modem, which I did, which resulted in a completely fresh IP address.
However, port remains closed.
I rang them there and they said I need to phone the level 3 support to get port forwarding configured.
0
AlanConsultantCommented:
Hi Mewtd,

How did you go with the Level 3 support people?

Is the port forwarding working now?

Alan.
0
mewtdAuthor Commented:
HI, I cannot get any answer from the Level 3 number!! I have tried many times, it just rings out, no one answering.

I will keep trying, or go back to level 2 to see what the story is...
0
mewtdAuthor Commented:
HI All,

issue is now resolved, will award points for help now.

The ISP modem is located at 192.168.0.1

The problem seems to have been that the netgear router beyond the modem, which is accessible via two different internal IP addresses.

I can reach it by going to either 192.168.0.11 OR 10.0.0.1

The port forwarding from the ISP modem had been pointing towards 10.0.0.1, and once this was changed to the alternative IP of 192.168.0.11 the plex came online from outside and all has been working perfectly since.

Thank you all for help.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.