spanning-tree issue

I dont know why I'm having this issue but it's happenig. I am working on basic topology. Router to layer 3 switch to little trendnet L2 switch to hosts. Image attached. Very simple. For some reason, the switch in the middle, STP is blocking the port. I have no idea why. How can I fix this and why it this even blocked, there is no redundant links
map.png
interface GigabitEthernet0/4
 switchport access vlan 100
 switchport mode access
 switchport nonegotiate
 switchport port-security maximum 4
 switchport port-security violation restrict
 switchport port-security aging time 60
 switchport port-security aging type inactivity
 switchport port-security
 no keepalive
end

Open in new window


TEST_SW#sh spanning-tree blockedports

Name                 Blocked Interfaces List
-------------------- ------------------------------------
VLAN0100             Gi0/4

Number of blocked ports (segments) in the system : 1

Open in new window


There is no even loop. It's one link to the L2 switch thats all.

Can anyone help that actually know whats going on here? Lately I've been getting a lot of answers that were useless to me and did not help. Thank you
LVL 3
Shark AttackNetwork adminAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Jeremy WeisingerSenior Network Consultant / EngineerCommented:
Well I'm not an expert on Cisco stuff but if the trendnet switch supports spanning tree AND Gi0/4 is an edge port AND BPDU guard is globally enabled on the Cisco switch, the Gi0/4 would enter a blocking state because is would receive an BPDU packet from the trendnet switch.

You can try disabling BPDU Guard or Portfast on Gi0/4 and see if that fixes it... or wait for someone that knows Cisco better. :)
0
Shark AttackNetwork adminAuthor Commented:
yeah , thats not the case. BPDU Guard is disabled, it's not a portfast port. Also, the trendnet is a L2 switch, does not do STP
0
Shark AttackNetwork adminAuthor Commented:
actually I resolved it, just made the port a trunk. Makes sense. I overthought the whole thing. Thanks anyways.
1

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Shark AttackNetwork adminAuthor Commented:
because it is the solution
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Switches / Hubs

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.