Mount Windows share in AIX 7.2

Does anyone have an easy way to mount a Windows share in AIX?  I've seen multiple posts regarding CIFS, but most are ancient (using AIX 5 or 6 and/or Windows 2008 and earlier).  I am using AIX 7.2 and need to mount from both Windows 2008 and 2012 Server.  We are getting the "There was an error connecting the share or the server. Make sure the lsdev command shows that device nsmb0 is in..." message and I've seen several pages address it, but none successfully beyond AIX 7.
Doug McKennaAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

carlmdCommented:
I have this working in several locations.

First use "smit cifs_fsmnt" to set up the mount.

more info: https://www.ibm.com/support/knowledgecenter/en/ssw_aix_72/com.ibm.aix.cmds3/mkcifsmnt.htm

Some things to check after you set it up.

At "/" check for a directory with the mount point name you specified. Permissions should be rwx.
The Server name, User name, password you entered should allow you to connect to the windows share. Try it from a pc to the server to be sure it works.

There should be an entry in /etc/filesystems that looks like the following:

/winshare:
        dev             = /UNIXLINK      (share name)
        vfs             = cifs
        nodename        = iporname/username/password
        mount           = true
        type            = cifs
        options         = uid=0,gid=0,fmode=777,wrkgrp=name
        account         = false

Essentially you can use a command like the following to do the mount.

mount -v cifs -n serverip/username/password -o wrkgrp=domain,fmode=755 /sharename /localmountpoint

Please note that nsmb0 must be available to work...
lsdev -C | grep nsmb0
nsmb0      Available             N/A
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Travis GrindalCommented:
In addition to the other answer...
The "nsmb0" is part of the "bos.cifs_fs" fileset.
If the Windows user is a local Windows account (not AD), then you can drop off the "wrkgrp" option.
0
Seth SimmonsSr. Systems AdministratorCommented:
No comment has been added to this question in more than 21 days, so it is now classified as abandoned.

I have recommended this question be closed as follows:

Split:
-- carlmd (https:#a42407923)
-- Travis Grindal (https:#a42427672)


If you feel this question should be closed differently, post an objection and the moderators will review all objections and close it as they feel fit. If no one objects, this question will be closed automatically the way described above.

seth2740
Experts-Exchange Cleanup Volunteer
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
AIX

From novice to tech pro — start learning today.