How can I permanently remove a folder's "hidden" attribute and make it always visible?

I am running Windows 7 Professional on my computer that also has a USB external Western Digital passport drive.

I did a robocopy of the "Documents" folder from my C Drive to my F drive (USB external WD passport drive).

When I view the F: drive in Windows Explorer, I CANNOT see the "Documents" folder.

However, I CAN see the "Documents" folder on the F: drive when I click on Windows Explorer:  Organize \ Folder and Search Options \ View \ Show hidden files, folders and drives.

How can I PERMANENTLY remove the hidden attribute on the external drive to make the "Documents" folder ALWAYS visible without have to click:  Show hidden files, folders and drives?

Thanks for your help!
eemmpphAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Seth SimmonsSr. Systems AdministratorCommented:
right-click the documents folder and go to properties
uncheck 'hidden' near the bottom and click ok
0
eemmpphAuthor Commented:
The hidden box is "greyed out" with a check-mark in it
0
Seth SimmonsSr. Systems AdministratorCommented:
can't you still uncheck it?
it means that not everything in the folder is hidden; it's mixed
toggling that will go back and forth between all hidden and nothing hidden
0
eemmpphAuthor Commented:
See image below:

Docs Hidden Attribue
0
eemmpphAuthor Commented:
I would like it to be "nothing hidden".
0
Seth SimmonsSr. Systems AdministratorCommented:
open elevated command prompt then type...

f:
attrib -h -s documents /d
0
Shaun VermaakTechnical SpecialistCommented:
Or for goog measure

f:
attrib -r -a -s -h documents /d

Open in new window

0
eemmpphAuthor Commented:
A message pops up that says:

The /D switch is only valid with the /S switch.
0
Seth SimmonsSr. Systems AdministratorCommented:
attrib -h -s documents /d /s
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
eemmpphAuthor Commented:
I did your original suggestion:

attrib -r -a -s -h f:\documents /s /d

and IT WORKED!

Now I can see the documents folder without having to check the box "Show hidden files, folders and drives".

Thank you very much!
0
eemmpphAuthor Commented:
Thank you very much!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 7

From novice to tech pro — start learning today.