Cisco LACP trunk ports

Hi

I need to setup two ports on my Cisco switch with lacp trunk ports. can someone advise on the commands.

I'm familiar with HP but not so much with Cisco.
LVL 2
Technical InformationAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Hemil AquinoNetwork EngineerCommented:
You want to ether channel two ports on Cisco

Here is what you do:

SW1#conf t
SW1(config)#interface range f0/1-2
SW1(config-if)#switchport trunk encapsulation 802.1q
SW1(config-if)#switchport mode trunk
SW1(config-if)#channel-group 10 mode active
SW1(config-if)#end

SW1#conf t
SW1(config)#interface range f0/1-2
SW1(config-if)#switchport trunk encapsulation 802.1q
SW1(config-if)#switchport mode trunk
SW2(config-if)#channel-group 10 mode pasive
SW2(config-if)#end

If you want to see the result, execute this command:

SW1# show etherchannel summary
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Technical InformationAuthor Commented:
Great thanks, Did you mean Sw2 on the 2nd part?
0
Hemil AquinoNetwork EngineerCommented:
You can run the command in both switches.
That is just for verification.
0
Technical InformationAuthor Commented:
Thank,

I have more that 2 switches now. So more LACP trunks will need to be setup.

So if I run this on the 1st and 2nd Switches

SW1#conf t
SW1(config)#interface range f0/1-2
SW1(config-if)#switchport trunk encapsulation 802.1q
SW1(config-if)#switchport mode trunk
SW1(config-if)#channel-group 10 mode active
SW1(config-if)#end

SW2#conf t
SW2(config)#interface range f0/1-2
SW2(config-if)#switchport trunk encapsulation 802.1q
SW2(config-if)#switchport mode trunk
SW2(config-if)#channel-group 10 mode pasive
SW2(config-if)#end

And run this on the 2nd and 3rd switches

SW2#conf t
SW2(config)#interface range f0/3-4
SW2(config-if)#switchport trunk encapsulation 802.1q
SW2(config-if)#switchport mode trunk
SW2(config-if)#channel-group 11 mode active
SW2(config-if)#end

SW3#conf t
SW3(config)#interface range f0/3-4
SW3(config-if)#switchport trunk encapsulation 802.1q
SW3(config-if)#switchport mode trunk
SW3(config-if)#channel-group 11 mode pasive
SW3(config-if)#end

Would this work?
0
Hemil AquinoNetwork EngineerCommented:
Yes.!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Cisco

From novice to tech pro — start learning today.