VM imported to Esxi Server fails to open

Hi,
   I have a VM (Windows 2012 Server)   which  opens good in my VMplayer (Version 9.1) . But when I import it to ESXI Server ( vsphere client 6.0) the import is done successfully. But when I try to open the VM in ESXI, It gives the following error
" Failed to start the virtual machine.Module DevicePowerOn power on failed.
Unable to create virtual SCSI device for scsi0:0, '/vmfs/volumes/599cc609-38480b40-4453-
782bcb2f6bfb/MyVM/SqlVM/C Drive-000003.vmdk'
Failed to open disk scsi0:0: Unsupported or invalid disk type 2. Ensure that the disk has been
imported"
Sam OZAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Dariusz TykaICT Infrastructure Specialist Senior Commented:
Was the VM exported using ovftool? As an alternative you can try to use VMware Converter.
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
You *MUST* use VMware Converter to MOVE Machines between VMware Player/Workstation and ESXi. The virtual disk format is not compatible between products.

Please see my EE Article

HOW TO: FAQ VMware P2V Troubleshooting

HOW TO:  P2V, V2V for FREE - VMware vCenter Converter Standalone 6.1

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Chach DalSantoSolutions & Systems ArchitectCommented:
Andrew is correct; its a different format and a different internal structure within the VMDK file.  Use the native VMware Converter to accomplish this.  It's free, and its what its made for.
SolarWinds® IP Control Bundle (IPCB)

Combines SolarWinds IP Address Manager and User Device Tracker to help detect IP conflicts, quickly identify affected systems, and help your team take near instantaneous action. Help improve visibility and enhance reliability with SolarWinds IP Control Bundle.

Sam OZAuthor Commented:
Hi I have tried with VConverter a couple of times and it is stuck at 1% and is not proceeding from there even after 12 hours ( But I have uploaded other VMs using Vconverter
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
what is the VM ?
compdigit44Commented:
By any chance did the VM have a snapshot in place. The drive listed in the error almost looks like it is reference a snapshot that is not longer present when is was moved.
Sam OZAuthor Commented:
I had snapshots. But I removed them all and tried VConverter
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Virtualization

From novice to tech pro — start learning today.