Wierd File Copy problem

This is the wierdest thing I ever saw...... I decided to post in here out of desperation. I'm developing in Access 2010. My program file is called Alchemy.accdb. I develop on my workstation in a folder called C:\Alchemy. When I want to publish an update, I copy Alchemy.accdb across to the server J:\ drive where my users can get a copy from.  I've been doing it this way for many years. It has always worked well up until now.

Last week I started finding that when I try and copy my program .accdb across to the server, the copy process hangs part way through. At that point I cannot kill the process, nor will my pc reboot. I have to hold the power button until it goes off.

File-copy-stalled.jpg
So for the past week i've been  doing things like updating drivers, disabling windows defender etc. All to no avail. I've had a question in here on the Windows 10 section, and for a while I thought I had a work around, but it turned out not to be the case. This morning I discovered some strange things....

1. Other file types will copy across to the server just fine. As far as I can see, it's just Access database files that won't copy.

2. if I rename some random large file as Alchemy.accdb it copies across just fine.

3. If I rename my program file to masquerade as a different file type, the copy process stalls.

So it seems that it is the actual file content rather than the name or file type which is causing the problem. I went into Windows Defender and added exclusion for both the source and destination folders. I also added an exclusion for Alchemy.accdb I've tried to copy various other .accdb files. They copy across just fine if they are less than 30M in size. Nothing larger will copy across.
Merlin-EngWorks ManagerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Jim Dettman (Microsoft MVP/ EE MVE)President / OwnerCommented:
Problems like this are usually a result of a bug in the NIC (Network card) driver.

 What have you been changing?  and are you on a wired or wireless connection?

 as a work around/test, can you zip the file, copy it, and then up-zip OK.

Jim.
0
Merlin-EngWorks ManagerAuthor Commented:
It's a wired gigabit connection via a cisco managed switch to a Dell SBS server.

I zipped it up and the first time I copied the zip file across it succeeded. I tried again and this time it stalled.

That's interesting for 2 reasons.

1. The zip file is only 15Meg and i've had no trouble copying .accdb files if they were that small.

2. If it's the file content causing the problem. The highly compressed nature of the .zip file would be unrecogniseable to the copy program.

Earlier today I renamed a 300Meg .exe file as Alchemy.accdb and that copied across just fine.
0
Jim Dettman (Microsoft MVP/ EE MVE)President / OwnerCommented:
Hopefully, you have a file that consistently fails.  If so, it will be easy to track down.

 I think my next step would be to check the event logs on both client and server.

 I'd also do a basic ping test and let it run continuously for about 15 minutes or so to see if anything odd is happening (ping <server> -t)

 I would also shutoff any firewall or anti-virus for a quick test (on client and server).

  If nothing pans out there, then changing the NIC drivers would be in order or at least disabling the advanced features.   Broadcom's have been buggy in the past, and that's usually what's in a Dell.

 Nothing unique by the way on the Dell?  ie. running teamed nic's, cards on different sub-nets, etc.

Jim.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

mbizupCommented:
Can you copy this file from a different computer to the network folder?
0
Merlin-EngWorks ManagerAuthor Commented:
@Jim: for consistency, it's any Access database >390meg which fails. Not always the first time, but always on the second attempt.

I'd already checked the Event logs. Nothing relevent in there.

I've got the ping test running. It seems fine.

I've tried shutting down the firewall and AV (windows defender)#

It's a Microsoft Driver on the Broadcom NIC

The server is SBS 2008. Nothing special about the network. ie 20 clients on a 192.168.16 subnet.

@Mbizup: Other clients can copy .accdb files to the same folder on the server just fine.
0
Jim Dettman (Microsoft MVP/ EE MVE)President / OwnerCommented:
<<@Mbizup: Other clients can copy .accdb files to the same folder on the server just fine.>>

 Sounds like the network setup on the station then.  I would try switching ports on the switch to see if that changes anything.

Jim.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Dale FyeCommented:
Probably irrelevant to this issue:  just out of interest, 390 M is large for an Access FE.  Is this a FE, BE, or combination of the two?

Miriam, nice to see you back.
1
Merlin-EngWorks ManagerAuthor Commented:
@DaleFye: Sorry that 390M was a typo. I meant to type 30M.

@Jim:

>>  I would try switching ports on the switch to see if that changes anything.

Spot on! I plugged into a different port and the issue went away.  I just can't imagine how a glitch on a switch port could have caused all this?
I have spent so many hours trying to fix this. Thank you so much.
0
Jim Dettman (Microsoft MVP/ EE MVE)President / OwnerCommented:
<<Spot on! I plugged into a different port and the issue went away.  I just can't imagine how a glitch on a switch port could have caused all this?>>

  Sometimes a switch will not auto negotiate a port correctly and end up working at a speed that the setup can't handle.  That can be due to a number of things. and you still might have an issue with the firmware in the switch or hardware on the port.    Also could be the client NIC that's the problem or cabling    You'll have to wait a bit (couple days) to see if the problem returns with the port your on now.

  If it does not, I would move back to the old port and see if the problem returns (and note the speed it is running at now vs when you switch back to the old port).  If it does, then I would power cycle the switch (again note the speed it ends up at).

  If you still have the problem after that and it's all running at the same speed (new vs old port, and same before / after reboot), then I would perform a cable scan and see if it is in compliance for the speed your pushing it at.   If you don't have a cable scanner, then I would force the port speed to 100mb/sec as a test.   If the problem goes away, then it's most likely the cable.   I would do this before updating any firmware or drivers, then update everything and test again.

 If you still have an issue at this point, then the port on the switch is bad.

Jim.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Access

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.