Exchange 2016 Autodiscover on Mobile Devices

Hello Experts

I am trying to setup an exchange email account Iphone 7. After providing the email and password, the iphone still asking additionals details like server, username.
I dont have any issue on external Outlook clients
I have created SRV and CNAME DNS records but still facing this issue.

Please advise
LVL 3
cciedreamerAsked:
Who is Participating?
 
MAS (MVE)EE Solution GuideCommented:
Hi cciedreamer,
4 things to check to make sure all phones will get configured automatic.

1.Autodiscover should be configured. Since all other outlook works fine autodiscover in place.
nslookup
autodiscover.youremail.com
This should return your Exchange server external IP.
or
nslookup
set q=srv
_autodiscover._tcp.youremail.com
Srv host name should be your external name.


2. Activesync virtual directories configured properly.  Use this to check.
Get-ActiveSyncVirtualDirectory -Server EX2016 | fl identity,internalURL,externalURL

Open in new window

Use this to set
Set-ActiveSyncVirtualDirectory -Identity “CAS_Server_name\Microsoft-Server-ActiveSync (Default Web Site)” -ExternalUrl https://mail.externalname.com/Microsoft-Server-ActiveSync -InternalUrl https://mail.externalname.com/Microsoft-Server-ActiveSync

Open in new window

.

3. Configure activesync server.
Set-ActiveSyncVirtualDirectory -Identity "COMPUTERNAME\Microsoft-Server-ActiveSync (Default Web Site)" -ActiveSyncServer "https://servername.com/"

Open in new window


4.Change internal UPN matches to your email address
https://support.office.com/en-us/article/How-to-prepare-a-non-routable-domain-such-as-local-domain-for-directory-synchronization-e7968303-c234-46c4-b8b0-b5c93c6d57a7

Hope it helps.
2
 
SinkeIT Solution EngineerCommented:
Hi,

This should be resolved by having SRV record "_autodiscover" targeting the MX record name for your server and having an A record "autodiscover" also pointing to the same MX.
Also, not sure when you have modified your public DNS but if you have a TTL with high value, you should probably wait a bit and then try again to setup iPhone with autodiscovery settings.
0
 
cciedreamerAuthor Commented:
I have already created the _autodiscover SRV record and CNAME recording pointing to the host server
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
pgm554Commented:
Have you run the M$ autodiscover test ?

https://testconnectivity.microsoft.com/
0
 
cciedreamerAuthor Commented:
Yes all were success.
0
 
Jose Gabriel Ortega CEE Solution Guide - CEO Faru Bonon ITCommented:
Is the certificate a self or external one? (it must be signed for an external CA)
0
 
cciedreamerAuthor Commented:
Its a public certificate
0
 
Jose Gabriel Ortega CEE Solution Guide - CEO Faru Bonon ITCommented:
1
 
Hemil AquinoNetwork EngineerCommented:
Knowing the fact you have tested everything and it went good  I need to ask what type of authentication method are you using to login?

1- domain/username
2-UPN
3- username

If you are trying to configure the phone automatically, you need to use UPN option. Also make sure all the users in your Exchange have the legal UPN domain.com and not domain.local

Cheers,
1
 
cciedreamerAuthor Commented:
Hi MAS
Thanks for your response
UPN and email address is different
UPN is user@internaldomain.com
Email address is user@externaldomain.com
0
 
MAS (MVE)EE Solution GuideCommented:
Hi cciedreamer,
Please change the UPN to your emailaddress by following article above on 4th point on my post above and try.
0
 
cciedreamerAuthor Commented:
Thanks MAS, it is solved.
UPN was one of the cause.

However at first instance, changing the UPN didn’t work until I change the IOS on my phone from 11.0 to 11.1

Here the discussion about it

https://discussions.apple.com/thread/8109311?start=0&tstart=0
0
 
MAS (MVE)EE Solution GuideCommented:
Glad to know you found a solution and thanks for sharing the solution.
0
 
cciedreamerAuthor Commented:
Iphone with  IOS 11.0 not automatically discovering the server name when configuring. It work just fine when upgraded to 11.1

In addition, as mentioned by MAS and Hemil. UPN must match with your email address.

Thank you all.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.