Angular5 Bootstrap Firestore Auth

I am trying to install the following for a new application:
Angular5
Bootstrap4
Firebase and Firestore
Firebase Hosting (probably)
Firebase Auth

I can get everything installed but there are dependency issues.  I think Node.js 9.0.0 does not work with NPM 5.5.1 and the Angular/cli.  Node.js 9 comes with NPM 5.5.1 so I'm not sure what the problem is.  I tried to update my package.json file with v. 5.5.1 from 5.0.0 but that causes even more issues.  I know this is all new but has anyone found a way to work around it?  Different versions?
LVL 1
Christopher GoreSolutions ArchitectAsked:
Who is Participating?
 
Julian HansenConnect With a Mentor Commented:
I think you are going to have to weather the teething issues on your own - par for the course when operating on the (b)leading eadge.

As far as I know bootstrap4 has only just entered beta, Angular 5 is still warm from the oven, 1.5 CLI also hot off the press.

It is going to be some time before info builds on how to get these to play nicely together so the question is - why the necessity to go with the latest versions. The changes in Angular 5 are really just extensions to the March 2017 Angular 4 release - some new functionality but mainly following the theme of easier, smaller faster - so I don't think you lose anything continuing with 4.3+ for now and then migrating when the issues you are encountering have been resolved or there is more information on them.
0
 
Christopher GoreSolutions ArchitectAuthor Commented:
Comes with the territory.   I'll probably just stick with tried and true for now.  When I figure out some solution or an update is made, I'll update this post for everyone.  For now, I just need to quit what I call "chasing a squirrel" and get back to work.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.