Create RDS Collect Error

We have the following servers all Windows Server 2016 with all patches installed as of this posting:

1.  Gateway:  RDP Gateway, RDS Broker, RDWEB
2.  RDS01: Remote Desktop Session Host.
3.  RDS02: Remote Desktop Session Host.
4.  PDC:  Domain Controller and Licensing server.

When I attempt to create a collection, I get the following error:  The program cannot open the required dialog box because no locations can be found.  Close this message, and try again.

RDPERROR.JPG
Note that the default group is not there.  I have never seen this error before and I've been using Windows since the NT4 days.  Any clues?

JamesNT
JamesNTAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Philip ElderTechnical Architect - HA/Compute/StorageCommented:
The above step is being run on the Broker?

Please publish Ipconfig /all into a CODE box for DC, Broker, and RDSH servers.
0
JamesNTAuthor Commented:
Gateway server which is broker, RDWEB, and Gateway:

Windows IP Configuration

   Host Name . . . . . . . . . . . . : Gateway
   Primary Dns Suffix  . . . . . . . : ad.mydomain.com
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No
   DNS Suffix Search List. . . . . . : ad.mydomain.com

Ethernet adapter Ethernet:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : vmxnet3 Ethernet Adapter
   Physical Address. . . . . . . . . : 00-50-56-B1-55-2D
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   IPv4 Address. . . . . . . . . . . : 192.168.16.8(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 192.168.16.1
   DNS Servers . . . . . . . . . . . : 192.168.16.35
                                       192.168.16.11
   NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter isatap.{79503AA5-1244-4CEB-896A-7CA738F92345}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Open in new window


PDC which is domain controller and licensing server:

Windows IP Configuration

   Host Name . . . . . . . . . . . . : PDC
   Primary Dns Suffix  . . . . . . . : ad.mydomain.com
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No
   DNS Suffix Search List. . . . . . : ad.mydomain.com

Ethernet adapter Ethernet:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Intel(R) 82574L Gigabit Network Connection
   Physical Address. . . . . . . . . : 00-50-56-B1-65-F9
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::98bb:4dab:7bfb:e024%2(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.16.35(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : fe80::c2ea:e4ff:fe0c:810%2
                                       192.168.16.1
   DHCPv6 IAID . . . . . . . . . . . : 301993001
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-1E-1C-79-F2-00-50-56-B1-65-F9
   DNS Servers . . . . . . . . . . . : ::1
                                       192.168.16.11
                                       192.168.16.35
   NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter isatap.{840A7667-AA05-4CFA-AA42-1740A0D5F600}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Open in new window


RDS01 Remote Desktop Sessions Host.

Windows IP Configuration

   Host Name . . . . . . . . . . . . : RDS01
   Primary Dns Suffix  . . . . . . . : ad.mydomain.com
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No
   DNS Suffix Search List. . . . . . : ad.mydomain.com

Ethernet adapter Ethernet0:

   Connection-specific DNS Suffix  . : ad.mydomain.com
   Description . . . . . . . . . . . : vmxnet3 Ethernet Adapter
   Physical Address. . . . . . . . . : 00-50-56-A1-84-BF
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::7007:811c:e6ce:48d0%4(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.16.105(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Lease Obtained. . . . . . . . . . : Sunday, November 5, 2017 11:03:40 AM
   Lease Expires . . . . . . . . . . : Monday, November 13, 2017 11:03:08 AM
   Default Gateway . . . . . . . . . : fe80::c2ea:e4ff:fe0c:810%4
                                       192.168.16.1
   DHCP Server . . . . . . . . . . . : 192.168.16.35
   DHCPv6 IAID . . . . . . . . . . . : 50352214
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-21-8E-DE-DC-00-50-56-A1-84-BF
   DNS Servers . . . . . . . . . . . : 192.168.16.35
                                       192.168.16.11
   NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter isatap.ad.mydomain.com:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . : ad.mydomain.com
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Open in new window


RDS02 Remote Desktop Session Host:

Windows IP Configuration

   Host Name . . . . . . . . . . . . : RDS02
   Primary Dns Suffix  . . . . . . . : ad.mydomain.com
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No
   DNS Suffix Search List. . . . . . : ad.mydomain.com

Ethernet adapter Ethernet0:

   Connection-specific DNS Suffix  . : ad.mydomain.com
   Description . . . . . . . . . . . : vmxnet3 Ethernet Adapter
   Physical Address. . . . . . . . . : 00-50-56-A1-4A-B2
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::a5cd:cd4c:a516:8c15%4(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.16.121(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Lease Obtained. . . . . . . . . . : Sunday, November 5, 2017 11:11:23 AM
   Lease Expires . . . . . . . . . . : Monday, November 13, 2017 11:10:48 AM
   Default Gateway . . . . . . . . . : fe80::c2ea:e4ff:fe0c:810%4
                                       192.168.16.1
   DHCP Server . . . . . . . . . . . : 192.168.16.35
   DHCPv6 IAID . . . . . . . . . . . : 50352214
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-21-8E-E5-59-00-50-56-A1-4A-B2
   DNS Servers . . . . . . . . . . . : 192.168.16.35
                                       192.168.16.11
   NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter isatap.ad.mydomain.com:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . : ad.mydomain.com
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Open in new window


I would like to point out that, if memory servers (and it may not), this seemed to be ready to work when I used self-signed certs for everything.  I'm using a Godaddy trusted cert for all cert needs now.  Just a shot in the dark.  :)

JamesNT
0
Philip ElderTechnical Architect - HA/Compute/StorageCommented:
PDCe DNS0 should point to itself or loopback and that's it. AD takes care of replication partner pointers.

We don't set certificates until after the farm is up. Where is the GD cert being used?
0
Cloud Class® Course: CompTIA Healthcare IT Tech

This course will help prep you to earn the CompTIA Healthcare IT Technician certification showing that you have the knowledge and skills needed to succeed in installing, managing, and troubleshooting IT systems in medical and clinical settings.

JamesNTAuthor Commented:
GD cert is being used in all cert locations you see here:

certsused.JPG
0
Philip ElderTechnical Architect - HA/Compute/StorageCommented:
I suggest leaving all of those alone until after the farm is set up. I've never personally set up the certs prior to the farm before.

The local ones may be messing with the setup between AD and RDS. Are there any cert specific errors in the Event Logs?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
JamesNTAuthor Commented:
Starting over with the gateway/broker/rdweb server and setting up the farm then saving certs for last worked.

JamesNT
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2016

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.