SAP Connector on Exchange 2016

Good Day All

I have a client who recently migrated from Exchange 2010 to 2016. After decommissioning their old 2010 Exchange server, they are now unable to send mails from SAP as the receive connector is now not on the Exchange 2016 server and needs to be recreated.

I tried recreating it as it was using old screenshots of all the settings. And the SAP has been changed to point now to the 2016 servers IP by the client.

SAP is still unable to send any mails via the Exchange.

Can someone please assist? Is there anything that needs to be restarted from the SAP side after make such a change?
Vince HAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Jason CrawfordTransport NinjaCommented:
  1. Create a new Receive Connector named 'SAP_Relay' in the on-prem Exchange server and select 'Custom' for intended use.
  2. In the next screen, click 'Add' then choose 'Specify an IP address'
  3. Keep the port set on 25, delete the default 'All available IPv4 addresses', and click OK
  4. Enter the Exchange server LAN IP and click Next
  5. In the next screen select 'Add', enter the IP of the SAP server, and delete the default 0.0.0.0-255.255.255.255 followed by New and Finish
  6. Open the Receive Connector you just created, open the Authentication tab, and select Transport Layer Security. This should be the only checkbox for this tab
  7. Open the Permissions tab and select Anonymous users and click OK
  8. Open EMS and run this command:

Get-ReceiveConnector SAP_Relay | Add-ADPermission -User "NT AUTHORITY\ANONYMOUS LOGON" -ExtendedRights "ms-Exch-SMTP-Accept-Any-Recipient"

Open in new window

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Vince HAuthor Commented:
Thx! I believe that powershell command was what was missing!!
0
Jason CrawfordTransport NinjaCommented:
Glad I could help.  Take care :)
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.