Exchange 2007 cannot send to Exchange 2013 on a migration

I am in the middle of migrating a client from Exchange 2007 to Exchange 2013 and it's gone fine up to this point. I've created a new test mailbox on the 2013 server and it can send to the Exchange 2007 server and externally fine but it does not receive messages from the 2007 server based users.

Currently the messages are sitting in a queue on the Exchange 2007 server awaiting retry but there are no error messages on the queue. I can telnet to the 2013 server on port 25 and test messages I send directly over SMTP work fine and are delivered, it is only messages sent from the 2007 server to the 2013 server that have this issue.

Would have to say my Exchange server is limited and this is the first on premise migration I've done in ages it's all been to Office 365 via Skykick in recent years so any assistance gratefully received
Capture.JPG
Phil EldridgeAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

MASEE Solution Guide - Technical Dept HeadCommented:
This expert suggested creating a Gigs project.
Hi Phil Eldridge,
Did you select "Server authentication"  ticked n the Default Receive connector of Exchange 2013?
Capture.PNG.
FYI your email should receive in Exchange 2013 and it will deliver the emails to Exchange 2007.  
i.e.Interface will be Exchange2013, point your common name to Exchange 2013.

You can test this in a PC/Outlook after creating a host(mail.domain.com) entry which points to Exchange2013..
0
Phil EldridgeAuthor Commented:
Thanks for the response MAS yes I did select Exchange Server Authentication in the default connection but it still doesn't do the trick. Just using OWA for testing and OWA on a PC with the hosts file modified sends from the new Exchange 2013 server fine. Both the Exchange 2007 users and external internet users receive fine.

On an unmodified machine connecting to OWA 2007 then the test user on the new server is found but when you send it just gets stuck in a retry queue and won't go any further I can't see any error messages to track back from. I can telnet from the 2007 server and send SMTP messages into 2013 so I know the 2013 server is largely OK. It is just the internal transport from 2007 to 2013 that seems broken, any suggestions gratefully received.

Capture.JPG
0
Phil EldridgeAuthor Commented:
I have now got an error message to work on with the Exchange 2007 server I am seeing an error which reads:

451 4.4.0 Primary target IP address responded with: "451 5.7.3 Cannot achieve Exchange Server Authentication." Attempted failover to alternate host, but that did not succeed. Either there are no alternative hosts, or delivery failed to all alternate hosts."

Any suggestions.Capture.JPG
0
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

MASEE Solution Guide - Technical Dept HeadCommented:
This is becasue you didnt enable server authentication or you didnt restart the transport service after enabling server authentication.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Phil EldridgeAuthor Commented:
MAS please see below for the receive connectors on the new Exchange 2013 server

Capture.JPG
Which connector are you talking about as both the hub transport one called Default RAUTOMEAD-EXC and the frontend one called Default Frontend RAUTOMEAD-EXC do have server authentication enabled and have been restarted. I've also restated the transport role on the old 2007 but that did not help either.

Captureb.JPGCapture2.JPGCapture3.JPG
Those are the current settings on the hub transport one. I've also checked that both servers are using the same SSL certificate and it is fully enabled for IIS and SMTP on both servers.
0
Phil EldridgeAuthor Commented:
MAS I've got it sorted now.

The issue was that the anonymous relay connector had the IP address of the old 2007 server in it. As soon as I removed the IP address of the old server from the anonymous relay everything just came over instantly.

Appreciate all your efforts please have an assisted solution,
0
Phil EldridgeAuthor Commented:
Thanks for responding.
0
MASEE Solution Guide - Technical Dept HeadCommented:
Glad to know you sorted.
Normal case this is what happens.
For your knowledge you can disable the additinal rcv connector and enable server authentication and test. So you will have a better idea how to fix in future.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.