Cannot restore system image created in Windows 10 v1709 using Backup and Restore

I cannot restore any system image which was created in Windows 10 v1709 using Backup and Restore. I receive the following error:

“The system image restore failed.

Error details: A Volume Shadow Copy Service component encountered an unexpected error. Check the Application event log for more information.
(0x80042302)”

This is a fresh Windows 10 v1709 installation. A repair disk was created using Backup and Restore. The image resides on an external USB hard drive which contains other images. I can restore any Windows 10 v1703 image using a repair disk. I cannot restore any Windows 10 v1709 image using a repair disk.

As a first test, I installed Windows 10 v1709 on a new HP EliteBook 840 G4 laptop (before installation I wiped the drive). I also used a different (smaller) external USB hard drive to back up the image successfully. I checked Event Viewer and found no errors or warnings relating to Windows Backup. After a successful backup, I wiped the drive using the “clean” command and tried to restore the same image I created earlier. It failed with the VSS error referenced above.

As a second test, I installed Windows 10 v1703 on the same HP EliteBook 840 G4 laptop (before installation I wiped the drive). I used the same external USB hard drive to back up the image successfully. I checked Event Viewer and found no errors or warnings relating to Windows Backup. After a successful backup, I wiped the drive again using the “clean” command and tried to restore the same image I created earlier. The restore was successful.

Unsuccessfully, I cannot restore any v1709 image using either repair disk I created in v1703, v1607 and v1511.

I am aware System Image Backup (SIB) Solution is deprecated (not removed) in v1709. I searched online for other users with the same issue and came across the following post on TechNet forum.

https://social.technet.microsoft.com/Forums/windows/en-US/1f21b451-1431-414c-89e4-8010dfa5d239/win10...

The culprit appears to be v1709. Something changed to prevent a successful restore.

There are 7 images on the USB drive. 3 from 1703 and 4 from 1709. All images created from 1703 can be restored successfully. All images created from 1709 produce a VSS error.

To further test, I wiped the drive clean on an HP EliteBook 840 G4 laptop. I installed a fresh copy of v1709 while disconnected from the Internet. This way, no updates are automatically downloaded and installed during setup.
Without any Windows updates, drivers or third-party software installed I created a system image on an external drive. Basically, a barebones image. Backup was successful; no errors or warning in Event Viewer.

Again, I wiped the drive clean and tried to restore. After clicking Yes on the final prompt I received a VSS error.
Dan BerryAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

David Johnson, CD, MVPOwnerCommented:
is the external drive mounted in a usb2 port?

You may want to check out my article about When Windows Restore Won't  replace WAIK with ADK (only need the deployment and imaging tools)
0
McKnifeCommented:
So steps to reproduce are which?
Install 1709 clean - create a system image to a usb drive and try to restore it from the repair disk? That's all, nothing in between? If so, please retry with a virtual machine created in hyper-v. If it happens there, too, it's a bug and microsoft needs to be notified.
0
Dan BerryAuthor Commented:
David Johnson: a USB 2 port? Really? Thanks for the article, but it's way overkill. None of those are related. I came here hoping to find a workaround to bug MS hasn't identified yet, or has identified and is working on a fix.

McKnife: What in between are you referring to? It's a simple process that I've been using for years. With all version of Windows 10 (1507, 1511, 1607 and 1703) the imaging process has not changed and I was able to successfully backup and restore any image. In v1709, I cannot. This is clearly a bug.
0
Acronis Data Cloud 7.8 Enhances Cyber Protection

A closer look at five essential enhancements that benefit end-users and help MSPs take their cloud data protection business further.

McKnifeCommented:
If I ask people to write down reproducible steps for a problem, they go "I installed windows and then the software and the problem appeared". later, t often turns out that they did a lot of other things like install AV software or configure something in between. Just making sure that you didn't. Ok, then please retry with hardware that cannot possibly be the problem: virtual hardware.
0
McKnifeCommented:
Ok, if that's the case, Microsoft will ask you to use the feedback app to report it unless you're a corporate customer with a support contract.
If I find the time, I will reproduce it.
0
Dan BerryAuthor Commented:
I would greatly appreciate it if you did that.

Thank you.
0
McKnifeCommented:
Did it and it works.
Steps:
1 Install a VM with 1709, update it to 16299.19
2 add a 2nd virtual hard drive and initialize it in disk management
3 start image creation to this disk, default options. Don't create a repair disk as this is a vm that has no dvd writer and we don't need one, anyway as we can use the setup dvd/USB/ISO
4 boot from the setup disk and restore

All works as expected.
0
McKnifeCommented:
Ha!

What I did differently is the following: I did not wipe-clean the disk before restoring (since I saw no reason for it). When I do, I get the same error.
So definitely, the error message is misleading, since the error is with repartitioning and not with VSS.
You could workaround that simply by choosing not to repartition the disk.

I will retry this with 1703 now.
0
Dan BerryAuthor Commented:
McKnife, all this work is great, and thanks for helping me. However, VM is not a real test. I am also able to successfully backup and restore an image in a VM (VMware Workstation 14).

The real test is on a physical machine. If you have a spare laptop or desktop, install a fresh copy of 1709, update it, do whatever you need, then create an image to another drive... Using a repair disk of any type, try to restore that same image to the machine.

Lmk how it turns out.
0
McKnifeCommented:
It seems you did not read my comments entirely. My comment before this comment confirms what you found out and tells you when it happens and when not. So you found a bug, yes, but it will not apply to all restore use cases but only to some. It will apply to restore2newdisk but won't apply to restore2samedisk. It will also apply to restore2same, when you do (for whatever reason) clean the drive (as in diskpart - clean) before you restore - and that is what you did. Results on physical hardware are exactly the same.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
David Johnson, CD, MVPOwnerCommented:
enough information to confirm an answer
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 10

From novice to tech pro — start learning today.