RPC server is unavailable while connecting to SCCM while connecting to WMI using wmbemtest.

event log : DCOM was unable to communicate with the computerxxxx using any of the configured protocols; requested by PID     41d0 (D:\Program Files\Microsoft Configuration Manager\bin\x64\smsexec.exe).
ccm.log
rpc-error.png
Molly sAsked:
Who is Participating?
 
Mike TLeading EngineerCommented:
Hi,

Forget SCCM - if WBEMTest fails, as per the screenshot, things are not going to work.

WMI is fundamental to lots of things, not least SCCM.
To troubleshoot check out this very long and detailed Wiki from MS:
https://social.technet.microsoft.com/wiki/contents/articles/4494.windows-server-troubleshooting-the-rpc-server-is-unavailable.aspx

Try this:
call netsh firewall set service RemoteAdmin enable
call netsh firewall add portopening protocol=tcp port=135 name=DCOM_TCP135

to check temporarily. It sounds to me like you have a GPO blocking the port or a hardware firewall in the way. What ports have you got open as stated above?

Mike
0
 
Ganesh Kumar ASr Infrastructure SpecialistCommented:
is it happening for specific client system or from all the computer? If it is specific system, perhaps the antivirus client or firewall is blocking, turn off and check if you are able to reach the SCCM server.
0
 
Molly sAuthor Commented:
This is for all the computers
0
Cloud Class® Course: Microsoft Azure 2017

Azure has a changed a lot since it was originally introduce by adding new services and features. Do you know everything you need to about Azure? This course will teach you about the Azure App Service, monitoring and application insights, DevOps, and Team Services.

 
Ganesh Kumar ASr Infrastructure SpecialistCommented:
Are you able to access the workstations, is there any firewall / antivirus blocking the access. Please check from either side and update us.

Check the client and server ports if they are open and reachable, check if the client is able to resolve the server. I believe you have configured the client access with HTTPS protocol, check if it supports both HTTP & HTTPS

Check if your SCCM deployment domain account has full permission on the client computers, if you are trying for the domain joined computers.
0
 
Molly sAuthor Commented:
Hi Ganesh,

ALl required ports are open. Also tried to uninstall antivirus and tested the connecting SCCM server . but no luck. COuld you suggest further troubleshooting steps on this
0
 
Molly sAuthor Commented:
thnks
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.