Tons of RAM "Reserved for Hardware use", Unable to adjust in BIOS

Have an HP PC1-1113w desktop that has now giving us low memory errors when scanning more than 2-3 pages. It has 6 GB total RAM on a 2GB card and a 4GB card.  Through Windows 7 Task Manager usable RAM is showing around 800 Meg, even though available RAM is almost 4GB.

Got desperate for any solution, even simply tried swapping Memory cards in their slot locations.  Actually worked for about 10 minutes and showed all the available RAM as being usable.  Then, back to the BS it was doing earlier.

The HP branded BIOS is nearly useless for making real changes, and no chipset/RAM adjustments are even listed.

The scanner is a Canon MFP Imageclass unit.  Could it's software be holding some memory hostage?  If so, it's not obvious by examining Task manager performance and application screens.

This is a 64bit Windows 7 system.

Thanks in advance
Gale W.
Gale WPresidentAsked:
Who is Participating?
 
noxchoConnect With a Mentor Global Support CoordinatorCommented:
I still think that your problem is a software problem but you can try replacing the ram.
0
 
Sajid Shaik MSr. System AdminCommented:
first of all did u run disk cleanup

or  go to run   type  Temp - enter  - select all files and delete ..

go to run again type   %temp% - enter -select all files - delete

check the resolution of the image tyr by reducing the resolution pixels ...

if it's works fine then increse RAM and install o/s 64 Bit.

all the best
0
 
Dr. KlahnPrincipal Software EngineerCommented:
Try this:  Download a copy of Memtest-86+.  Burn it to CD or USB stick.  Boot it, and see what it discovers.  (a) Does it see all the memory that is present?  (b) Can it run for at least 6 hours with no errors?

If the system can pass this hardware diagnostic, probability is high that there's no hardware problem and the issue is due to a memory leak in Windows or in the scanning software.  Memory leaks in Windows are usually fixed quickly by Microsoft automatic Updates, so that would put the issue back in the scanning software, either the driver (less likely) or the scan processing software (more likely).

(imo, scanning took a reliability hit at Windows 7 when Microsoft decided to "deprecate" TWAIN in favor of WIA.  Naturally every problem that could possibly occur leaped out of the woodwork and personally, I think some were never fixed).

You might try the approach at the second link below.  The devil is that last part, "Download and install the scanner application from the manufacturer, but don’t install the drivers."  This is difficult to impossible for an AIO printer.  But before you jump at that as a possible solution, see if your unit is supported at the upper of the two links.

https://www.hamrick.com/vuescan/canon.html#scanner-drivers

https://diymediahome.org/enabling-unsupported-scanners-on-64bit-windows/

Pragamatically you may be better off purchasing a good used USB scanner that can be supported by Vuescan.  $50 will buy an excellent used scanner off fleabay, but it won't pay for half an hour of IT support time in a business environment.
0
Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
nobusCommented:
try scanning from PAINT (in accessories) - import from scanner
does it have this problems also?  then the software is not the culprit
alternatively, look up in task manager -performance - resource monitor, and check what's using the ram
0
 
noxchoGlobal Support CoordinatorCommented:
If you check in Task Manager - Resource Monitor - what is using the RAM?
0
 
nobusCommented:
tx noxcho, for the repeat !
0
 
Gale WPresidentAuthor Commented:


Thanks everyone.
Included this Screen shot in case my description of issue wasn't accurate.
Dumped all the temps and Cached files many times earlier to no avail.
Win updates done (Auto update is turned off), no improvement. But still need to do MemTest-86 as suggested.
Paint import from scan is an option but grayed out/not available.
Resource Monitor never fully opens.  Gets a window frame, but just sits there laughing at me, no content/images
And a correction on the Scanner, it's a Samsung M2885fw, the Canon is another location.

D\RAM issue
0
 
nobusCommented:
that seems to point to an OS problem
you can try :
-system restore to a date it was ok
-run sfc, Dism, or a repair install
http://www.tenforums.com/tutorials/2895-sfc-command-run-windows-10-a.html
http://www.tenforums.com/tutorials/7808-dism-repair-windows-10-image.html                               DISM
https://www.tenforums.com/tutorials/16397-repair-install-windows-10-place-upgrade.html       REPAIR
0
 
noxchoGlobal Support CoordinatorCommented:
Can you post also view of Processes Tab? Please sort first most RAM using processes on top.
Does your motherboard have an onboard videocard?
Plus click on Resource Monitor - switch to Memory Pane and show us what it shows.
0
 
Gale WPresidentAuthor Commented:
Processes running
Processes tab print screen attached.  Free ram with these processes running is 32Mg.

Did run SFC/Scannow, found no problems.  Machine also stopped performing typical
PrtScn function when attempting to post Processes tab above, so thought outside chance of a bug.
Ran both Malware Bytes and Windows Defender scans, nothing found.
And Resource Monitor still doing nothing more than bring up an empty window frame

Pretty sure Video Card is built onto Mother Board, system says it is an AMD Radion HD 6310

Thanks again everyone-
GW
0
 
noxchoGlobal Support CoordinatorCommented:
What if you disable Google Chrome?
0
 
Gale WPresidentAuthor Commented:
Very interesting development.  
Restart computer and do not start Chrome=almost 3gb free RAM.  We keep several active tabs open in Chrome for immediate business use during the day.  Boiled that down to one and moved the rest into the bookmarks bar for quick access.  That leaves about 1.7GB free RAM.  Still seems like very little remaining from the 6GB we start with and what I think are very light RAM requirements, but is enough to work with.

Then test scanner while monitoring task manager.  Memory error message returns after just three pages scanned and free RAM still shows 1.6GB.  Recheck temp files in case "something" took a dump, clean.  Recheck Scanner image size settings, saving as JPEG at 200dpi.
Can't tell if or how to clean potential memory build up in scanner itself.  The scanner is the only memory we haven't been able to inspect and observe.  Did test it after leaving it off for a while, same issue.

Wish I could point to an instance which brought this on.  No new software installed or equipment connected.  Think I'm down to uninstall/reinstall the printer/scanner.
0
 
noxchoGlobal Support CoordinatorCommented:
Chrome is consuming a lot memory in your case.
The scanner could be saving the scan results in memory. Check in its settings if you have somewhere an option to control the memory. Or check if it has newest firmware and driver.
0
 
Gale WPresidentAuthor Commented:
Looks like there are two problems with overlapping symptoms.

Finally had time to take the unit out of service to uninstall and reinstall the Samsung software.
This seems to now allow scanning without any error messages or hangups, but still doesn't prevent
the Free Memory from dropping under 50Megs and bringing the PC almost to a halt.  
Starting Chrome even with just one active tab seems to pull about 2Gb off the Free Memory.
Maybe need to uninstall/reinstall Chrome?

Next plan is to replace the mismatched memory cards with identical units.  The current units are
the same clock speed but different manufacturers and one at 4Gb and other at 2Gb.
0
 
noxchoGlobal Support CoordinatorCommented:
Uninstalling and installing again Chrome is what I would do first ;)
0
 
Gale WPresidentAuthor Commented:
No improvement with uninstall/ reinstall Chrome.  Ran it overnight without Chrome or business software active and again showing
3.2G available but only 120Megs free for use.  Shows nearly all available memory to be free for use at start up, but drops steadily and greatly after 10-15 minutes of run time,  Resource monitor still stops loading after showing frame of it's window.  Back to replacing Memory Cards with matched set?
0
 
Gale WPresidentAuthor Commented:
Likely you are correct, but haven't been able to determine what software and where.  Got the memory ordered cheaply enough.  
If  that don't fix it, then you win at least for hanging in there with me.  Thanks-
0
 
noxchoGlobal Support CoordinatorCommented:
Resource monitor still stops loading after showing frame of it's window
Does it stop even if you start it right after system starts?
0
 
Gale WPresidentAuthor Commented:
Good suggestion.  Did get it to let me start recording immediately after a fresh restart, but locked up shortly after.  I'll keep playing with it as it may be me not understanding how to work with Resource Monitor.
0
 
Gale WPresidentAuthor Commented:
Have been running new matching (identical, same brand, everything) 4gb card for a week.  Problem seems fixed.  Doing so added 2gb to the 6gb already installed, but now the system recognizes an additional 3.5gb of free memory.  Everything faster as you'd expect.  Old cards not compatible?   Wish I knew but glad it's better.  AttacHong pictures of cards in case it helps others understand.
Thanks everyone, especially Noxcho
20171114_153723.jpg
1
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.