How to reset my Asus to defaults

Marco Gasi
Marco Gasi used Ask the Experts™
on
Hi everybody.

I have a dual-boot Asus F541U with Windows 10 (preinstalled) and Ubuntu (in a partition I created using the Windows Disk Manager).

Now, for several reason that are no important here, I want to reset the PC to its factory defaults but when I click Reset button I' asked to put in the Windows installation cd.
Now, Using Disk Management utility I see the Recovery partition:

Recovery partition
but it looks like Windows don't detect it or can't access it.
I thought it could be because the partition has been moved out from its default position. What can I do to make it visible and usable again?
I also tried to follow a suggestion found in Internet: type 'e' in the Grub screen and after having delete all the text write thses lines and press F10
insmod part_gpt
insmod chain
set root='(hd0,gpt5)'
chainloader /Recovery/WindowsRE/boot.sdi

Open in new window

where gpt5 is because the partion is sda5 and hd0 because my Asus has just one hard disk. Doing this I get an undefined error: it just says that boot.sdi cannot be loaded.

Any suggestion will be very appreciated: keep in mind that I already plan to reinstall Ubuntu (or more precisely, I want to go back to Linux Mint), so it is not a problem deleting the Linux partitions, but will this be enough? Or do I have to move the recovery partition in another position? And in which position it should go?

Thank you fro any help.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Root Cause of the problem could be Due to linux bootloader is residing on very first sector thats why It cannot read the partition table from linux grub bootloader. because Original partition table is in windows bootmgr which tell asus bios location of the factory settings partition. So you have to restore the windows bootloader first then try


1) Did you try by pressing F9 button for factory settings restore?
2) There are tools which move your partition positions. I have done it before many times long time ago.
Most Valuable Expert 2013
Commented:
Yes, installing Grub unfortunately breaks Windows' partition management and the Asus recovery loader.
Grub and the  Ubuntu partition need to go, don't leave a partition that Windows won't recognise
You then need to repair WinRE to point at the Asus Recovery Partiton in much the same way as you've already been trying
https://blogs.technet.microsoft.com/askcore/2016/04/26/customizing-the-recovery-partition-after-upgrading-the-os-from-windows-8-1-to-windows-10/ shows the process - different situation, same solution.
Marco GasiFreelancer
Top Expert 2010

Author

Commented:
Thank you Ashok.
I thought something like that, but I don't have idea about how to restore Windows bootloader.. I'll inverstigate on this and I'll let you know.
OWASP Proactive Controls

Learn the most important control and control categories that every architect and developer should include in their projects.

Most Valuable Expert 2013

Commented:
Don't forget that when you get the recovery partition to launch a reinstall of Win10  it won't be expecting to find any partitions that weren't there when it was originally installed.
Marco GasiFreelancer
Top Expert 2010

Author

Commented:
Thank you MASQ, I'll delete oher partitions.
@Ashok: I forgot to say that F9 has no effect even if I set the Windows boot partition as the first one in the BIOS.
Jackie Man IT Manager
Top Expert 2010

Commented:
Do you see ASUS Manager - Backup & Recovery under all programs?

https://www.asus.com/support/FAQ/1010537/#

If yes, you can create a recovery media USB thumb drive to do a factory reset.
Marco GasiFreelancer
Top Expert 2010

Author

Commented:
Thank you Jackie. Unfortunately, I don't have ASUS Manager and it looks like I can't install it: in the Asus website my product doesn't exist: Asus F541U is not listed in their list of models!

@everybody: I followed suggested articles and even some other I foud by myself. I don't have winre.wim in C:\System32\Recovery folder but I have it in the recovery partition and the file ReAgent.xml looks to be correct. So I thought I could delete ext4 partitions, rebuild the MBR using DualBoot Repair and then, once I have booted correctly Windows (just to check), I should be able to perform the reset with WindowsRE from recovery partition. What about?
Yes, First Rebuild the MBR and let us know. After that you can also think about recovery partition.
Marco GasiFreelancer
Top Expert 2010

Author

Commented:
Ok,  I have repaired the boot record and now restarting the computer, Windows is automatically loaded. Now I suppose I have to use Windows Disk Management utility to format the three primary partitions (the thirdth, fourth and fifth partitions in the image I posted above) and merge them with the one where Windows reside. And then I can try to reset. Is this correct?
Jackie Man IT Manager
Top Expert 2010

Commented:
three primary partitions (the thirdth, fourth and fifth partitions in the image I posted above)

Just delete the above partitions and you will have a RAW space.

Then, extend the primary partition of the OS using the RAW space.
Marco GasiFreelancer
Top Expert 2010

Author

Commented:
Perfect. Thank you :)
Marco GasiFreelancer
Top Expert 2010

Author

Commented:
Sorry, just a doubt: once I have deleted the partitions I've got this:

new disk partitioning
Right click on the OS partition, choosen "Extend" and I see that I can't extend the partition using all the available space;

Available space
How can now use the entire hard disk for Windows (as far as I have understood, this is mandatory to get WindowsRE work again)
Jackie Man IT Manager
Top Expert 2010

Commented:
747350MB ≈ 730GB and it is the total RAw space which can be extended

What is the problem?

You cannot touch the first (EFI) partition and the fourth (recovery) partition.
Marco GasiFreelancer
Top Expert 2010

Author

Commented:
Sorry it was a my mistakes converting MB to GB :)
Marco GasiFreelancer
Top Expert 2010

Author

Commented:
Well, no good news again. Now I have the original 3 partitions (EFI, OS and Recovery) but I can't get recovery to work.

From Settings->Update & security->Recovery->Reset this system I click Get started, the options button to keep files or remove everything appears, I click on the latter and it wants the installation CD (which I didn't find in the box).

If I restart the computer holding the Shift keys and I select Troubleshooting I get only the option to change UEFI settings or startup settings.

If I restart the computer and I press F9 (or F8) nothing happens: Windows is loaded.

Am I missing something crucial, I think... Any idea? Thank you again for your effort.
Distinguished Expert 2017

Commented:
See if the following helps, https://www.asus.com/support/FAQ/1013065/

Once booted into Windows 10, through setting you can reset....... See the link.
Jackie Man IT Manager
Top Expert 2010

Commented:
http://support.asus.com.cn/Download.aspx?SLanguage=en&m=ASUS+Recovery&p=3&s=110&_ga=2.123958922.1213085685.1510204015-475157619.1510204015

Goto the link above and download the zip file for the installer of Asus Recovery.

If your notebook comes with Windows 10, select Win 10 64 bit in the pull down menu.
Marco GasiFreelancer
Top Expert 2010

Author

Commented:
@arnold: thank you for the link but that is the same procedure I described above: it doesn't list the "Restore factory settings" option and if I click to Erase everything it asks me for the installation media,

@jackie: I was aware of that software, but they say it only support Asus computer
When you have upgraded from Windows 8 to Windows 10 or Windows 8.1 to Windows 10
My computer came with Windows 10 pre-installed and there is no Windows.old folder that could suggest that the OS has been upgraded...

I have followed MASQ link but I stopped when the article says to use the installation CD or ISO. I know I could download a Windows ISO from Microsoft, but they would provide a Windows 10 updated version and I don't want the Fall Creator update because I found it too memory consuming.

In addition, I'm uncertain: in C:\Windows\System32\Recovery folder I have a ReAgent.xml but this has just empty values and it is quite different from the one have in Recovery partition; and in C:\Windows\System32\Recovery folder there is no winre.wim. Do I have to modify the ReAgent.xml to meke it equal to the one in REecovery partition? Or do I have to copy winre.wim in C:\Windows\System32\Recovery folder and change ReAgent.xml accordingly?  

Or something else :)?
Distinguished Expert 2017

Commented:
Usually, there should be a Maia creating app on your system.
What did you do when you setup the dual boot. Did you shrink the Windows partition.
Look at hitting F11 as soon as you turn on
Look at bcdedit to see if you have a reference to the recovery partition which you want to boot from ...
Marco GasiFreelancer
Top Expert 2010

Author

Commented:
@arnold:
 - sorry, but I don't understand what you mean with "MAIA creating app"; if you mean an application to create a backup image to use for recovery, I didn't use it
 - yes I shrink the partition...
 - hitting F11 has no effect (as well as hitting F8 and F9)
 - about bcdedit: if I use DualBoot Repair to open launch bcdedit, it doesn't contain any reference to the recovery partition, but if i do it manually with the command
bcdedit /enum all

Open in new window

then I get this output (I just show what I think is relevant but if you want to see more let me know):
Windows Boot Manager
--------------------
identifier              {bootmgr}
device                  partition=\Device\HarddiskVolume1
path                    \EFI\MICROSOFT\BOOT\BOOTMGFW.EFI
description             Windows Boot Manager
locale                  en-us
inherit                 {globalsettings}
default                 {current}
resumeobject            {077c0916-c4a7-11e7-ad6d-94e9791af70f}
displayorder            {current}
toolsdisplayorder       {memdiag}
timeout                 10

Firmware Application (101fffff)
-------------------------------
identifier              {077c0918-c4a7-11e7-ad6d-94e9791af70f}
device                  partition=E:
description             UEFI:  USB DISK 2.0 PMAP, Partition 1

Firmware Application (101fffff)
-------------------------------
identifier              {dc6dc869-fb90-11e6-9a3c-838a38c04a42}
description             CD/DVD Drive

Firmware Application (101fffff)
-------------------------------
identifier              {dc6dc86a-fb90-11e6-9a3c-838a38c04a42}
description             Hard Drive

Firmware Application (101fffff)
-------------------------------
identifier              {dc6dc86d-fb90-11e6-9a3c-838a38c04a42}
device                  partition=\Device\HarddiskVolume1
path                    \EFI\UBUNTU\SHIMX64.EFI
description             ubuntu

Windows Boot Loader
-------------------
identifier              {current}
device                  partition=C:
path                    \windows\system32\winload.efi
description             Windows 10
locale                  en-us
inherit                 {bootloadersettings}
isolatedcontext         Yes
allowedinmemorysettings 0x15000075
osdevice                partition=C:
systemroot              \windows
resumeobject            {077c0916-c4a7-11e7-ad6d-94e9791af70f}
nx                      OptIn
bootmenupolicy          Standard

Windows Boot Loader
-------------------
identifier              {dc6dc85d-fb90-11e6-9a3c-838a38c04a42}
device                  ramdisk=[\Device\HarddiskVolume4]\Recovery\WindowsRE\Winre.wim,{dc6dc85e-fb90-11e6-9a3c-838a38c04a42}
path                    \windows\system32\winload.efi
description             Windows Recovery Environment
locale                  es-ES
inherit                 {bootloadersettings}
displaymessage          Recovery
osdevice                ramdisk=[\Device\HarddiskVolume4]\Recovery\WindowsRE\Winre.wim,{dc6dc85e-fb90-11e6-9a3c-838a38c04a42}
systemroot              \windows
nx                      OptIn
bootmenupolicy          Standard
winpe

Open in new window

As you can see the reference to the recovery partition is there...
Jackie Man IT Manager
Top Expert 2010

Commented:
The recovery partition is corrupted from its size of 499mb. Do you shrink it within Linux OS?

You need to manually recreate the recovery partition but it is a difficult task.
Distinguished Expert 2017

Commented:
Boot into windows and see if you can direct it to boot from the recovery partition on the next attempt.

See if you can delay boot in an effort to see a menu........
Marco GasiFreelancer
Top Expert 2010

Author

Commented:
@jackie: bad news, that! I shrink it from Windows using Disk Management utility... Anyway can you tell me if there is some tutorial or resource to recreate manually the recovery partition?

@arnold: how practically can direct Windows to boot from the recovery partition? Or how can I delay the boot?

Thank you
Jackie Man IT Manager
Top Expert 2010

Commented:
I shrink it from Windows using Disk Management utility... Anyway can you tell me if there is some tutorial or resource to recreate manually the recovery partition?

It will be a 30 minutes search but I am going to sleep now as it is already 00:30 hour in Hong Kong.
Marco GasiFreelancer
Top Expert 2010

Author

Commented:
@jackie: Ok, Good night and thank you again :)
Distinguished Expert 2017

Commented:
Advanced system settings look at whether you can delay boot to a point where it presents you with the windows boot options.
The other is the boot..

The ..
Distinguished Expert 2017

Commented:
Please see if you can create a restore media to a USB ........
Distinguished Expert 2017
Commented:
Note, the recovery partition is reflecting volume4 meaning you now havre it as volume3
You would need to rebuildbcd to reflect the recovery partition in the correct place

Do you have another drive,
Copying the efi partition and the recovery partition on the end, then booting the system with the new drive.......
Most Valuable Expert 2013

Commented:
There's no harm in using a Creator's edition image to boot to for the recovery process. It's just a means to an end, ultimately you're using it to access the WinRE installer on the HDD which will setup the factory installed version and not the version in the .iso
Marco GasiFreelancer
Top Expert 2010

Author

Commented:
@arnold: are you saying it's not possible to just change a "4" to a "3" in the bcdedit? And wouldn't it be faster to create a small partition shrinking the OS just a bit in order to put the recovery partition at the 4th position? Maybe it's a stupid idea, I'm ignorant (as you all have already understood at this time)...

@MASQ: that sounds interesting. Are you saying that I can download the current Windows image to create a media, put it in a usb, boot from that and from that boot for the recovery?

@jackie: I know you're sleeping now, but I just want to say that I don't think the partition be corrupted: from Linux I could mount it and read the ReAgent.xml file, so it should be fine.

Thank you so much to everybody for all your help.
Most Valuable Expert 2013

Commented:
@MASQ: that sounds interesting. Are you saying that I can download the current Windows image to create a media, put it in a usb, boot from that and from that boot for the recovery? Yes

But you have a working Win10 partiton so you can also launch WinRE from there
https://docs.microsoft.com/en-us/windows-hardware/manufacture/desktop/windows-recovery-environment--windows-re--technical-reference
Distinguished Expert 2017

Commented:
The creation of a new partition may auto-shift the recovery from 4 to 5.
bcdedit /rebuildos that you ran recreated the listing before you merged/deleted partitions on jackie's suggestion.,
Marco GasiFreelancer
Top Expert 2010

Author

Commented:
@MASQ: those methods don't work for me, probably because, as arnold pointed out, in bcd the recovery partition is referenced in Volume4 but it is in volume3...

@arnold: I have created the USB using the Media Creator Tool.

@everybody:
Anyway, going on to search for a solution, I tried some commands using diskpart; here the sequence of commands and their output:
C:\Users\marqu\Desktop>diskpart

Microsoft DiskPart version 10.0.15063.0

Copyright (C) Microsoft Corporation.
On computer: DESKTOP-KO6UAVN

DISKPART> list disk

  Disk ###  Status         Size     Free     Dyn  Gpt
  --------  -------------  -------  -------  ---  ---
  Disk 0    Online          931 GB  1024 KB        *
  Disk 1    Online           28 GB      0 B

DISKPART> select disk 0

Disk 0 is now the selected disk.

DISKPART> list volume
DISKPART> list volume

  Volume ###  Ltr  Label        Fs     Type            Size     Status     Info
  ----------  ---  -----------  -----  ----------  -------        ---------  --------
  Volume 0     D                                 DVD-ROM   0 B  No Media
  Volume 1     C   OS             NTFS   Partition   930 GB  Healthy    Boot
  Volume 2         SYSTEM     FAT32  Partition   260 MB  Healthy    System
  Volume 3                            RAW    Partition    499 MB  Healthy    Hidden

DISKPART> exit

Leaving DiskPart...

Open in new window

So the filesystem of the recovery partition is RAW: is this normal? Or should it be NTFS? In this second case I should use a tool like https://www.easeus.com/resource/raw-file-system-to-ntfs.htm to save files from the partition, format it and then pase saved files into it.

Then, to solve the problem of the wrong volume reference, I could run this command:
bcdesdit {default} {dc6dc85e-fb90-11e6-9a3c-838a38c04a42}

Open in new window

as described in https://docs.microsoft.com/en-us/windows-hardware/manufacture/desktop/bcd-system-store-settings-for-uefi

What are your thoughts?
IT Manager
Top Expert 2010
Commented:
The ASUS recovery partition should be a 25GB hidden partition and it is not so easy for you to recover it now.
Marco GasiFreelancer
Top Expert 2010

Author

Commented:
Oh. So we are just wasting time here... Thanks a lot anyway. I'm going to close the question splitting points.
Marco GasiFreelancer
Top Expert 2010

Author

Commented:
Thank you all, guys: I learnt a lot and I'm very grateful for your help and patience. I'll try to search Google for a manually recreation of recovery partition and eventually I'll open a new question posting a link here to notify you about. Thank you again.
Marco GasiFreelancer
Top Expert 2010

Author

Commented:
Hi guys.
Some update just to let you know :)
 - I copied winre.wim image from the recovery partition to the Windows\System21\Recovery\ folder;
 - then, from a command prompt with adminisrative right I have typed the following command: reagentc /enable (reagentc /info confirmed WIndowsRE was enabled
 -  From Settings->Update & security->Recovery->Reset this PC I have clicked GetStarted and finally, as expected the process started up to the confirmation dialog.

Then I stopped the process because the confirmation dialog told me the operation would have deleted all my personal files and users accounts (Ok); deleted all my apps and programs which didn'r come with the PC (Ok again); reset all my settings (Ok again). What it didn't tell is that Windows would have been reset to the version which came with the PC.

So, I did some step forward, but the Get started button still gives me only 2 options:
1) Keep my files
2) Remove everything

But "Restore factory settings" option is still missing...
Most Valuable Expert 2013

Commented:
"Remove everything" is restore to factory settings if it's the Asus WinRE.wim, from the recovery partiton. Windows isn't treating it as a recovery partition because it appears to it as a Win 10 setup image.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial