Exchange 2013 outlook anywhere (mapi over http) External asking password

Hi ,
We have set mapi over http :
internal Virtual directory : https://mailserver.domain.com/mapi
External Virtual directory : https://outlook.domain.com/mapi
Internal and extarnel authenthication : negotiate

When connecting from internal (lan) outlook 2013 will start and is sucsesfull connected.
When connecting from External outlook will ask for a password , once we fill in the password then it is connected sucsesfull.

But when a computer has joined the domain we want not to fill in a password.

What could be the trigger that i need to fill in the password?
ottenshxAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Tom CieslikIT EngineerCommented:
It's normal think.
It will always ask for password for connection to Exchange outside domain.
If you want prevent to do it you must install VPN and connect computer from outside network to your network using VPN prior to connect to Exchange.
0
ottenshxAuthor Commented:
Hi Tom .

We have VPN connections in place and once connected to the VPN outlook will not ask for a password .
But when not connected to a VPN and the computer is a member of the domain it is asking for a password and with outlook anywhere ( RPC-HTTP this was not the case , outlook was using the logged on credentials to use for a outlook session without VPN.
0
Tom CieslikIT EngineerCommented:
It looks like you have not configured correctly autodiscover.
I had same problem in my domain but after I've setup autodiscover correctly problem gone and Outlook is not asking for password without VPN anymore
0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

ottenshxAuthor Commented:
Hi Tom,

what did you configure to the autodiscover to make it work? then i will check the settings.
thanks.
0
Tom CieslikIT EngineerCommented:
OK,
1.  autodiscover.yourdomain.com must be listed inside your certificate
2. You must have A record in your external DNS: autodiscover.yourdomain.com and point it to your email server IP
3. You must create zone autodiscover.yourlocaldomain.com  in your local DNS with A host pointing to your internal email server IP
4. You must bind autodiscover.yourdomain.com to port 443 in your local IIS Manager
5. You must run PowerSchell command on your email server

Get-ClientAccessServer | Set-ClientAccessServer –AutoDiscoverServiceInternalUri https://autodiscover.company.com/autodiscover/autodiscover.xml

Open in new window


Link must point to your email server autodiscover
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ottenshxAuthor Commented:
Thanks .
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.