"Run as" command

I am trying to get an executable to run on Win 7 without constantly prompting for admin credentials. I followed a procedure I found on EE but when I click the shortcut I created I get a command prompt window that flashes for a second and disappears but the executable does not run. I do not want to disable UAC
InSearchOfAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Tyler BrooksNetwork and Security ConsultantCommented:
What procedure did you follow? I've used this once or twice quite effectively for this issue.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
arnoldCommented:
What program do you need to always run as or with admin rights?
Identifying why UAC seems to require admin rights could potentially resolve the issue.
0
InSearchOfAuthor Commented:
Need to run an accounting application
0
Acronis True Image 2019 just released!

Create a reliable backup. Make sure you always have dependable copies of your data so you can restore your entire system or individual files.

InSearchOfAuthor Commented:
That is what I have done but when I run it the command prompt window flashes for a second and that's it.
0
Tom CieslikIT EngineerCommented:
Copy line from your shortcut to Bat file, add pause on the end of file, run BAT and read why program is not executing.
0
arnoldCommented:
Accounting application usually does not need to run as administrator.
If the application icon has a yellowish shield, it means there is something else going.
Check with the vendor to resolve why this application needs to run as admin.
0
InSearchOfAuthor Commented:
It is actually a tax program. It involves running an executable every time you want to run it.
0
arnoldCommented:
I've seen many tax programs, have not seen one that requires administrative access.
Thomson reuter's
Did you have to run it in compatibility mode, when setting the compatibility mode, you may have forgot to allow all users to run in compatibility and that may explain why it is available to all, but still requires admin ...
0
William MillerIT SpecialistCommented:
Have you checked the security tab on the program shortcut to make sure it's enabled full control for the "everyone" group? Also, as a rudimentary question have you opened compatibility for the program and clicked "Run as admin" under privileges? Does this make a difference? (Though I don't know why it would) If not to any of these, at least attempt that change as well to ensure that wasn't the cause. Moving from there, this could be a program that requires an admin level account to run (We actually have a piece of software like this on-site for my company). Have you tried to load an administrator level account and run this software? Does it work then?

Edit: As an addendum, I just ran across this on SpiceWorks:

https://community.spiceworks.com/how_to/129445-disable-uac-prompts-for-specific-program

Could be worth a shot to see if this is a possible work around. Unfortunately it requires some manual setup steps, so I don't think you could globally push this, it would be individually.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 7

From novice to tech pro — start learning today.