Link to home
Create AccountLog in
Avatar of mkramer777
mkramer777Flag for United States of America

asked on

printer won't print at times

HP Laserjet M506 printer and every once in a while it won't print.  It is attached to the desktop computer through USB.  If I reboot the computer the print outs will print.   Not sure what to check.  This is a Windows 7 Pro machine.
Avatar of John
John
Flag of Canada image

Uninstall the printer and remove from Devices and Printers.
Clear the print spooler:
Click Start.
Type Command .
Right-click “Command Prompt” and select “Run as administrator“.

Type net stop spooler then press “Enter“.
Type del %systemroot%\System32\spool\printers\* /Q then press “Enter“.
Type net start spooler then press “Enter“.
The print queue on your Windows should now be cleared.

Now go back to Devices and Printers, Printer Server Management (click on any device to see this menu), go to the Drivers tab, remove the driver.

Now disconnect the printer and USB cable. Restart the computer, install the printer package and then (only then) connect the printer by USB.

Test
Avatar of CES
CES

try a new USB cable
reinstall the driver.
uninstall/resinstall the printer
install the full software if you do not have it.
update the firmware of the printer.
Avatar of mkramer777

ASKER

I will try those things.  FYI.  When the user restarted the computer it printed out 1 of the word documents they were trying to print.  It's like it was locked until they rebooted.
So try the steps I laid out and then check the cable as per the second post.
In addition to the above suggestions:

Click Start, and search for Devices click Printers.
Right-click the printer, and then click Printer Properties.
Click the Ports tab, clear enable bidirectional support checkbox, and then click OK.
Test if Issue persists.


                * * * * *

Check the Spooler service :

Click Start, type services.msc and hit Enter.
 2. Look for the Print spooler.
 3. Restart the print spooler service.

Also make sure that the service is set to Automatic:
 a.     Right click on service and click on Printer spooler service and click on Properties.
 b.     Under the startup type, set it to ‘Automatic’.
I suggested these steps in my first post above.
ASKER CERTIFIED SOLUTION
Avatar of Michael Machie
Michael Machie
Flag of United States of America image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account