XCOPY or ROBOCOPY wont run in batch file

Bogart Bogart
Bogart Bogart used Ask the Experts™
on
I have this old batch file that I used to upgrade a software and since it is time for another one I have tried creating a GPO and assigned it under User Configuration>Windows Settings>Logon.

But when testing with a user logging on the batch file wont run but when manually clicking the file it runs perfectly fine!

Here is the code:  xcopy "Source" "Destination" /S /C /I /H /R /Y

Users have a full time mapped drive from where the source file is copied to the local drive C:\Folder

Note that robocopy is the same and doesn't run automatically.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
NVITEnd-user support
Commented:
In your bat file, add this to check if mapped drives and dirs exist:
net use >> "c:\%temp%\logon_debug.txt"
echo Checking for Source dir...
dir "c:\SourceNameHere">> "c:\%temp%\logon_debug.txt"
echo Checking for Target dir...
dir "c:\TargetNameHere">> "c:\%temp%\logon_debug.txt"

Open in new window


Logon the user.

Review the file on user's station: "c:\%temp%\logon_debug.txt"

Author

Commented:
Hi NVIT, I just came back and revisited the still logged on user and I am seeing it happen just now and files are flying!

I don't know what's causing the delay?

My expectation was for the files to be copied and dos window to be up as soon as user is logged in.

Weird.
NVITEnd-user support

Commented:
Not sure on the delay cause. How long did you wait? Maybe try another user to time it.

Author

Commented:
Over 10 minutes which isn't really good. I will try with another user and will let you know.

It's a 3+Gb file and taking so long though. May have to try Robocopy as this could be a lot faster.

Otherwise will have to make this a logoff process.

Author

Commented:
Ni NVIT just logged in another test user and the batch file does work but it starts after 4 minutes of wait.

I am not sure where the delay is coming from

Author

Commented:
I am testing this on a Win8.1 and seems to be a policy setting set to a default of 5 minutes! Will test this on a Window 7 and see how I go.
Hi NVIT this problem is solved.

I have verified this on a Windows 7 machine and the culprit is the policy: Computer Configuration\Administrative Templates\System\Group Policy: Configure Logon Script Delay which is set to Not Configured and is by default to wait for 5 minutes.

Thanks for looking into this.
NVITEnd-user support

Commented:
Awesome, Bogart!
I'm glad you figured it out.
Can you set it to 1 minute?

Author

Commented:
Hi NVIT from what I've read it can be set to whatever you like.
NVITEnd-user support

Commented:
1 is faster than 5. Hehe

Author

Commented:
Hah it is indeed!

Author

Commented:
This is know issue with 8.1 and is controlled in the mentioned GPO settings

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial