troubleshooting Question

Issue with autodiscover not returning all protocols externally

Avatar of Bianca
Bianca asked on
Exchange
5 Comments1 Solution319 ViewsLast Modified:
I have an exchange 2007 server issue with autodiscover.  On external tests I only receive the IMAP and SMTP protocols, but when run internally I get the expected Exchange RPC and Exchange HTTP.  This is causing an issue when trying to connect external clients via outlook, that outlook thinks its an IMAP account when using autodiscover to add the account.  It think it may also be related to some external clients losing their outlook anywhere settings intermittently.

Internal Results
<?xml version="1.0" encoding="utf-8"?>
<Autodiscover xmlns="http://schemas.microsoft.com/exchange/autodiscover/responseschema/2006">
  <Response xmlns="http://schemas.microsoft.com/exchange/autodiscover/outlook/responseschema/2006a">
    <User>
      <DisplayName>Matthew Young</DisplayName>
      <LegacyDN>/o=ftssvr/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=user</LegacyDN>
      <DeploymentId>84ab4871-1fbd-49f9-80bd-92300a9ddd32</DeploymentId>
    </User>
    <Account>
      <AccountType>email</AccountType>
      <Action>settings</Action>
      <Protocol>
        <Type>EXCH</Type>
        <Server>xxxx.xxxx.local</Server>
        <ServerDN>/o=ftssvr/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Configuration/cn=Servers/cn=HTFSSVR</ServerDN>
        <ServerVersion>720280B0</ServerVersion>
        <MdbDN>/o=ftssvr/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Configuration/cn=Servers/cn=HTFSSVR/cn=Microsoft Private MDB</MdbDN>
        <PublicFolderServer>xxxx.xxxx.local</PublicFolderServer>
        <AD>htfssvr.Troon.local</AD>
        <ASUrl>https://mail.xxxx.com.au/ews/exchange.asmx</ASUrl>
        <EwsUrl>https://mail.xxxx.com.au/ews/exchange.asmx</EwsUrl>
        <OOFUrl>https://mail.xxxx.com.au/ews/exchange.asmx</OOFUrl>
        <UMUrl>https://xxxx.xxxx.local/UnifiedMessaging/Service.asmx</UMUrl>
        <OABUrl>https://mail.xxxx.com.au/oab/613b6969-f29e-4022-ac19-3f46b874be44/</OABUrl>
        <CertPrincipalName>msstd:mail.xxxx.com.au</CertPrincipalName>
      </Protocol>
      <Protocol>
        <Type>EXPR</Type>
        <Server>mail.xxxx.com.au</Server>
        <ASUrl>https://mail.xxxx.com.au/EWS/Exchange.asmx</ASUrl>
        <EwsUrl>https://mail.xxxx.com.au/EWS/Exchange.asmx</EwsUrl>
        <OOFUrl>https://mail.xxxx.com.au/EWS/Exchange.asmx</OOFUrl>
        <OABUrl>https://mail.xxxx.com.au/OAB/613b6969-f29e-4022-ac19-3f46b874be44/</OABUrl>
        <CertPrincipalName>msstd:mail.xxxx.com.au</CertPrincipalName>
      </Protocol>
      <Protocol>
        <Type>WEB</Type>
        <External>
          <OWAUrl AuthenticationMethod="Fba">https://mail.xxxx.com.au/OWA</OWAUrl>
          <Protocol>
            <Type>EXPR</Type>
            <ASUrl>https://mail.xxxx.com.au/EWS/Exchange.asmx</ASUrl>
          </Protocol>
        </External>
        <Internal>
          <OWAUrl AuthenticationMethod="Basic, Fba">https://mail.xxxx.com.au/owa</OWAUrl>
          <Protocol>
            <Type>EXCH</Type>
            <ASUrl>https://mail.xxxx.com.au/ews/exchange.asmx</ASUrl>
          </Protocol>
        </Internal>
      </Protocol>
    </Account>
  </Response>
</Autodiscover>

External Results
<Autodiscover xmlns="http://schemas.microsoft.com/exchange/autodiscover/responseschema/2006">
    <Response xmlns="http://schemas.microsoft.com/exchange/autodiscover/outlook/responseschema/2006a">
        <User>
            <DisplayName>user@xxxx.com.au</DisplayName>
        </User>
        <Account>
            <AccountType>email</AccountType>
            <Action>settings</Action>
            <Protocol>
                <Type>IMAP</Type>
                <Server>xxxx.com.au</Server>
                <Port>993</Port>
                <DomainRequired>off</DomainRequired>
                <SPA>off</SPA>
                <SSL>on</SSL>
                <AuthRequired>on</AuthRequired>
                <LoginName>user@xxxx.com.au</LoginName>
            </Protocol>
            <Protocol>
                <Type>SMTP</Type>
                <Server>xxxx.com.au</Server>
                <Port>465</Port>
                <DomainRequired>off</DomainRequired>
                <SPA>off</SPA>
                <SSL>on</SSL>
                <AuthRequired>on</AuthRequired>
                <LoginName>user@xxxx.com.au</LoginName>
            </Protocol>
        </Account>
    </Response>
</Autodiscover>

Everything else appears to be working fine without issue

Any assistancee would be appreciated.
ASKER CERTIFIED SOLUTION
Ganesh Anand
Lead Technical Consultant

Our community of experts have been thoroughly vetted for their expertise and industry experience.

Join our community to see this answer!
Unlock 1 Answer and 5 Comments.
Start Free Trial
Learn from the best

Network and collaborate with thousands of CTOs, CISOs, and IT Pros rooting for you and your success.

Andrew Hancock - VMware vExpert
See if this solution works for you by signing up for a 7 day free trial.
Unlock 1 Answer and 5 Comments.
Try for 7 days

”The time we save is the biggest benefit of E-E to our team. What could take multiple guys 2 hours or more each to find is accessed in around 15 minutes on Experts Exchange.

-Mike Kapnisakis, Warner Bros