More than 2 MB attachment is not coming from out side

I am using exchange server 2010. I am not getting more than 2 MB attachment from out side. Internally it is working fine but externally it is not working. I have allowed 10 MB mail size on receive connector. I think 10 MB is default size.
I have spoken with logix team for the same, they are saying message is reaching to exchange server. General mail flow is working fine but if you attach 5 MB attachment. then it is not coming in side my organization,
LVL 1
Arif KhanSystem AdministratorAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

AlanConsultantCommented:
Hi,

Please can you run these PowerShell commands and post the results back here:

	Get-TransportConfig | FT MaxSendSize, MaxReceiveSize
	Get-ReceiveConnector | FT Name, MaxMessageSize
	Get-SendConnector | FT Name, MaxMessageSize
	Get-Mailbox MyUserName | FT Name, MaxSendSize, MaxReceiveSize

Open in new window


Thanks,

Alan.
Arif KhanSystem AdministratorAuthor Commented:
[PS] C:\Windows\system32>Get-TransportConfig | FT MaxSendSize, MaxReceiveSize

MaxSendSize                             MaxReceiveSize
-----------                             --------------
11.72 MB (12,288,000 bytes)             14.65 MB (15,360,000 bytes)


[PS] C:\Windows\system32>


[PS] C:\Windows\system32>Get-ReceiveConnector | FT Name, MaxMessageSize

Name                                    MaxMessageSize
----                                    --------------
Default BIOMAIL                         10 MB (10,485,760 bytes)
Client BIOMAIL                          10 MB (10,485,760 bytes)


[PS] C:\Windows\system32>


[PS] C:\Windows\system32>Get-SendConnector | FT Name, MaxMessageSize

Name                                    MaxMessageSize
----                                    --------------
Internet Send Connector                 10 MB (10,485,760 bytes)
Logix Relay Connector                   11.72 MB (12,288,000 bytes)


[PS] C:\Windows\system32>



[PS] C:\Windows\system32>Get-Mailbox administrator | FT Name, MaxSendSize, MaxRe
ceiveSize

Name                       MaxSendSize                MaxReceiveSize
----                       -----------                --------------
Administrator              unlimited                  unlimited


[PS] C:\Windows\system32>
AlanConsultantCommented:
Hi Arif,

Things to try (any order):

1)  What do the Message Tracking Logs show?  Can you see the email getting delivered to the recipient's mailbox?

2)  Is this happening for all users or only some or one?  If only one, check that they don't have any rules setup that divert large emails to a different folder.

3)  As a test, send an email with a 5MB attachment with a unique subject line (something like 'df694sg6b54sbgr68498qroug') and see if you can find the email with this:

Get-MailBox | Search-Mailbox -SearchQuery 'df694sg6b54sbgr68498qroug"'

Open in new window



Thanks,

Alan.
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

Sunil ChauhanLead AdministratorCommented:
hey, get the message trace from Mail gateway, to check if the mail passing the gateway to Exchange and to which host it was submitted, as you have mentioned its working internally I don't think it is the exchange side of the issue.
Arif KhanSystem AdministratorAuthor Commented:
Since, it is happening for outbound also, I am just planning to remove the gateway for outbound mails and test. Well in the mean time, I am investigating this issue on exchange also. Your great support is really high appreciable. If you have any suggestion, kindly share.
AlanConsultantCommented:
Hi Arif,

That's a very different situation from your original post.  If they are not getting out, compared to just the incoming that you previously mentioned, then I would be looking at any devices that sit between, and including, your modem and the Exchange Server(s).

Check the logs on all of them.

Alan.
Arif KhanSystem AdministratorAuthor Commented:
Yes Alean, I just spoke with team, they said it is not working for incoming and outgoing for external users. While internally its working. I have already spoken with Logix (Message gateway provider), they said there is no issue from their end.
AlanConsultantCommented:
Okay, then definitely look at the logs for any devices in between your Exchange and Logix.

What is your setup (packet flow from Logix to Exchange)?
Arif KhanSystem AdministratorAuthor Commented:
From outside to inernal
LOGIX------>> FIREWALL----->>EXCHANGE SERVER

From internal to Ouside
EXCHANGE SERVER------>> FIREWALL---->> LOGIX---------> Out side recepient
AlanConsultantCommented:
Okay, so can you see the packets transiting the firewall in and out?

If so, can you see the messages in the Exchange Message Tracking Logs?

Alan.
Arif KhanSystem AdministratorAuthor Commented:
I tried tracing message on exchange but did not find anything. I used ECP as well as message tracker from Tool box.
Arif KhanSystem AdministratorAuthor Commented:
If you send email of 7 MB, Message will not deliver even send will not get any bounce back message. Even I am not aware where message is going
Sunil ChauhanLead AdministratorCommented:
get the full message tracking of the lost message from Logix team, that will help you to understand the next hope, i still feel its the gateway issue.
AlanConsultantCommented:
Can you try with the PowerShell command I gave above?  It should be 100% rock solid.

Also, if Logix are saying they are sending emails through to you without any problem, that will make it easier.  Ask them to send you an SMTP transaction log for an email with a 5MB attachment (maybe send it yourself from outside - Gmail or something, and give it a unique subject so that you can ask them to send you the transaction for that subject).


Alan.
Arif KhanSystem AdministratorAuthor Commented:
Unable to run the given command...

[PS] C:\Windows\system32>Get-MailBox | Search-Mailbox -SearchQuery 'BiovedaTestM
ail'
The term 'Search-Mailbox' is not recognized as the name of a cmdlet, function,
script file, or operable program. Check the spelling of the name, or if a path
was included, verify that the path is correct and try again.
At line:1 char:29
+ Get-MailBox | Search-Mailbox <<<<  -SearchQuery 'BiovedaTestMail'
    + CategoryInfo          : ObjectNotFound: (Search-Mailbox:String) [], Comm
   andNotFoundException
    + FullyQualifiedErrorId : CommandNotFoundException
[PS] C:\Windows\system32>



Logix have sent email of logs as below.............

Below are the log details:
+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
 Date 2017-11-08 12:51:11
 Sender testlogix@gmail.com
 Recipient administrator@biotik.com
 Subject Test mail with attachment at 12.21PM
 Message ID  
 Attachment  
 Delivery Type Bounce
 DSN Status 5.3.4 (message too big for system)
 DSN Dialog smtp;552 5.3.4 Message size exceeds fixed maximum message size
 Delivery IP 14.140.205.172
 Bounce Category other
AlanConsultantCommented:
Hi,

Are you able to try connecting to your server directly using telnet?  If so, please do this (can be from internal):

telnet ExchangeServerName 25

Open in new window

It should reply at which point type:

ehlo example.com

Open in new window


Please post what it returns as:  250-SIZE


I had also thought that maybe you have a Transport Rule that limits message size, but seems unlikely?

Thanks,

Alan.
Arif KhanSystem AdministratorAuthor Commented:
I  tried connecting using telnet, it is good. Please check attachment

I have already checked, there is no such transport rule, there is only two transport rule those for deleting some message.
Telnet.jpg
Arif KhanSystem AdministratorAuthor Commented:
I have gone through some Technet document, it said that Microsoft allows less 30 % of attachment of total configured size. So If I have allowed 10 MB then 10*30/100= 3 MB and then 10-3=7MB. So if I have allowed 10 MB, I will able to send only 10 MB mail size actually. I tried sending around 3 MB, it is going but 5 MB not going. So there is some configuration problem I think. .
AlanConsultantCommented:
Hi Arif,

Try changing the limits up to, say, 50MB and re-try the 5MB email.

If that works, then you know it is one of those limits that you increased.

Alan.
Arif KhanSystem AdministratorAuthor Commented:
Can you p;lease assist me how to increase the attachment limit in exchange server
AlanConsultantCommented:
Hi,

Try these one at a time so you know which one (if any) was the 'culprit' - all in PowerShell (Exchange Management Shell), changing each one back to the previous setting before changing the next.  It is a pain and slow / laborious, but it will be worth it to find where the problem is!)

Set-TransportConfig -MaxSendSize 50000000

Set-TransportConfig -MaxReceiveSize 50000000

Set-ReceiveConnector -Identity ConnectorName -MaxMessageSize 50000000

Set-SendConnector -Identity ConnectorName -MaxMessageSize 50000000


Set-Mailbox MyUserName - MaxSendSize 50000000

Set-Mailbox MyUserName - MaxReceiveSize 50000000

Open in new window


Replace 'ConnectorName' with the name of your actual connectors (use Get-ReceiveConnector and / or Get-SendConnector to list them all if you have more than one of each).

Replace My UserName with the name of the test user (Administrator?)


Alan.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Arif KhanSystem AdministratorAuthor Commented:
Is there no need to change web.config file for attachment increasing? Earlier, I had spoken with Microsoft, they also made some change in web.config file, I am not sure but they said, it must be change.
AlanConsultantCommented:
There is a change there that we can make, but maybe try the above first?
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.