New laptop browses internet, does not ping.

I just bought a new laptop, Dell Inspiron 15 7000, for my work. As I was testing everything, it was a physically working very well, so no complaints, however, when I tried to wirelessly connect to my server, it was giving me issues until I hardwired it. I was unable to ping any IP address (Local network or Google, Yahoo, etc.) and I notice that my virtual machines when run on this new laptop is doing the same thing no matter what OS (VMs running Ubuntu Server, Windows 10, Windows Server 2012, and CentOS)

Browsing through file explorer shows other PCs and servers connected, I can use Chrome, Firefox and IE to connect to a multitude of websites, however if I ping either the domain or the IP address... fails everytime.

Then I noticed that after I have installed Eve Online, it will not connect to the main server either, I ran all the port changes and fixes that I could possibly find online and everything fails.

This is a new issue that I have never experienced before, even as a network engineer, and I am completely flabbergasted at this. Any help would be greatly appreciated.
Aaron BurgessAsked:
Who is Participating?
 
AlanConsultantCommented:
Hi Aaron,

Okay - so this happens to the same machine, no matter what network you are on (home, work, client etc), and no matter whether you are connected via ethernet or wifi.

In that case, I am guessing that there might be something installed on the machine that is blocking ICMP.

First, make sure your machine is somewhere trusted (home network, behind a router for example - definitely NOT exposed directly to the internet) then:

1)  Do you have any anti-malware / ant-virus software installed? If so, please can you disable it, and then try ping again.

2)  If that does not help, do you have any third-party firewall or any other security software installed?  If so, please disable it and re-try ping again.

3)  Finally, if neither of those worked, open Windows Firewall with admin credentials, click on Actions, Properties, and turn the firewall state to 'off', then re-try ping again.


Whether any of that works or not, make sure you have re-enabled anything you have disabled.

Please post the results of those three tests.

Thanks,

Alan.
0
 
AlanConsultantCommented:
Hi,

Just to be clear - for example, you can browse to www.google.com fine, but you cannot 'ping www.google.com'?

If so, do you have anything installed on the machine, or any device between your machine and the internet, that is, or could be, blocking ICMP?

Can you ping your default gateway (generally that would be your modem / router)?

Thanks,

Alan.
1
 
Aaron BurgessAuthor Commented:
correct

here is a visual:Cmd ping
website browse
0
Network Scalability - Handle Complex Environments

Monitor your entire network from a single platform. Free 30 Day Trial Now!

 
Aaron BurgessAuthor Commented:
And this is not limited to just my network, I was working on someone else's network just after I got the new laptop and it wouldn't ping the cisco switch.

EDIT: This includes wireless and hardwire.
0
 
JohnBusiness Consultant (Owner)Commented:
Check and see if your wireless adapter put you on a Public Network. It should be Private and once Private, Network Discovery should be ON as well (Network and Sharing center).
0
 
masnrockCommented:
I noticed you're running VMs. What are the VMs running on top of? If the host is an OS, are you able to ping without issue from there?

As far as the VM with Eve Online, have you tried uninstalling it?
0
 
Jimmy Larsson, CISSP, CEHNetwork and Security consultantCommented:
A web browser uses DNS only. A DOS window can also use WINS for lookup. Verify if your DOS window can resolve www.google.com when forcing it to use DNS only, with nslookup www.google.com.

If it works with nslookup and not with the ping command you need to troubleshoot wins, or preferably turn it of totally.
0
 
Aaron BurgessAuthor Commented:
ICMP was blocked. Idk how because this is a new OS and was just pulled out of the box. Eve is on the host OS Windows 10, my VMs are Ubuntu server and CentOS, also newly installed.

Problem solved, thanks for the help!
0
 
AlanConsultantCommented:
Author confirmed ICMP was blocked.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.