Link to home
Create AccountLog in
Avatar of jskfan
jskfanFlag for Cyprus

asked on

EIGRP ping issue

User generated imageI configured EIGRP in R1 and R2 , but for some reason I cannot ping from R1 to 192.168.23.3, even though there is an EIGRP route in R1 for 192.168.23.0

1#sh run | sec eigrp
router eigrp 1
 network 192.168.12.0
R1#

Open in new window


router eigrp 1
 network 0.0.0.0
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0

Open in new window



R1#sh ip route eigrp

D*    0.0.0.0/0 [90/30720] via 192.168.12.2, 00:06:03, FastEthernet0/0
D     192.168.23.0/24 [90/30720] via 192.168.12.2, 00:06:03, FastEthernet0/0
R1#

Open in new window


I cannot ping  R3 from R1



R1#ping 192.168.23.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.23.3, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
R1#

FRom R2 I can ping:
R2#ping 192.168.23.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.23.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/19/24 ms
R2#
Screen-Shot-2017-11-09-at-8.38.50-PM.png
SOLUTION
Avatar of Hemil Aquino
Hemil Aquino
Flag of United States of America image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
SOLUTION
Avatar of Predrag Jovic
Predrag Jovic
Flag of Poland image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
SOLUTION
Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
SOLUTION
Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Avatar of jskfan

ASKER

I thought as long as the route shows in the Routing table (as shown below in Bold) means we can ping any IP within that Network:
R1#sh ip route eigrp

D*    0.0.0.0/0 [90/30720] via 192.168.12.2, 00:06:03, FastEthernet0/0
D     192.168.23.0/24 [90/30720] via 192.168.12.2, 00:06:03, FastEthernet0/0
R1#
SOLUTION
Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
SOLUTION
Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Avatar of jskfan

ASKER

- NAT traffic in ISP direction (traffic will look like it is generated by WAN IP address (or pool)

how do you configure that so that the ping reply will work ?
SOLUTION
Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Avatar of jskfan

ASKER

without the NAT:

on R1:
ip route 0.0.0.0 0.0.0.0 192.168.12.2


on R2 I configured:
ip route 0.0.0.0 0.0.0.0 192.168.23.3

on ISP:
ip route 192.168.12.0 255.255.255.0 192.168.23.2

I believe NAT is used just in case you want some Networks  on R1 and R2 to access ISP  and not all Networks

in my case I used the command below to route everything
ip route 0.0.0.0 0.0.0.0 192.168.12.2
ASKER CERTIFIED SOLUTION
Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Avatar of jskfan

ASKER

Thank you Guys
You're welcome.