EIGRP ping issue

eiI configured EIGRP in R1 and R2 , but for some reason I cannot ping from R1 to 192.168.23.3, even though there is an EIGRP route in R1 for 192.168.23.0

1#sh run | sec eigrp
router eigrp 1
 network 192.168.12.0
R1#

Open in new window


router eigrp 1
 network 0.0.0.0
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0

Open in new window



R1#sh ip route eigrp

D*    0.0.0.0/0 [90/30720] via 192.168.12.2, 00:06:03, FastEthernet0/0
D     192.168.23.0/24 [90/30720] via 192.168.12.2, 00:06:03, FastEthernet0/0
R1#

Open in new window


I cannot ping  R3 from R1



R1#ping 192.168.23.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.23.3, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
R1#

FRom R2 I can ping:
R2#ping 192.168.23.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.23.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/19/24 ms
R2#
Screen-Shot-2017-11-09-at-8.38.50-PM.png
jskfanAsked:
Who is Participating?
 
JustInCaseCommented:
NAT has few different purposes, typically not what you described above. Generally, traffic filtering by ACLs is configured for permitting of denying traffic from/to some destination IP addresses .
Static route was option two in suggestion above, however, if you are not using public IP addresses in your network typically you would have to stick to NAT option otherwise ISP may drop all of your traffic. But, anyway, solution may depend on your contract with ISP (architectural solution of network and type of IP addresses that are assigned to hosts).
0
 
Hemil AquinoNetwork EngineerCommented:
Here is an straight up answer.

That might be because you haven't configured EIGRP on R3 to advertise it's network, but I'm kind of confuse because your R3 says " I am ISP"
But anyways tell me if that's what you need.

Here is an example
In each router do the follows:

R1: router eigrp 1
 network 192.168.12.0 0.0.0.255
 no auto sumary

R2: router eigrp 1
 network 192.168.12.0 0.0.0.255
 network 192.168.23.0 0.0.0.255
 no auto sumary

R1: router eigrp 1
 network 192.168.23.0 0.0.0.255
 no auto sumary

Remember in order for routers knows about each other they need to know each routing tables. So basically you need to advertise every network in your router, or better say, the network you want  to advertise.
0
 
JustInCaseCommented:
Most likely that problem is that ISP router does not have a route to ping source network (192.168.12.0/24) and since there is no route is just dropping traffic. ISPs typically do not participate in EIGRP routing (they can for example in the case for of L3 MPLS).
Solution that can resolve routing:
- NAT traffic in ISP direction (traffic will look like it is generated by WAN IP address (or pool)
- configure static route  on ISP router to 192.168.12.0/24
- configure EIGRP on ISP router as Hemil Aquino suggested (ISPs typically do not participate in routing)
0
Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

 
Mitul PrajapatiJunior IT EngineerCommented:
Predrag is right. ISP doesn't know the return path t your network. So, do the super-netting for your entire internal network and add one route on your ISP network

ip route 192.168.0.0 255.255.224.0 fa0/0     (Supernet Address include both of your insider network)
0
 
Hello ThereSystem AdministratorCommented:
Example of basic configuration:
router.png
Do it on each router.
Plus "no auto-summary".
0
 
jskfanAuthor Commented:
I thought as long as the route shows in the Routing table (as shown below in Bold) means we can ping any IP within that Network:
R1#sh ip route eigrp

D*    0.0.0.0/0 [90/30720] via 192.168.12.2, 00:06:03, FastEthernet0/0
D     192.168.23.0/24 [90/30720] via 192.168.12.2, 00:06:03, FastEthernet0/0
R1#
0
 
JustInCaseCommented:
Routing table of R1 is used to forward traffic from R1 device. However, for return traffic rest of the network that needs to forward traffic need to know where source of ping is located (by default IP address that will be used as source of traffic is IP address of interface that is closest to destination).
If you issue on ISP router debug ip icmp and then ping from R1 you can see that pings are reaching ISP router, but since ISP router has no route to source network (192.168.12.0/24) ICMP reply will be dropped.
1
 
Hemil AquinoNetwork EngineerCommented:
As predrag stated, ISP does not participate on EIGRP unless you have L3 Routing MPLS in your environment, this is totally true.
And I'm 80% sure that you might have a confusion with routing and you thought you can communicate EIGRP with the ISP.


That's the reason why I got confused when you stated " I cannot ping  R3 from R1 " So I thought "may be" your ISP was acting as a R3 and not as a internet provider. Do you get what I am saying? hence the fact my configuration.

Now, keep in mind this.

1- ISP dont need to know about your routing, they only care to deliver your traffic via NAT
2- ISP will give a range of private address to connect to the internet, and from there you need to create an static route to leave the interface.
3- ISP has a L3 service called MPLS that will help you to route packets via routing protocols, MPLS supports the majority of them.
0
 
jskfanAuthor Commented:
- NAT traffic in ISP direction (traffic will look like it is generated by WAN IP address (or pool)

how do you configure that so that the ping reply will work ?
0
 
JustInCaseCommented:
Standard IP NAT overload configuration (+ default route so ping to loopback on ISP router can also be successful (I guess 192.168.23.3 is IP address of Fa0/0)).

On R2 configure:
interface fa0/0
 ip nat outside
!
interface fa0/1
 ip nat inside
!
access-list 110 permit ip 192.168.12.0 0.0.0.255 any
!
ip nat inside source list 110 interface fa0/0 overload
!
ip route 0.0.0.0 0.0.0.0 192.168.23.3

Open in new window

0
 
jskfanAuthor Commented:
without the NAT:

on R1:
ip route 0.0.0.0 0.0.0.0 192.168.12.2


on R2 I configured:
ip route 0.0.0.0 0.0.0.0 192.168.23.3

on ISP:
ip route 192.168.12.0 255.255.255.0 192.168.23.2

I believe NAT is used just in case you want some Networks  on R1 and R2 to access ISP  and not all Networks

in my case I used the command below to route everything
ip route 0.0.0.0 0.0.0.0 192.168.12.2
0
 
jskfanAuthor Commented:
Thank you Guys
0
 
JustInCaseCommented:
You're welcome.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.