Windows 10 HDD as an external drive by usb - Unallocated Space

This is one I have come across a few times and never did find a solution. When the hard drive that contains the operating system is removed from a Windows 10 machine and placed in a caddy or similar to be attached to a different computer (running Window 7), The drive will not show up in my computer. When accessing Storage in Computer Management the Windows 10 drive (now an external drive connected by USB) shows as unallocated space and no drive letter can be assigned. The only option is to Initialise the disk but then the data would be lost (without some serious time spent on recovery). My guess is that this is to do with the 'GPT' rather than MBR partitions that was originally the case with Windows Drives... This doesnt however explain why it wont mount in Linux either or Mac OS (even when using Fuse software etc). I did try changing the settings for the drive so that Fast Boot/Fast shutdown wasnt enabled beforte I removed it, hoping this would enable it to mount but no joy. Whilst I have tried all the major platforms this question is really about getting it to mount on a Windows 7 machione

Does anyone have an explanation for this or perhaps a solution?

Thanks so much in advance,

Lee
Lee WallisAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Jackie Man IT ManagerCommented:
Good question.

Modern computers use UEFI instead of BIOS and by default Secure Boot and disk encryption are enabled which means that the internal hard-disk will not be able to be attached in another computer to prevent theft of data.
McKnifeCommented:
That is abnormal behavior. It would mount at any time on any windows OS.
Please upload a screenshot of disk management and also the output of diskpart list volume.
McKnifeCommented:
Possibly related to your way of connecting it. USB-caddies tend to fail, while esata is stable.
Your Guide to Achieving IT Business Success

The IT Service Excellence Tool Kit has best practices to keep your clients happy and business booming. Inside, you’ll find everything you need to increase client satisfaction and retention, become more competitive, and increase your overall success.

Lee WallisAuthor Commented:
By that rationale if i were to turn off UEFI (including fast boot/secure boot etc) the device would mount. It doesnt. Even if I take a brand new Windows 10 pc setup without UEFI the problem still resides.
McKnifeCommented:
The partitioning type is not the problem.
Lee WallisAuthor Commented:
Here is the screenshot from Computer Managemnet within Windows 7. The unallocated drive is the Windows 10 drive connected by USB
ComputerManagement.jpg
KimputerIT ManagerCommented:
Agree with @McKnife, UEFI installed disks have no bearing on the mounting procedure. Foreign GPT should also give you an import message.
I suspect the caddy may be defective (or too old, not adhering to current standards), or a VERY special RAID config on the working Win10 system.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Lee WallisAuthor Commented:
Dispart List image - All looks online (Disk 1).
Diskpart.jpg
McKnifeCommented:
Definitely either a problem of the controller you are connecting it to (USB?), of the caddy itself or of the USB controller (?) driver.
Lee WallisAuthor Commented:
Thanks so much guys. As suspected nothing to do with UEFI/BIOS/Partition. Your comments got me thinking @McKnife and after Kimputer suggested the HDD caddy i was using may be older I quicly plugged it into the desktop test pc and reboted. Bam... Mounted with no problems. FYI I'm using a dock 'QuickPort Combo' and is 3-4 years old. Time to but a new one i think.

Thanks so much!!!
Lee WallisAuthor Commented:
Note: Used the QuickPort Combo on multiple devices using different OS systems with the same problem on Windows 10 drives. So must be the Device itself (quickport) rather than drivers.
Lee WallisAuthor Commented:
Speedy advice and solved a problem that had been bugging me for a while. Thanks again.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 10

From novice to tech pro — start learning today.