Proxy error connecting to HTTPS site

Hi, I have a weblogic server running with different port numbers for HTTP and HTTPS. In our workstation we setup HTTP pointing to same port in the ISSPROXY.INI file. We could access from the local IIS URL to connect to the weblogic server; but when try to connect to secured server from IIS gets 2 different errors in the event viewer Event ID 1000 and Event ID 1001. below are the errors captured

EVENT ID 1000:

Faulting application name: w3wp.exe, version: 8.5.9600.16384, time stamp: 0x5215df96
Faulting module name: iisproxy.dll, version: 0.0.0.0, time stamp: 0x59966438
Exception code: 0xc0000005
Fault offset: 0x0000000000030410
Faulting process id: 0x2514
Faulting application start time: 0x01d35a3fff6328df
Faulting application path: c:\windows\system32\inetsrv\w3wp.exe
Faulting module path: \\?\C:\xxxxxx\XXXXXXXXX\lib\iisproxy.dll
Report Id: 3dddc54c-c633-11e7-812e-005056886b10
Faulting package full name:
Faulting package-relative application ID:


EVENT ID: 1001
----------------------

Fault bucket , type 0
Event Name: APPCRASH
Response: Not available
Cab Id: 0

Problem signature:
P1: w3wp.exe
P2: 8.5.9600.16384
P3: 5215df96
P4: iisproxy.dll
P5: 0.0.0.0
P6: 59966438
P7: c0000005
P8: 0000000000030410
P9:
P10:

Attached files:

These files may be available here:



Our iisproxy.ini has the below information:
--------------------------------------------------------------

ISSPROXY.INI

WebLogicHost=ssl-server-name
WebLogicPort= ssl-port
SecureProxy=ON
WLSSLWallet=<path for wallet>

Thanks for your help in advance.
LVL 2
Shanmugam RajagopalAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Daniel_PLDB Expert/ArchitectCommented:
Hi,

Please take a look at Application event log for any warnings/errors at the time of above mentioned ones.
Have you tried to update Weblogic plugin extension? (http://www.oracle.com/technetwork/articles/wls-plugins-096117.html)

There are some support notes in Oracle support about this plugin problems, one of them is Doc ID 1970258.1:

APPLIES TO:
Oracle WebLogic Server - Version 11.1.1.7.0 to 12.1.3.0.0 [Release 11g to 12c]
Microsoft Windows x64 (64-bit)

SYMPTOMS:
IIS Proxy Plug-in crashes with Access Violation Error.

CAUSE:
This is a known issue in the IIS proxy plug-in version 11.1.1.7 and 12.1.3

SOLUTION:
Replace the old plug-in with the fixed plug-in by downloading it from My Oracle Support using patch number 18026274

Could you bring some light on versions used in your deployment? What is Weblogic version, IIS (w3wp.exe build number seems to be IIS 8.5 but I'm not 100% sure) and Windows.

If nothing obvious is in these logs and new drivers is failing I'm afraid it is necessary to look at memory dump which was generated (event 1001).

Regards,
Daniel
0
Shanmugam RajagopalAuthor Commented:
The problem was WebLogic server need TLS 1.0 to be unchecked and it worked. Tried all other options and finally this was the solution.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Routers

From novice to tech pro — start learning today.