Windows 10 Pro 1709 Build 16299.19 Remote Desktop not working

Starting today, I can no longer remote into a couple of PCs at the office.  They are both using the latest build of Win 10.  PCs on the same network, not yet upgraded to 1709, work fine. Remote Desktop Connection does not work on or off the network with or without a RD Gateway.  The problem appears only on 1709 version.  
Is there a fix for this?
botisysAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

William MillerIT SpecialistCommented:
This is a "known issue" it seems. At least, known to the people trying to use RDP with version 1709 of Windows 10. Some possible fixes have included:

- Disabling printer redirection in RDP
- Rolling back to 1703
- Installing "Remote Desktop" from the Windows App Store (Note that TSPrint has been listed to not work with this software)
0
JohnBusiness Consultant (Owner)Commented:
I have it working.  Go into Remote Desktop and turn OFF Printers and Clipboard in Local resources tab. Works fine.
0
botisysAuthor Commented:
I unchecked all the local resources and tried to connect using the RD Gateway.  Still won't connect.  
Rolling back to 1703 is not an option.  Old version has already been cleaned up.
I downloaded Remote Desktop from the Microsoft Store -- no change.
0
Acronis True Image 2019 just released!

Create a reliable backup. Make sure you always have dependable copies of your data so you can restore your entire system or individual files.

JohnBusiness Consultant (Owner)Commented:
I am connecting via VPN to machines at a client. RDP would not work at all until removing printers and then it connected
0
botisysAuthor Commented:
Using a VPN would not help.  It even fails inside the network -- PC to PC.  All the Resources are unchecked.
0
JohnBusiness Consultant (Owner)Commented:
I do not have any issues inside a client network. If no VPN why are using a gateway?
0
botisysAuthor Commented:
I've tested from inside and outside the network -- no difference.  I'm working offsite right now.
0
JohnBusiness Consultant (Owner)Commented:
Check other things possibly wrong in your system and try a different V1709 computer. I tried on two and my colleague uses his V1709 system to talk to other computers.
0
botisysAuthor Commented:
These computers have been on 1709 for at least a couple of weeks.  RDT stopped working today.
0
JohnBusiness Consultant (Owner)Commented:
Take one problem computer and do a repair install

Go to the Media Creation Link

https://www.microsoft.com/en-us/software-download/windows10

Windows 10 is running, so click on the Download button (not Upgrade Button, select Open (Run) but NOT Save. Allow the program to run. Allow drivers to update. Then select Keep Everything.

You can also Keep Data, or Keep Nothing. Keep Nothing is very close to a clean install.
0
McKnifeCommented:
Since it works without issues or modifications here, it will be probably some incompatibility with software that you use. You need to do some tests:

1 install 2 clean 1709 VMs and let them access one another via RDP - it will work.
2 join those same two to your domain - does it still work afterwards?
3 if yes, install your key software including security software - does it still work?
0
botisysAuthor Commented:
I found the solution else where.
The solution that worked was to go to Windows Defender Firewall with Advanced Security and enable the 3 newer Remote Desktop firewall rules:
Remote Desktop - Shadow (TCP - In)
Remote Desktop - User Mode (TCP - In)
Remote Desktop - User Mode (UDP - In)
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
McKnifeCommented:
You should wait with closing. These rules are not needed for standard remote desktop. They are disabled here and still, it works. Please investigate to find out what is wrong at your place. The standard rule "remote desktop", which opens up port 3389 would be perfectly enough.
0
botisysAuthor Commented:
It worked.
0
Josh RNetwork AdministratorCommented:
I was having a similar issue. My issue was after the update, I was using a remote port besides 3389. Even though the registry was correct with my new port, it didn't propagate to the Windows Firewall for some reason. I created a new rule in Windows Firewall with my correct RDP port and it worked.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Remote Access

From novice to tech pro — start learning today.